Skip navigation

External hard drive ejects on sleep

67921 Views 429 Replies Latest reply: Apr 17, 2014 6:24 PM by Lee from Cincinnati RSS Branched to a new discussion.
  • Martin Zedig Level 1 Level 1 (15 points)
    Currently Being Moderated
    Aug 15, 2012 12:49 PM (in response to OsirisIsisSeth)

    I heard that the next version 10.8.1 was released to developers with the instructions to look closer on USB amomg other things. But that wont explain my problems with diskimages being ejected. I have run some test and from what I can see even a mounted diskimage (file resides on desktop) with password saved in keychain is ejected and not remounted.

     

    I dont understand the point of ejecting stuff on a stationary mac...

    In my case its almost impossible to go on with mac like this. Thinking about ubuntu.

    They make progress and Apple is going the other way with so many "features" :-(

  • ab57 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 16, 2012 1:50 AM (in response to OsirisIsisSeth)

    Interesting experience today - got a call from a person in Apple who has now scheduled a teleconference with me to run some tests and collect some data on my Mac related to the disk issue.

     

    Not sure a certain other large software company would be that open and collaborative (IMHO) so was very impressed at the dev team's willingness to seek end user input and get informatioin to help resolve this frustration for the good of all users.

     

    Hopefully the information they are able to glean from the tests on my Mac will help pinpoint the cause, however as it seems this conversation thread is being investigated it may be helpful for those of you impacted to specifically indentify the problems with drives and/or DMGs you are having, when etc (e.g. on going to sleep, wake from sleep, random other times) and put up the information here in case Apple want to also talk to other impacted end users.


    The teleconference is not for a day or so due to my availability but will update here re the outcomes of the call.

     

    Regards

    Andrew

  • Ferri44 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 16, 2012 2:05 AM (in response to ab57)

    Same problem...

  • dynamix1 Calculating status...
    Currently Being Moderated
    Aug 16, 2012 6:43 AM (in response to ab57)

    I also received a call from Apple last night. At first I thought is was some telemarking thing but after he stated who he was and described my posts here I seemed to find this legit. He apologized to me several times for wasting my time and he seemed to be really interested in what I was saying about my problem and how I fixed it. Out of every product and every service that I have had I never received a phone call like this to address my concerns and correct the problem. I am used to these type of call when they call and say "everything is ok, thanks goodbye," but nothing like this. I am proud of all my Apple products, and I made sure that the person on the other end knew it. Now thats customer service.

  • nickditoro Level 1 Level 1 (10 points)
    Currently Being Moderated
    Aug 16, 2012 7:07 AM (in response to iamapple)

    With the release to developers of 10.8.1 and some of you getting phone calls from Apple regarding this issue, I'm hopeful it will be addressed and I can turn off Caffeine. Meantime, since Caffeine been running non-stop, my drives haven't automatically ejected.

     

    Thanks,

    Nick

  • Martin Zedig Level 1 Level 1 (15 points)
    Currently Being Moderated
    Aug 16, 2012 10:27 AM (in response to iamapple)

    Anyone that knows which logfile I might find logs about the unmounting...

  • Tenux Level 1 Level 1 (25 points)
    Currently Being Moderated
    Aug 16, 2012 10:43 AM (in response to Martin Zedig)

    wel, everyone has the same problem but no solution, why dont you just put the display on sleep but not the system? my hard drive wont eject when my mac sleep. thats weird

  • Martin Zedig Level 1 Level 1 (15 points)
    Currently Being Moderated
    Aug 16, 2012 10:47 AM (in response to Tenux)

    Ive installed caffeine now to make some tests. btw, my external drives stays mounted (or at least is there when I wake up the system/screen). But its only my mounted images that gets ejected.

     

    Can anyone else please check if thats the case for them too?

    I read a lot about external drives but not much about mounted images. It would be of great help so that I am not the only one with htis problem.

  • MrMacvos Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 16, 2012 11:03 AM (in response to iamapple)

    Same problem here with my Drobo. First I thought that the 10.6 Firewire problem was back so I switched the Drobo to USB. That worked a few nights and then, bingo! Ejected.

     

    I have not 'Put hard disks to sleep when possible' switched on. I have 'Computer sleep' set to 3 hours. Now, some days it just doesn't happen at all and then suddenly two nights in row.

     

    So, I am now going to set 'Computer sleep' to 'Never' until this is said to be fixed.

  • zbgn Level 1 Level 1 (5 points)
    Currently Being Moderated
    Aug 16, 2012 9:18 PM (in response to iamapple)

    I have a similar issue, my 3TB Firewire external that is partitioned into 3rds will unmount upon sleep. Worse part is it never comes back and trying to re-mount in Disk Utility fails. Its a 50/50 shot whether verify/repair works. I've lost many files since upgrading including photos. If I eject the disk it never comes back and if I reboot its the same as well. This is my Time Machine disk as well so I'm pretty screwed until this gets fixed if it ever does. With Lion my 27" display wouldn't work anymore due to new HDMI drivers in Lion that never got fixed, I had to go get another display.

  • Martin Zedig Level 1 Level 1 (15 points)
    Currently Being Moderated
    Aug 16, 2012 11:31 PM (in response to iamapple)

    aaaahhh, I am going crazy, On my work computer (macbook pro 2011) my mounted image does NOT eject.

    Same settings in powersettings. This is nuts.

  • Martin Zedig Level 1 Level 1 (15 points)
    Currently Being Moderated
    Aug 17, 2012 3:34 AM (in response to Martin Zedig)

    Update: caffein did not do the trick.

     

    I will make some more tests but I wonder if has anything to do with fast user switching and/or remote access via ARD. Thats the only thing that has happened today and the images has been dismounted since this morning.

  • Martin Zedig Level 1 Level 1 (15 points)
    Currently Being Moderated
    Aug 17, 2012 3:47 AM (in response to iamapple)

    EUREKA....

     

    I can reproduce my problems.

     

    - Mount a dmg in one user.

    - log in another user (in this case fast user switch)

    - The mounted dmg is unmounted.

     

    If I mount the dmg with both users logged in there is no change or unmounting.

     

    This might explain why my disks at home get unmounted since I frequently log in via ssh and/or ARD.

    I guess that that might count as a fresh/new login (especially since the 10.7 virtual desktop)

     

    phew. now I only hope that Apple read this and look in to the matter.

     

    PLEASE fix Apple...

  • mattplowman Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 17, 2012 5:08 PM (in response to iamapple)

    I had my call from Apple today and yay for me, the problem could not be reproduced. It seems that the issue disappeared a couple of days ago. Unfortunately I do not know what I did to resolve it. Caffine was installed but has since been removed. Fingers crossed it doesn't happen again.

     

    Feel a bit bad for the guy from Apple on the phone. He was understanding but I still feel like I wasted his time

  • OsirisIsisSeth Calculating status...
    Currently Being Moderated
    Aug 17, 2012 5:22 PM (in response to OsirisIsisSeth)

    Don't feel bad, and you didn't waste his time.  I was unable to reproduce the problem when the rep was on the phone, but I have been able to reproduce the issue many times since.  I have emailed the rep the diagnostic logs, so hopefully it will help them figure out what is wrong.

1 2 3 4 5 ... 29 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (38)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.