5 Replies Latest reply: Dec 24, 2014 12:38 AM by pinktoast
oscarbuzz Level 1 Level 1 (0 points)

I was rendering a slideshow of 253 pictures (approximately 4MB each) and I watched the available drive space on my MacBook Pro go from 23 GB available right down to zero.  The rendering did not finish and an error message came on the screen to let me know.  When I first clicked 'Export', I chose to save the finished slideshow to an external drive formatted for MacOS.  I also chose to save it as 1080p QuickTime .mov file.

 

This is my first time using Aperture and am puzzled as to why it used up that much drive space in my MacBook Pro.  I thought that it was hanging on to some unfinished render files so I quit Aperture and restarted my MacBook Pro but now I only see that I regained about 2 GB out of my original 23GB.

 

Is it correct for me to assume that there are cache files or temporary files still present somewhere?  If so, please tell me where so I can delete them and restore my available internal drive space on my MacBook Pro to 23 GB again.

 

Why did it use up so much of my internal drive space when I actually told Aperture to save the finished slideshow file to an external drive?

 

Please help.  Thanks.


MacBook Pro, Mac OS X (10.7.4), 15-inch early 2008, 4 GB SDRAM
  • léonie Level 9 Level 9 (63,990 points)

    Aperture has two cache directories that uses regularly

    1. In your user library: ~/Library/Caches/com.apple.Aperture/
    2. At System Level: There are temporary file written to a hidden area, that you can open from the Terminal by referring the system varaiable $TMPDIR.
      Open a Terminal window and enter the following command:
               open $TMPDIR

      This will open a terminal Window showin this hidden cache. I found the partially rendered movies in a subfolder called something like "TemporaryItems"

     

     

    Why did it use up so much of my internal drive space when I actually told Aperture to save the finished slideshow file to an external drive?

    The final movie will be saved to the destination you named, but Aperture needs working space for partial renderings and as much RAM as it can get. The OS will swap other applications to a swapping area of the ystem drive to free RAM for Aperture.

    Another problem could be that the destination drive you want to write to temporarily went offline. Then aperture will write to $TMPDIR instead. Check the permissions on your external volume and the connection. Is it a Network volume? This is risky, of you need a stable connection for a long render time. In that case connect the external volume directly.

     

    Regards

    Léonie

  • oscarbuzz Level 1 Level 1 (0 points)

    Hi Léonie.

     

    First of all, thank you for your reply.

     

    I tried your first suggestions but there was no "com.apple.Aperture" file inside the Library/Caches folder.

     

    When I did your second suggestion, the resulting window after I typed in "open $TMPDIR" revealed 4 folders: (1) etc, (2) tftpboot, (3) tmp, and (4) var.  I looked into all 4 of them (including their subfolders) but did not find anything that could look like the temporary render files that I can delete to free up several GB of internal drive space.

     

    What if I deleted ALL 4 FOLDERS?  They are temporary files anyway, right?  Will I create new problems if I do so?  Wouldn't the system just create new temp files every time I use an application?

     

    Also, I am running OS X 10.7.4 right now.  What if I upgraded to Mountain Lion?  Would this free up the missing GB of internal drive space?

     

    Is there anything in Disk Utility that I can do that could help with this problem?

     

    Thank you again.

     

    Mario

  • léonie Level 9 Level 9 (63,990 points)

    Mario,

    on no account touch the folders (1) etc, (2) tftpboot, (3) tmp, and (4) var at that level - that are important system files and install locations,

    I cannot check this on Lion right now, the $TMPDIR is a folder at a deeper nesting level of the var folder, at least on my Mt. Lion system. And the temporary items have random names for security reasons, so malware cannot guess the names.

     

    Here is what I see: the caches for my user account are in

    /var/folders/qt/dm6q98q95tdf3lv6wdxwb67m0000gp/T/TemporaryItems

     

    tmpdir.png

  • léonie Level 9 Level 9 (63,990 points)

    I just remembered - sometimes Aperture also write to /tmp, if the connection to a volume gets lost.

     

    Type into your Terminal

         open /tmp

    to browse this folder, but do not delete anything, that you do not clearly recognized as being produced by Aperture.

  • pinktoast Level 1 Level 1 (0 points)

    Hi there,

     

    I am on Yosemite and the suggestions worked for me.

    But there were no files in the user library, but in the folder opened with terminal. But there I had to dig deeper by finding the Aperture folder (which was a lot bigger than the other folders) and then sorting by file size. Finally there were some videos created by exporting to an eternal drive.

     

    Deleted them successfully.

     

    Thanks a lot.