3 Replies Latest reply: Sep 22, 2012 8:15 AM by johoba
dansmacbook Level 1 Level 1 (0 points)

I have a late 2011 17" MBP and did a clean install of 10.8.  Ever since that time, I am unable to maintain a useable connection to certain access points.  At first it seemed like the internet was slow, but eventually pages loaded and I didn't think too much of it.  But then I started accessing lots of files on my home server (OS 10.6.8 Server) and the Finder was beachballing with nearly every click.  I plugged in an ethernet cable and all the problems went away.  Went back to wireless, the beach balls and sluggishness came back.  Then I rebooted to my 10.6.8 partition and connected and used the network just fine on the wireless, as I had been for years before on this MacBook and my previous MBP.

 

After searching through forum posts I saw that some people were blaming this Mountain Lion bug on whatever runs the 5Ghz connections.  So I forced my MBP to connect to the 2.4Ghz radio.  While I did have one glitch (a video didn't play smooth over the network initially) it has basically been solid ever since. Yesterday I spent the day at a client where I run the network and my 5Ghz problems came back.  I would have to power cycle the Airport to get the connection useable again.  Both my home network and this client's are running with Ruckus Wireless ZoneFlex 7363 access points.  At home I also have an Airport Extreme from a few years ago that I use as a router with wireless disabled.  I turned that on and while I didn't really use it for all that long, it seemed to work at 5Ghz--but I didn't really use it that long and need to do more testing.

 

My exact setup:

1) Clean install of 10.8

2) Late 2011 MBP 17"

3) Ruckus Wireless ZoneFlex 7363 firmware 7.3.x

 

I hope this is fixed soon or someone discovers a workaround.


MacBook Pro, OS X Mountain Lion
  • 1. Re: Mountain Lion WiFi: Major Problem
    rvinny Level 1 Level 1 (0 points)

    +1 -- I'm basically in WiFi h*ll since upgrading. 10.8. Injected all sorts of issues on my network and devices where 10.7 was rock solid. Mid 2009 15" MBP dropping connections on Linksys E4200 at 5GHz. If I switch to 2.4 GHz, no issues. At home I have an Airport Extreme running 2.4 and 5Ghz. I am experiencing drops on 5GHz there as well. I upgraded to 10.8 instead of a clean install, but from reading the forums that doesn't work either.  I have a Mac Mini that is wired and no problems.

     

    A couple of other interesting pheneomenons since upgrading;

     

    new model Airport Express: 

    I bought one the same day as upgrading to 10.8 and immediately encountered issues setting up the AP to extend the Airport Extreme network on 5GHz (kept returning "encountered unkown errror" when writing the configuraiton to the AP). I had to use the old 5.6 Airport Utility to get it to save and 2.4GHz to keep devices from losing their connections. Other weird thing is the 'Back to My Mac' icon on the Airport Express stays yellow where the Airport Extreme turns green.

     

    new model Apple TV 3:  

    Flawless prior to upgrade day. Now, no longer works on either frequency. Started with dropping Home Sharing connections, then progressed to losing WiFi altogether. It won't even run on the ISP provided router at this point. If I do a reset or a full restore in iTunes, it works for about 5 minutes and then drops the connection and resets itself to the main screen with only a 'Settings' and 'Computers' icon.

     

    I know, possilby conincidences and unrelated but curious issues for sure. I've pulled out each piece and tried to see where the problem returns but no luck. I have recommended and deployed a lot of Apple devices over the years and this is the first time I've ever had problems. One family member seems to be having a similar issue with a new Apple TV3, Airport Extreme and iMac on 10.8 combination. A little embarrassed for having made those recommendations now. The only thing that solves it for me is rolling back to 10.7

  • 2. Re: Mountain Lion WiFi: Major Problem
    softwater Level 5 Level 5 (5,370 points)

    This fix seems to be working for most people experiencing wifi issues with ML:

     

    http://osxdaily.com/2012/08/02/fix-os-x-mountain-lion-wireless-connection-proble ms/

  • 3. Re: Mountain Lion WiFi: Major Problem
    johoba Level 1 Level 1 (0 points)

    This fix worked! My 5GHZ wifi is working great! Thanks alot!