Previous 1 2 Next 22 Replies Latest reply: Apr 7, 2015 7:37 PM by barbielee
LownoteNB Level 1 (0 points)

I would like to make my User Library folder permanently visible since it has much useful information that I consult.  Many sources have recommended you insert     chflags nohidden ~/Library/     into a Terminal window to make this change.  I was able to do this successfull in Lion.

 

However, in Mountain Lion, Terminal responds with Permission Denied when I do this.  Does anyone know what I need to do to make the command work?

 

Thanks.


iMac (27-inch Late 2009), OS X Mountain Lion
  • Jiri Krecek Level 4 (1,070 points)

    put "sudo" in front of the command above

    it will prompt you for  admin password

  • Tuttle Level 7 (29,470 points)

    Easiest way to do this is to option-click the Go menu in Finder and choose Library. When it opens, drag the Library folder into Finder's sidebar and it will always be available.

  • soehn Level 2 (195 points)

    Try to add a sudo before the command:

    sudo chflags nohidden ~/Library

  • Jiri Krecek Level 4 (1,070 points)

    sudo is SUPER USER DO and executes any command behind it at a root level.

    Watch out with using it for other commands.

    You can do a lot of harm when using it and bring your Mac to a state of FUBAR

     

    For this reason, Apple has hidden the Library folder.

  • LownoteNB Level 1 (0 points)

    Thanks.  Worked like a champ!

  • ag2231 Level 1 (5 points)

    I am logged in as 'Root' so at the prompt sh-3.2# I should only have to type:

     

    sh-3.2#  chflags nohidden ~/Library/

     

    When I do this I am not given any errors and I am taken bake to the prompt with one exception, the "Library" remains invisible. Any ideas why the library is not becoming visible?

  • markwmsn Level 5 (5,572 points)

    If you are logged in as "root", then you are changing root's ~/Library, not your own. Is that what you intended?

  • Jiri Krecek Level 4 (1,070 points)

    As markwmsn pointed out, this may be your case. If you are logged as root, then you are changing root's library flag and not your own. Unless root is the only user you are using on this Mac, I don't see a reason why you should log into the machine as root.

     

    Would this work?

     

    chflags nohidden /Users/username/Library/

     

    where "username" would be the user you are trying to show the library for.

     

    Otherwise, I'm out of ideas. :-(

  • Jiri Krecek Level 4 (1,070 points)

    Spoke too soon.

    One more idea crept in

     

    If/when you get the shell script working save it in Automator as an application and fire it as a Startup Item upon login. I just tested mine and it works flawlessly. Again, this will only work, if the shell scipt works in terminal.

     

    I am logged in as a non-root user with admin privileges and pon running the script, library immediately appears or disappears, without prompting me for root password or using sudo.

     

    If you are logged in as admin into OS X and the scipt still doesn't yield results, then I'm afraid something may be wrong with your OS X instance.

  • ag2231 Level 1 (5 points)

    Duh, completely slipped my mind, thanks for the reminder both Markwmsn and Jiri Krecek. Obviously just performing this command as "SUDO" works fine. Sometimes when you always use root for the heavy lefting you forget to just keep it simple like with sudo.

  • Jiri Krecek Level 4 (1,070 points)

    If you want to have this fast, consider creating those apps in Automator to run this shell script.

    I tested them both to hide and unhide the Lib and it really works like a charm

  • DouglasRibeirao Level 1 (0 points)

    Perfect!!      tk`s friend 

  • skillet Level 1 (5 points)

    One thing I had to do to get this to work was to create another administrator user and then go to the disc permissions and repair them there.  It wasn't working for some reason from my admin I was logged into typing in my password.  After doing that and logging back in and runing sudo chflags nohidden ~/Library and typing my password solved the problem and the library folder showed up.

  • DouglasRibeirao Level 1 (0 points)

    Work`s  tks

Previous 1 2 Next