Previous 1 2 Next 15 Replies Latest reply: Jul 4, 2015 3:25 PM by dh-one
IngallsBL Level 1 Level 1 (0 points)

My iMessage is offline and when I try to switch it it online it won't change.


MacBook Pro, OS X Mountain Lion
  • tarekfromalexandria Level 1 Level 1 (5 points)

    i had the same problem it looks inactive always

  • Ralph Johns (UK) Level 9 Level 9 (69,740 points)

    HI,

     

    I see 17 others have marked this as having the same issue.

     

    When you start Messages for the First Time it asked for a Apple ID to link/register with iMessages.

     

    When that is done you tend to see the Messages main window

    It is a combined Interface and Chat window.

     

    Other than going to the Messages Menu > Preferences > Accounts and checking the iMessages account is enabled there is no way to tell you are "On Line" in iMessages on it's own.

     

    If you enable the Bonjour account (everyone gets this one) then you get A Buddy List (See the Window Menu > Buddies CMD +1)

    This can be set for Status and Status Messages.

    Of course you can Add names Valid with AIM and Jabber IDs (these include GoogleMail IDs)

    The Buddies List is then a combined list and can be separated in the General section of the Preferences.

     

     

    Essentially the Messages Window sits there doing nothing.

    You have to click the New Message icon, then either type a name in the "To" spot or use the Blue + icon top right and chose Buddy and iMessages contact (iPhone number or Apple ID email registered with iMessages) - Or choose the Buddies List.

     

     


    10:11 PM      Saturday; September 22, 2012


    Please, if posting Logs, do not post any Log info after the line "Binary Images for iChat"

     

      iMac 2.5Ghz 5i 2011 (Mountain Lion 10.8.2)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),
     Couple of iPhones and and iPad

    "Limit the Logs to the Bits above Binary Images."  No, Seriously

  • elmwoodestate Level 1 Level 1 (0 points)

    Hi Ralph,

     

    Its clear that you really know your stuff and I can see where you resolved so many issues here. My wife and I travel extensively and we use my iphone 4 and her iphone 4s to exchange imessages. When moving from, Say Oman, to the UK for example, I'll change out my Omantel sim for an O2 sim and imessage works for us as long as we have a data package at each end. Recently we have begun to have a lot of problems using imessage in Oman or in other places. We visited our service provider today and they told us that it is probalby the software. I am not so sure because we both have relatively recent updates. Can you let us know your opinion regarding the recent problems w imessage? I am wondering if the networks are realizing that they are loosing revenue fomr texts this way and purposely acting to make life difficult for imessage users. Any advice you can offer us to remedy our issue?

     

    Otherwise thanks for helping so many people and have a good day.

     

    Chris and Anita

  • Cris0101 Level 1 Level 1 (0 points)

    Hi

     

    I'm trying to log in but I keep getting this message "the server encountered an error processing registration. PLease try again later." I've tried several times and days.  I still get this message.  Do I need to change anything?

     

    Thanks!

  • Ralph Johns (UK) Level 9 Level 9 (69,740 points)

    Hi,

     

    I don't know so much about the iPhones general use.

     

    However it is fair to say that when iChat went AV it uses the SIP process to connect calls.

    This technically uses one of 4 ports start with 5060.

    It is also supposed to Internationally Agreed that ISPs and the people running the internet backbone will not interfere with data on these ports.

     

    As many ISPs were originally telcom companies we soon found that there were issues with iChat using Port 5060 along with other VoIP adapters like Vonage and similar.

    It did seem that some ISPs took to blocking the ports then charging for an "Extra Service" when they realised they were losing out on Long Distance call traffic.

     

    At iChat 4 Apple changed to using SIP on port 16402 (as first choice)

    Skype uses SIP as well but uses their own ports and also has not used the dedicated ports either.

     

    I would not be surprised to hear that some carries are blocking iMessages.

     

     

    On the other hand this Apple Doc suggests the ports iMessages uses should not cause an Issue

    http://support.apple.com/kb/HT4245

     

    Enable port forwarding on the following ports to use FaceTime and iMessage on a restricted network.

    Ports

    FaceTime

    iMessage
    80 (TCP)
    443 (TCP)
    3478 through 3497 (UDP)-
    5223 (TCP)
    16384 through 16387 (UDP)-
    16393 through 16402 (UDP)-

     

    Port 80 is used for Web Browsing

    Port 443 is used for Secure sites like the Logging Page here at Apple Support Communities and Bank.

    Some emails use it.

    iChat 6 and Messages use this to log in to the AIM Servers (we were recommending using this port for years)

     

    Port 5223 is a Jabber port (normally)

    If you have a GoogleTalk name then it will login on this port in iChat or Messages.

     

    iMessages is only part of what Messages does.

     

    This Doc lists th iChat 3 ports

    http://support.apple.com/kb/HT1507

     

    This lists AIM, Jabber and Bonjour Ports as well as the A/V ports.

    The OS X 5 doc about using iChat behind a Firewall or NAT router (Artnum=306688 has disappeared) It should the reduced A/V ports but failed to show the Bonjour and Jabber or AIM ports.

    Despite HT1507 being updated in July it does make make note of that or the Messages ports (Where the AIM Login has changed.

    (It is fair to say though that port up to port 1024 are normally open in a router anyway).

     

    That said there are still some parts of the Middle East that seem to manage to block iChat and Messages as a whole.  (some countries have different results depending on Western Business parks and Housing compounds and ISPs used)

     

     

     

     

     

     


    9:11 PM      Tuesday; September 25, 2012


    Please, if posting Logs, do not post any Log info after the line "Binary Images for iChat"

     

      iMac 2.5Ghz 5i 2011 (Mountain Lion 10.8.2)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),
     Couple of iPhones and and iPad

    "Limit the Logs to the Bits above Binary Images."  No, Seriously

  • Ralph Johns (UK) Level 9 Level 9 (69,740 points)

    hi Cris0101,

     

    This one seems to have several causes.

    This in turns means there is no one answer to fix the issue.

     

    Try the following one at a time.

    1) Try and basic plain Restart of the Computer

    2) Try a PRAM reset.

    Shut down the computer.

    Restart it holding down Apple/CMD ( or ⌘)+ALT( ⌥)+P+R Keys until you have heard three Start Up Bongs.


    PRAM Keys

     

    3) Try Safe Mode and see if you can then Log in.

     

    4) Open Activity Monitor and use the app to Force Quit imagent. Highlight the item then use the Quit button and confirm Force Quit.

     

    5) In System Preference > Network > your connection Method > Advanced Button > DNS tab add 8.8.8.8  and 8.8.4.4 as Public DNS servers (Some DNS servers seem to have trouble finding the iMessages and FaceTime Servers (two different ones).

     

    If these do not work we may have to dig deeper.

     

     

     

     

     


    9:20 PM      Tuesday; September 25, 2012


    Please, if posting Logs, do not post any Log info after the line "Binary Images for iChat"

     

      iMac 2.5Ghz 5i 2011 (Mountain Lion 10.8.2)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),
     Couple of iPhones and and iPad

    "Limit the Logs to the Bits above Binary Images."  No, Seriously

  • Ernesto1331 Level 1 Level 1 (0 points)

    Ralph,

     

    I can't get to work my iMessage on my MacBook Pro.

     

    I've done what you suggested in this message but still doesn't work.

    Any other thoughts???

  • Ralph Johns (UK) Level 9 Level 9 (69,740 points)

    HI,

     

    Many things have changed in Messages since this Thread started.

    There have been at least 2 if not three OS updates and one to Messages and another that was supposed to have changed something in a support app.

     

    What sort of Apple ID do you have ?

    External email ?

    @mac.com ?

    @me.com ?  (Issued by iCloud)

    @iCloud.com also issued by iCloud.

     

    If you have an expired @me.com ID from Mobile Me then it may not work due to changes in security checks Messages makes.

     

    It is late where I am and it will be a while until I reply again.

     

     

     

     

    3Sigcopy2.png
    10:11 pm      Wednesday; September 11, 2013

     

      iMac 2.5Ghz 5i 2011 (Mountain Lion 10.8.4)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),
     Couple of iPhones and an iPad

    "Limit the Logs to the Bits above Binary Images."  No, Seriously

  • Jczuba Level 1 Level 1 (0 points)

    Wow!  that was easy! Thanks ralph!

  • Ralph Johns (UK) Level 9 Level 9 (69,740 points)

    You're Welcome.  ( am not sure what for as this thread is so old).

     

     

    3Sigcopy2.png

    7:45 pm      Tuesday; September 23, 2014

     

      iMac 2.5Ghz i5 2011 (Mavericks 10.9)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),
     Couple of iPhones and an iPad
  • Danie! Level 1 Level 1 (0 points)

    Go into to the Messages Menu > Preferences > Accounts > select iMessage from the list of accounts and sign in with your Apple ID and password.  After signing in, the "Enable this account" check box will be selected and your iMessage will be online.

  • Ash Lee Level 1 Level 1 (0 points)

    Help! I’ve tried all the suggestions above, trying to get my iMessage on my Mac and iPhone to sync like they used to, but nothing seems to be working. This all used to sync just fine, but recently has stopped. When I click Available on my iMessage on my Mac computer— it still shows Unavailable and won’t change. The only thing that will allow me to appear as Available is if I enable Bonjour. Bonjour is something I have never heard of. Is that what needs to be enabled to get my items synced again?

    Thanks for any help.

    I’m not technology savvy and I may be asking really stupid questions, but I thought it couldn’t hurt to at least ask.

  • Sam Pilkey Level 1 Level 1 (0 points)

    I had the same issue this morning! This worked for me:

     

    When iMessage is open, click on Messages (beside File, Edit etc.)

    Click Preferences.

    Go to Accounts.

    Select your iCoud account/Apple ID on the left side and then select Enable this Account.

     

    Hope this helps!

     

    Sam

  • Ralph Johns (UK) Level 9 Level 9 (69,740 points)

    Hi,

     

    Messages is built from the iChat App.

    Some of the Menu items, including the Status option, only refer to Buddy List accounts (AIM, Jabber which includes Google, Yahoo and Bonjour - all the ones in iChat before the change to Messages)

     

    The Bonjour Account uses the Computer name (see System Preferences > Sharing) and the name in the My Card (See Contacts App > Card Menu >  Show My Card) as the way of finding other Macs on your LAN that are also using iChat or Messages with the Bonjour account active - the My Card supplies the Name the other see you as in their Buddy List)

     

    At one time Bonjour was called Rendezvous but you would have to go back 15 years to iChat version 1 for that.

     

    Bonjour has nothing to do with iMessages and certainly not the Syncing.

    iCloud also has nothing to do with iMessages. That is to say there is nothing in System Preferences > iCloud that refers to iMessages and it does not matter if the iCloud part is logged in or not.

    You might use and Apple ID that is also an iCloud ID  but it is the iMessages servers that check your password is the one to go with the ID.

     

    NOTE it is best that the FaceTime App and iMessages use the same ID so that you can swap between text chatting and Video or Audio Chatting.

    However the iCloud ID and iTunes and the one for Messages/FaceTime can all be different.

     

    Check these details.

    On the iPhone > Settings > Messages check the Send And Receive section.

    This should list the iPhone Number as a greyed out but Ticked option (i.e you can't access it but it should be ENABLED).

    In addition the Apple ID used on the Mac should be listed.

     

    I have had the situation where the iPhone number has somehow been disabled and I have not been able to change it.

    The iPhone only "sees" sync version of iMessages to the Apple ID.

     

    If this is the case remove the Apple ID.

    Set the iPhone to Airplane mode for a few minutes (to break with the servers)

    Go back to the Messages settings and check the iPhone Number verifies (you might find you have to turn Messages On)

    When that is done check you can send an iMessage to the Apple ID (Mac) and that a return iMessages (to the iPhone Number Only) can be sent.

    When this works Add the Apple ID to the iPhone settings.

     

     

    3Sigcopy2.png

    8:28 pm      Monday; January 19, 2015

     

      iMac 2.5Ghz i5 2011 (Mavericks 10.9)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),
     Couple of iPhones and an iPad
Previous 1 2 Next