14 Replies Latest reply: Oct 17, 2012 12:08 PM by Richard E. Cooke
Chris-UK Level 1 (0 points)

Hi

 

Since moving from HDD to SSD and Lion to ML I am getting loads of these errors in my System Log

 

Mail(1739) deny file-read-data /Library/Preferences/com.apple.mail.plist

 

I am not experiencing any end issues as a result but notice I am getting 6 every second which must be causing an issue

 

The details are:

 

Mail(1739) deny file-read-data /Library/Preferences/com.apple.mail.plist

 

Process:         Mail [1739]

Path:            /Applications/Mail.app/Contents/MacOS/Mail

Load Address:    0x10f773000

Identifier:      com.apple.mail

Version:         1485 (6.0)

Build Info:      3-Mail~1485000000000000

Code Type:       x86_64 (Native)

Parent Process:  launchd [237]

 

Date/Time:       2012-08-05 11:54:01.392 +0100

OS Version:      Mac OS X 10.8 (12A269)

Report Version:  8

 

Thread 0:

0   libsystem_kernel.dylib            0x00007fff8c9d5fee __open + 10

1   CoreFoundation                    0x00007fff8c12a588 __33-[CFPrefsPlistSource synchronize]_block_invoke_0 + 296

2   CoreFoundation                    0x00007fff8c125f07 withDaemonConnection + 87

3   CoreFoundation                    0x00007fff8c12a36c -[CFPrefsPlistSource synchronize] + 316

4   CoreFoundation                    0x00007fff8c1291a1 -[CFPrefsPlistSource synchronizeIfStale] + 113

5   CoreFoundation                    0x00007fff8c12927a -[CFPrefsPlistSource copyValueForKey:] + 42

6   CoreFoundation                    0x00007fff8c128213 -[CFPrefsSearchListSource copyValueForKey:] + 131

7   CoreFoundation                    0x00007fff8c124080 __CFPreferencesCopyAppValue_block_invoke_0 + 32

8   CoreFoundation                    0x00007fff8c1277e8 +[CFPrefsSearchListSource withSearchListForIdentifier:perform:] + 824

9   CoreFoundation                    0x00007fff8bffd67a CFPreferencesCopyAppValue + 186

10  Foundation                        0x00007fff8ccb7db0 -[NSUserDefaults(NSUserDefaults) objectForKey:] + 22

11  Foundation                        0x00007fff8ccb7c97 -[NSUserDefaults(NSUserDefaults) boolForKey:] + 23

12  AddressBook                       0x00007fff92932d8b ABDLog + 290

13  AddressBook                       0x00007fff92935eda -[ABSafeNotificationEntry reflectNotification:] + 63

14  AddressBook                       0x00007fff92935cf1 -[ABSafeNotificationReflector reflectNotification:toEntryIfElligible:] + 72

15  AddressBook                       0x00007fff92935c72 __50-[ABSafeNotificationReflector notificationFunnel:]_block_invoke_0 + 37

16  CoreFoundation                    0x00007fff8c0597d9 __NSSetEnumerate + 985

17  AddressBook                       0x00007fff92935c26 -[NSSet(ABSetAdditions) _abEach:] + 91

18  AddressBook                       0x00007fff92935ad3 -[ABCopyOnWriteSet useReadOnlySet:] + 44

19  AddressBook                       0x00007fff92935a9e -[ABCopyOnWriteSet each:] + 91

20  AddressBook                       0x00007fff92935a1e -[ABSafeNotificationReflector notificationFunnel:] + 181

21  CoreFoundation                    0x00007fff8bff5b8a _CFXNotificationPost + 2554

22  Foundation                        0x00007fff8ccb7a76 -[NSNotificationCenter postNotificationName:object:userInfo:] + 64

23  Mail                              0x000000010f7757d5

24  CoreData                          0x00007fff88968e64 -[NSManagedObjectContext(_NSInternalAdditions) _didSaveChanges] + 2132

25  CoreData                          0x00007fff88958589 -[NSManagedObjectContext save:] + 1241

26  Message                           0x00007fff88d3e755 -[SeenMessagesManager saveChanges] + 46

27  Message                           0x00007fff88d372f6 -[POPStore fetchSynchronously] + 2175

28  Message                           0x00007fff88d2edd2 -[POPAccount fetchSynchronously] + 140

29  CoreFoundation                    0x00007fff8c036cac __invoking___ + 140

30  CoreFoundation                    0x00007fff8c036b47 -[NSInvocation invoke] + 263

31  CoreMessage                       0x00007fff8b271d5d -[MonitoredInvocation invoke] + 225

32  CoreMessage                       0x00007fff8b28a2b2 -[ThrowingInvocationOperation main] + 33

33  CoreMessage                       0x00007fff8b236602 -[_MFInvocationOperation main] + 431

34  Foundation                        0x00007fff8ccfdbb6 -[__NSOperationInternal start] + 684

35  Foundation                        0x00007fff8cd053d1 __block_global_6 + 129

36  libdispatch.dylib                 0x00007fff8cc5ef3d _dispatch_call_block_and_release + 15

37  libdispatch.dylib                 0x00007fff8cc5b0fa _dispatch_client_callout + 8

38  libdispatch.dylib                 0x00007fff8cc5c23e _dispatch_worker_thread2 + 304

39  libsystem_c.dylib                 0x00007fff8c361ceb _pthread_wqthread + 404

40  libsystem_c.dylib                 0x00007fff8c34c1b1 start_wqthread + 13

 

Binary Images:

       0x10f773000 -        0x10fb0fff7  com.apple.mail (6.0 - 1485) <6C62E4AC-EBA9-3E31-B677-B26356423DE1> /Applications/Mail.app/Contents/MacOS/Mail

    0x7fff88914000 -     0x7fff88b32fff  com.apple.CoreData (106 - 407.5) <45EF39FE-7FD6-366E-BB5C-3E86E0B7DA3C> /System/Library/Frameworks/CoreData.framework/Versions/A/CoreData

    0x7fff88bc2000 -     0x7fff88e08ff7  com.apple.MessageFramework (6.0 - 1485) <79FA27A2-D01A-3D35-AE3A-7F8F41034728> /System/Library/Frameworks/Message.framework/Versions/B/Message

    0x7fff8b20c000 -     0x7fff8b2c4ff7  com.apple.CoreMessage (1.0 - 1485) <1210621B-BABB-3153-A8DF-DAC0FA671D05> /System/Library/PrivateFrameworks/CoreMessage.framework/Versions/A/CoreMessage

    0x7fff8bfb0000 -     0x7fff8c199fff  com.apple.CoreFoundation (6.8 - 744) <47AEA7C7-EF9B-3FC6-AEBF-CE02FC650301> /System/Library/Frameworks/CoreFoundation.framework/Versions/A/CoreFoundation

    0x7fff8c34b000 -     0x7fff8c417fef  libsystem_c.dylib (825.24) <16B6B86C-53EE-36E8-AC2B-4AADC1008098> /usr/lib/system/libsystem_c.dylib

    0x7fff8c9c4000 -     0x7fff8c9dfff7  libsystem_kernel.dylib (2050.7.9) <E0447BF5-E104-35B0-B28B-4156887D58F1> /usr/lib/system/libsystem_kernel.dylib

    0x7fff8cc59000 -     0x7fff8cc6eff7  libdispatch.dylib (228.18) <0B6B6E7F-4D8A-3F3B-A4BF-6CF34638DBBB> /usr/lib/system/libdispatch.dylib

    0x7fff8cc6f000 -     0x7fff8cfcbff7  com.apple.Foundation (6.8 - 945) <0C972F73-0C07-3384-98F2-B176E0289494> /System/Library/Frameworks/Foundation.framework/Versions/C/Foundation

    0x7fff92926000 -     0x7fff92be1fff  com.apple.AddressBook.framework (7.0 - 1143) <EC55CF4B-4194-3163-B6E1-8C8D2712FBCF> /System/Library/Frameworks/AddressBook.framework/Versions/A/AddressBook

 

Any wise wisdom?

 

Thanks, Chris.


MacBook Pro, Mac OS X (10.7)
  • clintonfrombirmingham Level 7 (30,000 points)

    I don't know that it's a ML or SSD issue - I'm running both and not seeing that problem with Mail (although I admit that I seldom use Mail).

     

    Have you tried just deleting com.apple.mail.plist? It sounds as if maybe pemissions are screwed up on that one file...

     

    No real wisdom...

     

    Clinton

  • Chris-UK Level 1 (0 points)

    Did what you said and deleted and its fine now.

    Any ideas whats in the plist file? backed it up just incase :O)

    Thanks for your help.

    I used Superduper to migrate my HDD to SSD and think it could be something there with a permissions copy?

  • clintonfrombirmingham Level 7 (30,000 points)

    plists are just preference files left over from the NeXTStep days... you can edit them if you know what you're doing. And you can delete them and they will re-generate (hopefully with the right permissions!).

     

    I've never used SuperDuper so I don't know how it works really. You might have just had permissions screwed up on one file - no big deal if everything else is running fine.

     

    Glad I could help - makes me feel good!

     

    Clinton

  • Wout Mertens Level 1 (0 points)

    Yup deleting it solved it for me too. This is the new sandboxing of 10.8 at work, I'm guessing that it doesn't have access to the legacy file and deleting it allows it to recreate where it should be.
    The file doesn't contain anything interesting anyway (checked with "defaults read /Library/Preferences/com.apple.mail").

  • smittyrocks Level 1 (10 points)

    didn't work for me, after deleting the plist, it did regenerate due to a Mail plugin I have but I still get the error in the activity log.

  • smittyrocks Level 1 (10 points)

    Disregard previous post. I was in the wrong library folder. Deleted the plist from the proper library folder and my error is gone as well. Thanks for the fix.

  • Kiwi Graham Level 4 (1,850 points)

    Same issue here - except I noticed it because all of a sudden my disk cloning operation had an extra 50GB of changed data to copy. So this error was causing many many log files in /private/var/log/asl

     

    I'm wondering if it's due to a perference edit I did for Mail at one stage when a bundle ID had to be updated for Mail Act-On?

     

    Anyway, I have deleted that preference file now and Mail has not recreated it. Console messages seem to have dried up

  • Dieter Nuyens Level 1 (0 points)

    I had the same issue.

    Deleting this .plist file solved my problem, but to do so I had to make invisible files visible first because I could't find any com.apple.mail.plist file at all. After unhiding using "defaults write com.apple.Finder AppleShowAllFiles YES" in the terminal I was able to delete this file and problem solved.

  • clintonfrombirmingham Level 7 (30,000 points)

    Next time, no need to delete from Terminal - use the free "EasyFind" - available from the App Store. It finds everything, hidden or not.

     

    Clinton

  • PierG Level 1 (0 points)

    Same issue and resoved the problem

    Thanks

     

    PierG

  • Michael Prewitt Level 1 (15 points)

    The .plist files are almost always preferences. I believe "plist" is short for "property list". It contains a list of keys (configuration options) and settings for each key, similar in some respects to the way the Windows Registry works, except that there is a separate file for each set of settings, instead of a single registry file as in Windows. In this case it's a shared settings file for Mail, but I couldn't tell you anything more about the contents.

     

    You were smart to back it up. Usually .plist files can be deleted without signicant loss, because they will be recreated automatically with default settings. But sometimes they contain important settings that may be hard to set up again, especially if you had help setting up your computer in the first place, or have lost important details that you'd need for setting up an app, such as Mail. But sometimes the settings are trivial, for example the position and size of windows, etc., and do not contain settings you'd care about, which may be in another .plist file or in some other kind of file/database.

  • Burke102 Level 1 (0 points)

    This solved it for me also. Thank you!

  • Richard E. Cooke Level 2 (220 points)

    I did'nt have the file, but I did have a lockfile: com.apple.mail.plist.lockfile in the folder where the file was expected.

     

    I deleted it.  Time will tell if that fixes it or not....

     


  • Richard E. Cooke Level 2 (220 points)

    After I exited MAIL, the file appeared - became visible?

     

    I deleted it, and another LOCK file and the error did not come back when I started MAIL.

     

    Now I get this:

     

    2012-10-17 3:05:23.879 PM SyncServer[22646]: [0x7fb173c0be20] |DataManager|Warning| Client com.apple.Mail sync alert tool path /System/Library/Frameworks/Message.framework/Resources/MailSync does not exist.

     

    Which looks like an unrelated issue - Google searching I go....