Skip navigation

Blue tinted screen after mountain lion

10004 Views 76 Replies Latest reply: Oct 30, 2013 1:58 PM by Leschy RSS
1 2 3 ... 6 Previous Next
ndada Calculating status...
Currently Being Moderated
Aug 5, 2012 5:48 AM

Ever since i installed Mountain Lion the display on my 2010 15' MBP gets a blue tint, and its ONLY when i open the Chrome browser.

once i close the browser the color on the screen reverts to normal.

this has never happened to my MBP prior to Mountain Lion.

 

heres a screencap

Screen Shot 2012-08-05 at 8.47.29 AM.png

iPhone 4S, iOS 5.1
  • Umputun Calculating status...
    Currently Being Moderated
    Aug 9, 2012 10:31 AM (in response to ndada)

    I have the same issue with MBP 2011. In fact, this is not just Chrome, but any application forcing switching to discrete graphic card.

     

    The workaround I have discoverd - turning "System Preferences / Energy Saver / Automatic grpahics switching" OFF, reboot MBP and then turn it on.

  • John in Paris Calculating status...
    Currently Being Moderated
    Aug 28, 2012 1:40 AM (in response to ndada)

    Umputun's tip works, but only as long as you turn off "Automatic graphics switching" every time that you reboot. (Thanks Umputun for the tip!)

     

    It looks like an error with the gamma correction, which is how the graphics card displays your image - it doens't actually impact the stored image. That means that your screen capture will look normal to anyone who isn't having this problem.

     

    Basically, if you turn off "Automatic graphics switching" before you boot, the discrete graphics card will be correctly initialized on boot. Then you can turn "Automatic graphics switching" back on, and you won't have the problem until the next time you reboot. I've tested, and this workaround continues to work even after sleeping and awakening my computer.

     

    For whatever reason, the integrated graphics card is always initialized with the correct gramma settings, but the discrete graphics card is only correctly initialized when "Automatic graphics switching" is turned off. I didn't have this problem when using Lion, so it's definitely an error with Mountain Lion. Hopefully 10.8.2 will fix this.

  • clintonfrombirmingham Level 7 Level 7 (26,745 points)
    Currently Being Moderated
    Aug 28, 2012 2:15 AM (in response to John in Paris)

    You can try gfxCardStatus - as I noted in another thread - and won't need to reboot. As I said in the other thread, I had this problem early on - in a developer's release of ML - but one day (still using developer releases) it just went away. I've no idea why. I didn't report it as a bug because I thought that I was the only one having the problem. But then I found others posting both here and in the Adobe Photoshop users forum. Try gfxCardStatus and see if it will temporarily fix the problem.

     

    Clinton

  • GC1766 Calculating status...
    Currently Being Moderated
    Sep 5, 2012 6:53 PM (in response to Umputun)

    THANK YOU!

     

    I thought something might've been wrong with my MBP 17.

  • Donot Haveone Level 1 Level 1 (15 points)
    Currently Being Moderated
    Sep 28, 2012 11:11 PM (in response to John in Paris)

    10.8.2 is the first & only version of Mountain Lion I've installed, and I'm having this problem with 2011 MBP now with Photoshop, which obviously makes it utterly unusable, and with Citrix Viewer (but eerily enough, only Citrix Viewer opened via Firefox, and not the same Citrix Viewer/server combos opened via Safari!).

     

    Lots of previous posts and threads mentioned 10.8.1 fixing the problem, but this is a brand new 10.8.2 download. 

     

    I don't like the sound of something I have to do with every reboot, since I need to reboot often for security/encryption reasons.  If I turn off "Automatic graphics Switching", I will not remember to turn it back on.  What happens if it is off and an application really needs the switch? 

  • clintonfrombirmingham Level 7 Level 7 (26,745 points)
    Currently Being Moderated
    Sep 28, 2012 11:16 PM (in response to Donot Haveone)

    Try running Photoshop using integrated graphics only - see if the switch to the blue tint doesn't go away. It's not a permanant solution - as i said, I don't know what 'fixed' my problem - but it will isolate the switching of GPUs as the problem.

     

    Sorry that I don't have a better solution.

     

    Clinton

  • Donot Haveone Level 1 Level 1 (15 points)
    Currently Being Moderated
    Sep 28, 2012 11:50 PM (in response to clintonfrombirmingham)

    clintonfrombirmingham wrote:

     

    Try running Photoshop using integrated graphics only

    Thanks for the suggestion.  How would I do that?

  • clintonfrombirmingham Level 7 Level 7 (26,745 points)
    Currently Being Moderated
    Sep 29, 2012 12:10 AM (in response to Donot Haveone)

    Download gfxCardStatus and install. Set the card status to "integrated only" - no applications will 'force' the discrete GPU to kick in. Yes, it will slow down some graphics functions, but it will determine if the auto-graphics switching is to blaim.

     

    Clinton

  • Donot Haveone Level 1 Level 1 (15 points)
    Currently Being Moderated
    Sep 29, 2012 1:10 AM (in response to clintonfrombirmingham)

    Ok.  Will try that tomorrow.  Thanks

  • Donot Haveone Level 1 Level 1 (15 points)
    Currently Being Moderated
    Sep 29, 2012 7:55 AM (in response to Donot Haveone)

    And that worked....weirdly enough, the gfxcardstatus install seemed to stop the color hijack even when I let the dynamic switching remain on, and I went through my list of things that provoked the dreaded blueing previously--open a file in Photoshop (CS5); open Citrix viewer windows from Firefox.  The switches happened, but there was no color hijacking.  Cool.  Time to go donate to the person who made this, and give Apple some a little piece of my mind about the lameness of Mountain Lion on this at Apple.com/feedback.

     

    If you're reading this far because you have this issue too, add to the feedback:  it can't hurt if they get lots and lots of the same complaint, and it helps them know its not my computer and the crazy stuff I downloaded off the internet....

  • Donot Haveone Level 1 Level 1 (15 points)
    Currently Being Moderated
    Sep 29, 2012 8:04 AM (in response to clintonfrombirmingham)

    I want to click 'this solved my problem', but am not the originator of the thread.  Sorry!

  • clintonfrombirmingham Level 7 Level 7 (26,745 points)
    Currently Being Moderated
    Sep 29, 2012 8:20 AM (in response to Donot Haveone)

    Glad it worked - I sent Cody $10 - enough to get some food into a college kid, I guess. He's been good about updates, too - even shows up here once in awhile.

     

    Clinton

  • xXMaGNuSXx Calculating status...
    Currently Being Moderated
    Oct 1, 2012 11:15 AM (in response to ndada)

    I have an OCZ Vertex 4 SSD and installed Mountain Lion 10.8.2 on my early 2011 MBP. I had this issue as well. After I reset my PRAM/NVRAM, this issue went away. To reset the PRAM/NVRAM, hold the command, option, R and P keys before the gray screen upon start up. Some system settings may need to be reset.

     

    http://support.apple.com/kb/HT1379

  • Donot Haveone Level 1 Level 1 (15 points)
    Currently Being Moderated
    Oct 2, 2012 9:25 AM (in response to xXMaGNuSXx)

    xXMaGNuSXx wrote:

     

    After I reset my PRAM/NVRAM, this issue went away.

     

    Even easier than gfxcardstatus, worked perfectly, thanks!

1 2 3 ... 6 Previous Next

Actions

More Like This

  • Retrieving data ...

Related Articles

Bookmarked By (4)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.