7 Replies Latest reply: Aug 12, 2012 8:30 AM by Bob Timmons
Carpe-PM Level 1 (0 points)

I've tried using a powered and non-powered USB hub without success. Plugging the hd directly into the airport didn't work either. The hd functions fine when plugged into a USB port on 3 other computers so it doesn't appear to be a hd issue. I've reset the airport with and without the hd attached but no success in getting the hd to appear in the airport utility. I followed all of the instructions in Apple's Airport support section but no luck.

 

All my pc's are running on XP Pro (service pack3). The airport extreame is working flawlessly except for this one particular issue which, unfortunately, was one of the main reasons I purchased it. I've looked through numerous discussions already in the community and tried some suggestions such as attempting to map the drive using the airport's IP address but still no luck.

 

Does anyone have any suggestions or can tell me what I'm missing in the set-up process?


Airport Extreme, Windows XP Pro
  • Bob Timmons Level 10 (98,114 points)

    Checked the format of the drive?

     

    It must be Mac OS Extended (Journaled) or FAT32.

     

    Windows formats of exFAT or NTFS will not work with the AirPort Extreme.  More details here:

     

    http://support.apple.com/kb/HT2426

  • Carpe-PM Level 1 (0 points)

    Thanks Bob. I drive was using NTFS. I reformatted it to FAT32 using HP USB Disk Format Tool (v2.1.8) and then again with SwissKnife (v3.39) but no luck either time.

     

    As before, the reformatted drive works fine when attached directly to a PC. I can move data to & from the drive without issue. However, the Airport Extreme won't recognize the drive at all regardless of whether it's plugged directly into the Airport, using a powered USB hub, or a non-powered USB hub.

     

    I plugged in a 250gb Western Digital drive that was already formatted as FAT32 and the Airport recognized it immediately so I'm at a loss for ideas. Others in the community have posted that they are using 2tb hard drives with their Airport Extremes so I don't know why the unit won't recognize this particular hard drive. 

  • Bob Timmons Level 10 (98,114 points)

    Some drives just are not recognized by the AirPort Extreme. I don't know why other than a guess about firmware limitations. Iomega seems to be a brand that appears often as having "recognition" problems, for example.

     

    If you can, try formatting the drive in Mac OS Extended (Journaled). If you plan to leave the drive attached to the AirPort Extreme, PCs will be able to read and write to the drive without the FAT32 file size limitations.

  • Carpe-PM Level 1 (0 points)

    Thanks Bob. I'll give that some thought.

     

    I found an article in Apple support (http://support.apple.com/kb/HT2426?viewlocale=en_US&locale=en_US) that mentions external drives connected to the Airport Extreme must follow the USB 2.0 protocol.

     

    It states "To work with the AirPort Extreme (802.11n) and Time Capsule, devices must follow the USB 2.0 power specification; for more information, see http://www.usb.org/developers/docs/.

     

    The TouroPro is USB 3.0 backwards compatible to 2.0. Could this be the issue?

  • Bob Timmons Level 10 (98,114 points)
    The TouroPro is USB 3.0 backwards compatible to 2.0. Could this be the issue?

     

    Should not be an issue, but anything is always possible.

     

    We would have received thousands of posts from users on the forums if this were an issue, I cannot find anything in this regard.

     

    I would check with Apple Support for an opinion.

  • ruphio Level 1 (0 points)

    I struggled with this same issue for quite awhile.  I have both a PC desktop and Mac Laptop and wanted both to be able to see my Seagate external HDD through my Airport Extreme.  Plugging the HDD it into either computer, they could see and write to it just fine; but plugging it into the Airport, it would not show in Airport Utility.  After reformatting the drive to MacOS Extended format through my MacBook; it showed up immediately through the Airport Express and both PC and Mac can read/write to it just fine.  I don't think there is any way for you to force a drive to show up that is formatted in NTFS if it doesnt show automatically.  When trying to troubleshoot my problem I discovered a forum that was saying certain NTFS drives work just fine, and some just won't.  But if you can reformat it to MacOS extended, any drive will work.

  • Bob Timmons Level 10 (98,114 points)
    When trying to troubleshoot my problem I discovered a forum that was saying certain NTFS drives work just fine

     

    Apple support says that an NTFS or exFAT drive cannot be used when connected to the AirPort Extreme.

     

    I suppose it is possible that someone might have been using some type of special software on the drive that might perform a "conversion", but without more details, it is hard to know.

     

    Note: ExFAT and NTFS formats aren't supported.

     

     

    http://support.apple.com/kb/HT2426