9 Replies Latest reply: Nov 25, 2012 12:49 AM by Izek.Ruiz
TownTroniks Level 1 (0 points)

I'm working on a Lion with a Mac BookPro in iMovie 11.


I've gotten to the point with my project that I'm ready to share it and ran into a wall. When I try any of the Share option I get this message:


"Sharing requires more memory to be available. Quit iMovie and relaunch it"


I tried that like 100 times and nothing! Help!!!!


This project is a stopmotion video with a series of picture and audio clips.

The audio clips are housed on an extrenal drive, the picture on the desktop.

Project is 1.07GB


I have 250GB available of the 500GB drive.

Is there some way else to boost the Memory???


Anyone have this problem????

MacBook Pro, Mac OS X (10.7.2), iMovie 11
  • Bengt Wärleby Level 6 (19,450 points)



    So You've got two hard disks

    • Start-Up one

    • and external one


    It is the amount of free space on the Start-up (Mac OS) one that are Important

    • I never go under 25Gb free space on this when doing SD-Video (as on old CRT-TV or DVD - standard) if HD I guess that 4 to 5 times more will do.




    If You got 25 to 125Gb free on this one and still got problems

    • Trash iMovie pref file/s


    Yours Bengt W

  • TownTroniks Level 1 (0 points)

    Thanks for your reply. I will try this but I have more then enough space on the start-up its the external that only has 8GB left. Maybe I'll free up some of that space too.


    How do I "Trash iMovie pref file/s"???

  • Bengt Wärleby Level 6 (19,450 points)

    • Delete iMovie pref. file


    iMovie pref. file resides.

    Mac Hard Disk (start-up HD)/Users / "Your account" / Library / Preferences

    and is named. (one or more of these)








    and find



    While iMovie is NOT RUNNING - move this/these file/s out on to desk-top.

    Now restart iMovie.


    If You run Mac OS X.7 or more - then the Library in the User-account folder is invisibly and need to be set to be viewable. IT IS NOT in the Library on Root level (when opening MacintoshHD - first window = root level)


    ( It can be done like this: Open Terminal, then enter: chflags nohidden ~/Library

    Press return, then restart, and it will always be visible until the next major update, when you do the same thing again. )


    or - do like this. EASIER !


    On the Finder window at the top left of the screen,

    • Hold down the Option key and clicked on Go

    • This allowed You to see the Library folder and select it. 

    • Keep the Option button pressed down in order to see and select the Library folder. 

    Once I found that, You navigate to the Preferences and in this move the above named files to DeskTop/Finder.  Now start up iMovie ! 


    Yours Bengt W

  • TownTroniks Level 1 (0 points)

    I was really hopeful but it didnt work.  If you have anymore ideas I'm open.


    I made space on both drive and everything.


    I have an iMac here at work with Lion on it, I'm going to move everthing on there and try it. Not sure if it with find the path to the all the audio though??? Most of its stored on the external drive.

  • TownTroniks Level 1 (0 points)

         This totally *****!!! That didnt work either. The iMac wont even open it.   HeEEELp!!!!

  • TownTroniks Level 1 (0 points)

    Ok So i found another forum that gave me the answer. He said right click the project in the project gallery and select export...blah blah and that should work. Its exporting now! I guess opening the movie takes more memory... makes since. 

  • Stefan9876543 Level 1 (0 points)

    I'm having almost the same problem.  I'm trying to export a 5 minute movie and I get the error that says "sharing requires more memory to be available."  I have 8GB of ram and plenty of HD space, so I know I know memory isn't the problem.  The project is 57GB, so I can see how this could lead to problems, but since this happened, it's affecting all of my projects.  I can't even export a 6 second video project.  The weird thing is I can export NEW small test projects just fine.  I tried rebooting, deleting plist, right clicking from the project gallery, changing the name of the project, nothing works.


    I even went to the Genius bar!  After waiting around 20 minutes for them to search for an answer, they told me to try exporting to an external drive (which we both knew woulnd't work).  I think they were stumped and just trying to get rid of me!  iMoive is useless if I can't export my project, so this needs to be fixed.

  • Bengt Wärleby Level 6 (19,450 points)

    When iMovie doesn't work as intended this can be due to a lot of reasons


    • iMovie Pref files got corrupted - trash it/they and iMovie makes new and error free one's

    • Creating a new User-Account and log into this - forces iMovie to create all pref. files new and error free

    • Event or Project got corrupted - try to make a copy and repair

    • a codec is used that doesn't work

    • problem in iMovie Cache folder - trash Cache.mov and Cache.plist

    • version miss match of QuickTime Player / iMovie / iDVD

    • preferences are wrong - Repair Preferences

    • other hard disk problem - Repair Hard Disk (Disk Util tool - but start Mac from ext HD or DVD)

    • External hard disks - MUST BE - Mac OS Extended (hfs) formatted to work with Video

    ( UNIX/DOS/FAT32/Mac OS Exchange - works for most other things - but not for Video )

    • USB-flash-memories do not work

    • Net-work connected hard disks - do not work

    • iPhoto Library got problems - let iPhoto select another one or repair it. Re-build this first then try to re-start iMovie.

    This You do by

    _ close iPhoto

    _ on start up of iPhoto - Keep {cmd and alt-keys down}

    _ now select all five options presented

    _ WAIT a long long time


    • free space on Start-Up (Mac OS) hard disk to low (<1Gb) - I never go under 25Gb free space for SD-Video (4-5 times more for HD)

    • external devices interferes - turn off Mac - disconnect all of them and - Start up again and re-try

    • GarageBand fix - start GB - play a few notes - Close it again and now try iMovie

    • Screen must be set to million-colors

    • Third-party plug-ins doesn't work OK

    • Run "Cache Out X", clear out all caches and restarts the Mac

    • Let Your Mac be turned on during one night. At about midnight there is a set of maintenance programs that runs and tidying up. This might help

    • Turn off Your Mac - and disconnect Mains - for about 20-30 minutes - at least this resets the FireWire port.

    • In QuickTime - DivX, 3ivx codec, Flip4Mac, Perian etc - might be problematic - temporarily move them out and re-try

    (I deleted the file "3ivxVideoCodec.component" located in Mac HD/Library/Quicktime and this resolved my issue.)


    buenrodri wrote

    I solved the problem by removing the file: 3ivxVideoCodec.component. after that, up-dated iMovie runs ok.


    Last resort: Trash all of iMovie and re-install it


    Yours Bengt W

  • Izek.Ruiz Level 1 (0 points)

    Thank you so much! I was stressed out all day trying to edit a video and at the last minute it wouldn't export.  Your advice was a life saver!! Thanks again buddy.