8 Replies Latest reply: Aug 6, 2012 7:15 AM by KUPO29
KUPO29 Level 1 Level 1 (0 points)

Hello,

 

I have recently been having problems with my macbook pro running Mac OS X 10.6.8 announcing the time, and more recently I have had a general text to speech problem. It used to annouce the time perfectly every hour, however now whenever the time changes to noon or midnight in announces instead "it is now 12 o *garble" with the garble sounding like the computer glitching or like a cd skipping. That wasnt too big of problem but now it has started to effect my ipod shuffle, and text to speech messes up the pronuciation on about half the songs on it. Does anybody have suggestions or have they dealt with a similiar problem?

 

Thanks!


MacBook Pro (13-inch Mid 2010), Mac OS X (10.6.8), Also not working on ipod shuffle
  • Kenichi Watanabe Level 7 Level 7 (30,460 points)

    As general trouble-shooting, you should run Disk Utility (in Applications/Utilities).  Select the "Macintosh HD" (your startup volume) in the Disk Utility sidebar.  Over to the right, go to the First Aid tab.  Use Verify Disk.  This will check for data corruption issues on your startup volume.

     

    Make sure your startup volume is not getting to close to being full.

  • KUPO29 Level 1 Level 1 (0 points)

    I ran disk utility and verified the disk but I got a message saying that "The volume Macintosh HD appears to be OK." Nice try but i dont think that is it, do you have any more suggestions?

    Oh and my startup volume has about a 100 gb so i dont think it is close to being full.

  • Kenichi Watanabe Level 7 Level 7 (30,460 points)

    I would create a new user account in System Preferences Accounts pane.  It can be admin or standard.

     

    Log out (to the login screen) and log in to the new user account (don't use Fast User Switching from the menu bar).

     

    Try doing some text-to-speech in the new user account.  If it works better in the new account, that means the problem is something isolated to your normal user account.  It may be a background process that runs in your normal account that is interfering with text to speech, or it may be a corrupted user preferences setting.  If the problem recurs in the new user account, then the problem is a system wide issue.  That will help narrow down your trouble-shooting.

  • KUPO29 Level 1 Level 1 (0 points)

    Ok so I created a new standard account, log out and logged into the new account and it doesn't work any better in the new account. It still glitches and reads words incorrectly. Okay so its a system wide issue, do you have idea of what to do next?

  • Kenichi Watanabe Level 7 Level 7 (30,460 points)

    Try some hardware resets first.  This is reseting PRAM

     

    http://support.apple.com/kb/HT1379

     

    and resetting SMC (power management)

     

    http://support.apple.com/kb/HT3964

     

    If that does not help, then it is more likely to be a software issue affecting the overall OS.  It might be a third-party system extension that is causing a conflict, or some system component may have become corrupted since the original installation.  System extensions are installed here

     

    <startup volume>/System/Library/Extensions/

     

    but it is often difficult to see anything that is obviously wrong.  If you see anything listed that is obviously for hardware or software that you no longer use, you can try removing it.

     

    Short of doing a complete re-install of Mac OS X, it may help to apply the 10.6.8 "combo" update manually.  This will re-install all the system components that have been updated since the initial 10.6 release.  It can sometimes fix mysterious problems that are difficult to diagnose precisely.  This is the combo updater for 10.6.8.

     

    http://support.apple.com/kb/DL1399

     

    NOTE:  Before doing a system update, you should have a good backup.  If you have been using Time Machine, that will serve as your backup.  Things can go wrong during system updates, and you don't want to end up with an unbootable system, with no backup.

  • KUPO29 Level 1 Level 1 (0 points)

    I tried resetting PRAM and resetting the SMC but that hasnt helped me either. I have tried to apple the 10.6.8 combo update manually once and I am trying it again as I later found a bunch of old third party extensions which I deleted after I had first tried it. Another weird thing I noticed was that only the "Alex" voice is is glitching up, the rest of voices work fine, maybe that is a clue as to what is wrong here?

  • Kenichi Watanabe Level 7 Level 7 (30,460 points)

    Another weird thing I noticed was that only the "Alex" voice is is glitching up

    I think that's a BIG clue.  After looking around, I found that the "voices" are stored here

     

    <your startup volume>/System/Library/Speech/Voices/

     

    Actually, I'm using Lion, not Snow Leopard, so if you are using 10.6.8, it may be different, because there were some changes to Speech with Lion (with higher-quality voices).

     

    However, what I see there are folders corresponding to the voices.  So, if Alex is not working right, but the other voices are fine, maybe something in the "Alex" voice folder is corrupted.

     

    Do you use Time Machine?  If you have an old backup state in your Time Machine archive, that goes back to when you installed Snow Leopard (or when this problem did not exist), you can try copying the (current) "Alex" voice folder to another location, deleting it from that location, and restoring it from Time Machine (before you had this problem).

  • KUPO29 Level 1 Level 1 (0 points)

    That was it! I restored just the Alex.SpeechVoice folder in the voices folder and that was it! It has been working perfectly since that. Thank you very much!