11 Replies Latest reply: Dec 1, 2015 1:04 PM by californiajay
ffalzett Level 1 (0 points)

Any ideas?


24" IMAC, Mac OS X (10.6.2)
  • Sahil Om Arora Level 1 (5 points)

    Hello Guys,

     

    I faced the same issue. Apple has now changed the default settings to only download application from Mac App Store and identified developers. you need to change the settings

    Please follow the steps given below to resolve this issue -

     

    System Preferences > Security & Privacy > General > Allow applications downloaded from > Anywhere

     

    Hope this helps

  • cheesok Level 1 (0 points)

    I downloaded MPlayerX from the Mac AppStore but it still doesn't allow it to run. I have to change the settings to "Anywhere". This is annoying. After restarting my computer, it will revert to Quicktime as the default player even though I have set MPlayerX as the default prior to shutting down my computer. Before the upgrade to Mountain Lion, I had no such issue. This shows that Apple could not even trust the apps they approved in the Mac AppStore.

     

    I hope Apple will fix this issue as it makes me nervous when the security setting is set to "Anywhere"

  • ldove Level 1 (5 points)

    1.  Hold down "control" button

    2.  Click on the app that is triggering the message about the security preferences

    3.  Select "open" to override and install/open the application

     

    This allows you to avoid changing the security setting to "anywhere."

  • AasmaSyed Level 1 (0 points)

    Worked like a charm... Thanks

  • A Texan Level 1 (0 points)

    I may have more than one problem. Every time I open System Preferences and choose Security & Privacy, then System Preferences becomes non-responsive (hangs up) (spinning wheel) and then I have to Force Quit it.

     

    Therefore I cannot choose the fixes you recommend.

  • josephreddy Level 1 (0 points)

    thank you tht really helps.

  • STUPENDOUS!!! Level 1 (25 points)

    Thanks!

  • Jacksonthecat Level 1 (0 points)

    This was so helpful. Thank you!

  • rastas chicken feather Level 1 (0 points)

    Thanks, that did it...

  • xolisey Level 1 (0 points)

    Thank you!! It worked!

  • californiajay Level 1 (0 points)

    This didn't work for me since I was trying to do it from Launchpad.

     

    Full instructions can be found by clicking the "?" on the bottom left of the error dialogue.

     

    Text from mac help is here:

     

    If you try to open an app that is not registered with Apple by an identified developer you get a warning dialog. This doesn’t necessarily mean that something’s wrong with the app. For example, some apps were written before developer ID registration began. However, the app has not been reviewed, and OS X can’t check whether the app has been modified or broken since it was released.


    A common way to distribute malware is to take an innocent app and insert harmful code into it, and then redistribute the infected app.

    The safest approach is to look for a later version of the app from the Mac App Store or look for an alternative app.


    To override your security settings and open the app anyway:

    • In the Finder, locate the app you want to open.
      Don’t use Launchpad to do this. Launchpad doesn’t allow you to access the shortcut menu.
    • Press the Control key and click the app icon, then choose Open from the shortcut menu.
    • Click Open.

     

    The app is saved as an exception to your security settings, and you can open it in the future by double-clicking it just as you can any registered app.


    Note: Another way to grant an exception for a blocked app is to click the “Open Anyway” button on the Security pane of System Preferences. This button is available for about an hour after you try to open the app.


    To open this pane, choose Apple menu > System Preferences, then click Security & Privacy.

    Open Security & Privacy preferences for me


    To change your security settings, see Protect your Mac from malware.