Previous 1 2 Next 26 Replies Latest reply: Jan 24, 2014 10:27 PM by itecheck
tcpudp Level 1 (20 points)



Since Mountain Lion Apple has decided to remove svn with apache modules all together. I haven't been able to configure subversion running on https as I did in Lion Server. I tried compile and install subversion from source ( but apache won't start properly.


Has anybody got any luck with that?



Mac mini Server (Mid 2011), OS X Server
  • Andreas Amann Level 5 (7,815 points)

    The following approach seems to be successful:


    1) Download and extract the SVN sources:





    2) Configure SVN with the following command (from within the subversion-1.6.18 directory the two above files where extracted into - I used /usr/local/src/subversion-1.6.18/ You will have to adjust the command to reflect the location you are using)

    ./configure --with-apr=/usr/local/src/subversion-1.6.18/apr --with-apr-util=/usr/local/src/subversion-1.6.18/apr-util

    3) Compile SVN:


    4) Copy the two module sources into apache's directory:

    sudo cp subversion/mod_authz_svn/.libs/ /usr/libexec/apache2/

    sudo cp subversion/mod_dav_svn/.libs/ /usr/libexec/apache2/

    5) Compile and install APR & APR-UTIL

    cd apr;sudo make install;cd ../apr-util;sudo make install




  • tcpudp Level 1 (20 points)

    Hi Andreas,


    Thanks for the quick reply.


    I have tried to follow your instructions step by step, but when I try to do


    ./configure --with-apr=/usr/local/src/subversion-1.6.18/apr --with-apr-util=/usr/local/src/subversion-1.6.18/apr-util


    It stops here:

    Configure: Apache Portable Runtime (APR) library configuration

    checking for APR... configure: error: the --with-apr parameter is incorrect. It must specify an install prefix, a build directory, or an apr-config file.



    Is there anything I am missing?






    bash-3.2# pwd


    bash-3.2# ./configure --with-apr=/usr/local/src/subversion-1.6.18/apr --with-apr-util=/usr/local/src/subversion-1.6.18/apr-util

    configure: Configuring Subversion 1.6.18

    configure: creating config.nice

    checking for gcc... gcc

    checking for C compiler default output file name... a.out

    checking whether the C compiler works... yes

    checking whether we are cross compiling... no

    checking for suffix of executables...

    checking for suffix of object files... o

    checking whether we are using the GNU C compiler... yes

    checking whether gcc accepts -g... yes

    checking for gcc option to accept ISO C89... none needed

    checking for g++... g++

    checking whether we are using the GNU C++ compiler... yes

    checking whether g++ accepts -g... yes

    checking how to run the C preprocessor... gcc -E

    checking for a sed that does not truncate output... /usr/bin/sed

    checking build system type... i386-apple-darwin12.0.0

    checking host system type... i386-apple-darwin12.0.0

    checking target system type... i386-apple-darwin12.0.0

    checking for grep that handles long lines and -e... /usr/bin/grep

    checking for egrep... /usr/bin/grep -E

    checking whether ln -s works... yes

    checking for a BSD-compatible install... /usr/bin/install -c

    configure: Apache Portable Runtime (APR) library configuration

    checking for APR... configure: error: the --with-apr parameter is incorrect. It must specify an install prefix, a build directory, or an apr-config file.

    bash-3.2# ls


    CHANGES                              build                              neon

    COMMITTERS                    notes

    COPYING                              build.conf                    packages

    HACKING                              config.log                    serf

    INSTALL                              config.nice                    sqlite-amalgamation                    configure                    subversion

    README                                        tools

    TRANSLATING                    contrib                    

    aclocal.m4                    doc                              www

    apr                              gen-make.opts                    zlib



  • Andreas Amann Level 5 (7,815 points)

    Not sure why it is not working for you that way - I just tested the command again and it works for me.




  • Andreas Amann Level 5 (7,815 points)

    Just in case it still doesn't work for you - I uploaded the compiled modules to my server and you can grab them from there (I obviously don't take any responsibility if this doesn't work for you…)



    Most likely you will have to adjust the permissions on those files after installing them into /usr/libexec/apache2




  • Blaidd Drwg Level 1 (75 points)

    If you're building svn, I take it you already have Xcode installed. If so, you've already got svn, but it's buried in outside of your default path. You can add an alias like this to your .bashrc so it will be available easily:


    alias svn=$(xcrun -find svn)


    Oh, you were talking about subversion server. Just ignore me.

  • Andreas Amann Level 5 (7,815 points)

    You can also avoid using an alias to svn by installing the command line tools from Xcode's preferences - this will install svn in a standard location which is accessible from your default path.




  • esrthysrdyxdrtvgdr Level 1 (0 points)

    I'm getting the same error here. I've got a brand new OS X Mountain Lion Server install with the latest version of Xcode and command line tools installed.


    Searches on Google suggest that this is something to do with no having APR installed. Do you possibly already have something else installed on your system that the rest of us are missing?

  • esrthysrdyxdrtvgdr Level 1 (0 points)

    I also tried downloading and installing your pre-built version of the .so libraries. When I install them into Apache and test the config I get the following error:


    Cannot load /usr/libexec/apache2/ into server: dlopen(/usr/libexec/apache2/, 10): Library not loaded: /usr/local/apr/lib/libaprutil-1.0.dylib\n  Referenced from: /usr/libexec/apache2/\n  Reason: Incompatible library version: requires version 5.0.0 or later, but libaprutil-1.0.dylib provides version 4.0.0

  • tcpudp Level 1 (20 points)

    Thanks very much Andreas! I was going to ask you the same thing..


    However I am having the same problem when the mods are referenced:



    bash-3.2# apachectl -M

    httpd: Syntax error on line 500 of /private/etc/apache2/httpd.conf: Syntax error on line 1 of /private/etc/apache2/other/svn.conf: Cannot load /usr/libexec/apache2/ into server: dlopen(/usr/libexec/apache2/, 10): Library not loaded: /usr/local/lib/libsvn_repos-1.0.dylib\n  Referenced from: /usr/libexec/apache2/\n  Reason: image not found



    Could you give us a tar of your /usr/local if possible?


    Thanks again!

  • Andreas Amann Level 5 (7,815 points)

    Hmmm - I do indeed have libapr and libapr-util in /usr/local/apr/lib/ - based on the date it seems that they were installed when I was messing around trying to get the svn modules to work…

    Try "sudo make install" from both the apr and apr-util subdirectories of the subversion source tree and then re-configure subversion with the above command to see whether that works…




  • Andreas Amann Level 5 (7,815 points)

    My whole /usr/local might be a little excessive…


    Anyway - I created a tar.bz2 of /usr/local/apr/:




  • tcpudp Level 1 (20 points)

    Still giving out the same error here mate.


    If I copy the content of *.dylib from /usr/local/apr2/lib to /usr/lib it seems to pass the version check, but asking something about ldap. Maybe we are missing some module again?

    bash-3.2# apachectl -M

    dyld: Symbol not found: _apr_ldap_get_option

      Referenced from: /usr/sbin/httpd

      Expected in: /usr/lib/libaprutil-1.0.dylib

    in /usr/sbin/httpd

    /usr/sbin/apachectl: line 90: 91486 Trace/BPT trap: 5       $HTTPD $ARGV



  • Andreas Amann Level 5 (7,815 points)

    Hmm - not sure. I guess sharing individual modules is not the way to go and you'll have to try and compile SVN yourself…




  • commandsoft Level 1 (0 points)

    Upgraded to Mountain Lion Server, my SVN server is now broken. Anyone got this working yet with detailed steps that actually hold up to someone else trying it? I've tried the above from Andres without success and he seems to stop answering anyone so I'm guessing no one else was able to make it work. If there is anyone out there some detailed steps would be nice since a lot of us aren't super duper users. Especially if it requires compiling from scratch something steps with everything that must be typed would be helpful for the rest of us just trying to get back working what Apple decided to break with this update. --Thanks -- Jim

Previous 1 2 Next