10 Replies Latest reply: Aug 6, 2012 2:03 PM by babowa
Peter Inova1 Level 1 Level 1 (0 points)

I get this message when trying to install Unity Web Player.

 

Screen Shot 2012-08-06 at 12.41.13 AM.png

 

Okay, smarty pants. There is nothing in the Security preferences that has anything to do with choosing apps.

 

All this managed to do was make me miss the Curiosity Mars landing on my laptop.

 

%$#@!!!!

 

Where the heck do you turn this unappreciated gatekeeper off?


MacBook Air, Mac OS X (10.7.3)
  • b j t Level 4 Level 4 (3,670 points)

    I was going to help you, but with that attitude ........

  • softwater Level 5 Level 5 (5,370 points)

    In the Security panel 'General', unclick the padlock at the bottom and enter your admin password.

     

    You'll now see three options enabled in the bottom half of that panel. Choose 'Anywhere' to turn Gatekeeper off.

  • Peter Inova1 Level 1 Level 1 (0 points)

    Wouldn't that have been a nice thing to include in the verbose warning?

     

    And thank you very loud.

  • Bimmer 7 Series Level 6 Level 6 (10,270 points)

    go here - system preferences - security and privacy...

     

    Gatekeeper.png

  • Peter Inova1 Level 1 Level 1 (0 points)

    I went with General, but spotted my error seconds later and edited the post.

  • William Lloyd Level 7 Level 7 (20,615 points)

    For reference, it may be better to leave Gatekeeper on.

     

    You can get around this warning by right clicking on the application and choosing "Open."  You will then get a dialog box that lets you explicitly OK the download and can go from there.

     

    FWIW Gatekeeper only comes into play on possibly hazardous file types (i.e. applications, zip files, scripts, etc.) that are downloaded from the Internet, emailed, etc.  And you only have to OK an application once, and from then on it will OK things.

  • babowa Level 7 Level 7 (26,030 points)

    FWIW Gatekeeper only comes into play on possibly hazardous file types (i.e. applications, zip files, scripts, etc.)

    I was under the impression that an application whose developer has not signed with MAS will prompt that pop up.

     

    For the OP:

     

    Take a look here:

     

    http://support.apple.com/kb/HT5290

     

    And here on how to override it:

     

    http://support.apple.com/kb/PH11437

     

    Since I rarely purchase anything from MAS, I've chosen to override the settings if it is an app I trust.

  • Peter Inova1 Level 1 Level 1 (0 points)

    This came up when trying to install the program that the Curiosity NASA site directed me to so I could view their simulation in real time of the seven minutes of terror landing sequence.

     

    As it turned out, there was not enough time to deal with this before landing, so that computer could not participate.

     

    Hence the %$$##@!!.

     

    The only -ONLY- reason this became a gate-keeper to me was that it arrived inside Mountain Lion which was installed days earlier.

     

    But gate-keep a NASA-directed install? Thank you not, Mr. Apple.

  • Peter Inova1 Level 1 Level 1 (0 points)

    That, too, would have been a dandy item to include in the gate-keeping alert.

     

    BTW, you can see the NASA simulation at eyes.nasa.gov and run the entire thing from any point.

  • babowa Level 7 Level 7 (26,030 points)

    But gate-keep a NASA-directed install? Thank you not, Mr. Apple.

     

    Any app from any developer who has not signed with MAS will bring up that pop up. It had nothing to do with a "NASA directed" install; it has to do with protecting your machine and  it had to do with the fact that the developer of the app you chose to install has not signed his app with MAS. The developer is Unity Technologies, not NASA.

    FWIW, I also watched part of it and did not need to download anything.

     

    If you'd rather not have your machine protected, just switch from the default to "anywhere" and you can download anything you want without the pop up.