Skip navigation

HT1338: OS X: Updating OS X and Mac App Store apps

Learn about OS X: Updating OS X and Mac App Store apps

HT1338 i cannot run java with mountain lion

1512 Views 12 Replies Latest reply: Dec 24, 2012 1:02 AM by anandaguy RSS
vipami Calculating status...
Currently Being Moderated
Aug 6, 2012 4:58 AM

i cannot run java with mountain lion

MacBook Pro, OS X Mountain Lion
  • baltwo Level 9 Level 9 (59,145 points)
    Currently Being Moderated
    Aug 6, 2012 2:33 PM (in response to vipami)

    The paucity of details is amazing. Provide some and maybe someone can help.

    27" i7 iMac SL, Lion, OS X Mountain Lion, G4 450 MP w/Leopard, 9.2.2
  • anandaguy Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 7, 2012 12:30 PM (in response to vipami)

    I followed suggestions made by 'softwater' on the Apple Discussions page(https://discussions.apple.com/thread/3982638) instructing us to enable Java in the Java Preferences (see above link for details). I found that the checkbox for enabling Java had not been checked--and I enabled it by checking it.

     

    But . . . with my installation of today's update (Java for OS X Lion 2012-005 1.0 -- and "...NOT 2012-004") that there seems to be an issue/bug with getting drop-down menus to show all of their options (I get only a few of the listed items at a time, and have to select the last one in the list, and then reselect it again to get the next set in the series of options). This wasn't a problem before I installed this recent update.

     

    On the U.S.P.S. Zip Code lookup page (https://tools.usps.com/go/ZipLookupAction!input.action) I cannot get all of the states to appear in the drop-down list.

  • Marlin-Pierre Pryor Calculating status...
    Currently Being Moderated
    Nov 16, 2012 8:21 PM (in response to anandaguy)

    As I am new to technology, where do I find the "enable" switch to enable Java, please?

     

    Thank you,

     

    Marlin

  • Grant Bennet-Alder Level 8 Level 8 (48,110 points)
    Currently Being Moderated
    Nov 16, 2012 9:24 PM (in response to anandaguy)

    anandaguy-

     

    the list of states on the page you referenced is not done with Java. I have Java turned off in my Browser and it still works for me.

    Mac Pro (Early 2009), Mac OS X (10.6.8), & Server, PPC, & AppleTalk Printers
  • mcgerbs Level 1 Level 1 (15 points)
    Currently Being Moderated
    Nov 16, 2012 11:39 PM (in response to vipami)

    For those of you having issues with ML and Java.... attmepting to download here:

     

    http://www.java.com/en/

  • Grant Bennet-Alder Level 8 Level 8 (48,110 points)
    Currently Being Moderated
    Nov 17, 2012 8:14 AM (in response to mcgerbs)

    You should be able to use Java Preferences.app from the Utilities folder. If you do not have an appropriate version of Java installed already, it will fetch one for you.

     

    Then it will show you what version you do have installed and allow you to enable it.

     

    Java Applets in Browsers (not to be confused with the similar-sounding JavaScript) must be enabled separately, using each Browser's Preferences.

    Mac Pro (Early 2009), Mac OS X (10.6.8), & Server, PPC, & AppleTalk Printers
  • jnsmth Calculating status...

    @anandaguy... i am having very similar problems... but mine is with the price calculator from usps. i cannot get other countries to load.

     

    have you found a solution?

     

    i am running current chrome version.

    i have a mid-2007 imac 10.7.5

    flash is installed, java problems... who knows? haha! ; )

     

    but... not having the problems on my macbook pro...

    running snow leopard.

  • Barney-15E Level 7 Level 7 (33,270 points)
    Currently Being Moderated
    Dec 22, 2012 6:56 AM (in response to jnsmth)

    That dropdown menu is straight html, so you shouldn't have a problem unless it is with Chrome.

     

    Selecting an item invokes a javascript (which isn't Java or Flash, nor has anything to do with either) to set the country ID you selected. If Javascript is not enabled, it will not function properly. Interstingly, it doesn't tell you it needs Javascript enabled, though.

     

    Make sure Javascript is enabled in Chrome's preferences. I don't use Chrome, so I don't know where to check that setting.

  • jnsmth Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 23, 2012 7:59 AM (in response to Barney-15E)

    thanks for your reply @barney-15E!

    javascript is enabled in chrome.

  • Barney-15E Level 7 Level 7 (33,270 points)
    Currently Being Moderated
    Dec 23, 2012 2:16 PM (in response to jnsmth)

    Does it work with another browser?

  • jnsmth Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 23, 2012 7:20 PM (in response to Barney-15E)

    no...

    and i didn't upgrade to mountain lion, still have lion.

     

    it works my my macbook pro though... that's running snow leopard.

     

    so strange... ???

  • anandaguy Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 24, 2012 1:02 AM (in response to jnsmth)

    @jnsmth

     

    I see Barney-15E made suggestions regarding Chrome preferences. There's also a setting on the Mac to deal with this. Regarding the drop-down menus not seeming to scroll through (such as a list of states)--where when you place or click your cursor over the drop-down menu and it only opens to some of the options in a list, I found that you have to change the scroll bar behavior in your computer's (and not the browser's) General Preferences within your System Preferences.

     

    Open System Preferences, and click on "General" inside the top row of "Personal Preferences" (as it is in my system with Mountain Lion, and I think prior operating systems before that).

     

    Once inside General Preferences, select the radio button option for your scroll bar which you'd like to use in the "Show scroll bar:" section ("Automatically based on mouse or trackpad," "When scrolling," or "Always." If you're using a mouse and not a trackpad, you'd probably want to select "Always" as it takes swiping over the drop-down list on the trackpad to enable (make visible) the scroll bar and/or scroll the list.

     

    Either with the installation of Mountain Lion, or the installation of my trackpad (I'm using a desktop iMac and not a Macbook / laptop) I found that the righthand scroll bars seem to automatically disappear. When I moused over or clicked on a drop-down menu (such as the list of states) I'd see only the first few options in the list. In order to access the rest of the states (get the list to scroll) you have to either have the scroll bar setting set to show "Always" or (if you have a trackpad) use the trackpad to swipe/scroll while hovering your cursor over the list's items to get it to scroll the list, and thus then show/reveal the lefthand scroll bar (which can then be accessed with your mouse if you prefer.

     

    This confused me at first when my scroll bars seemed to disappear, but was an easy fix.

     

    Hope that helps with that part of your issue.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.