10 Replies Latest reply: Aug 12, 2012 12:46 PM by Terence Devlin
azhar Level 1 Level 1 (5 points)

Every time i launch iPhoto 11 (after i connect iPhone), and the updating thumbnail process initiates, iPhoto stalls saying it can't find about ~20 original photos.  It the same ~20 photos everytime.  Tried repairing database.  No change.


iPhoto '11, Mac OS X (10.7.4), iPhone 4S
  • LarryHN Level 9 Level 9 (62,780 points)

    Is the iPhoto preference to "copy imported items to the iPhoto library" checked or have you unchecked it?

     

    LN

  • azhar Level 1 Level 1 (5 points)

    Thanks so much for quick response.

    Yes, "copy imported items to the iPhoto library" is checked.

    Frankly, i can't recall ever checking or unchecking that setting.  Never really paid any attention to it.  Just noticed this pop-up a few weeks ago.  I've had iPhoto for many years.

  • LarryHN Level 9 Level 9 (62,780 points)

    Back up your iPhoto library, depress the option and command keys, launch iPhoto and rebuild the iPhoto library

     

    LN

  • azhar Level 1 Level 1 (5 points)

    Ok, call this a rookie mistake in terms of wrong terminology used but I tried that to no success.  I referred to it incorrectly (I see now) in my post as 'repairing the database'.  I re-launched iPhoto while holding down option & command keys.  Sadly, no change ... still getting the popup.

  • Michael McWatters Level 1 Level 1 (60 points)

    I'm having the same issue. I can do a search in finder and see the so-called missing photos in the library, but they don't associate with the thumbnails. Each time I launch iPhoto I have to click cancel dozens of times. I tried to 'find' the original, but I can't go into the library bundle itself.

  • LarryHN Level 9 Level 9 (62,780 points)

    Download iPhoto Library Manager - http://www.fatcatsoftware.com/iplm/ - and use it's rebuild command

     

    LN

  • LarryHN Level 9 Level 9 (62,780 points)

    Same problem

     

    Same solution

     

    What happens when you use the recommended solutions?

     

    LN

  • Michael McWatters Level 1 Level 1 (60 points)

    I did try iPhoto Library Manager before posting here, but it told me it couldn't rebuild the database because it was corrupt! Yikes.

     

    Okay, so I did what someone suggested on another thread, and tried to identify all the 80 or so photos that were supposedly 'missing'. I wrote down the name of every photo on a text edit doc.

     

    Then I did something strange that seems to have worked: I went to Spotlight, and searched for one of the image names. I found it inside the iPhoto library. (I'm not sure why you can't navigate to photos from inside iPhoto, but you can from Spotlight - note, you can't find them in any other finder window, just Spotlight).

     

    I dragged the culprit file to my desktop. Then, when the alert came up again, I used File > Reveal in Finder to navigate to the photo...interestingly, iPhoto then pointed to the original location of the missing file...I then dragged the photo from my desktop back into iPhoto's library via the Finder. Voila, the photo was re-linked.

     

    But here's where it gets interesting. Somehow other photos got re-linked, too!

     

    I quit the program, and the same problem reoccurred. So I took the steps again above, but this time I did something slightly different afterward.

     

    I went to the TextEdit doc, and I found each and every photo, and dragged it into an album I'd created (I called it something like "Photos to Fix" or something). I then went to the Trash, and found some broken aliases in there, too. I emptied the Trash, after clicking 'cancel' on each error message. Then, I quit and restarted iPhoto several times. The problem is gone! I then moved the photos out of the "Photos to Fix" album, and the problem has not returned.

     

    In short:

    - Find a broken photo in iPhoto, note the name

    - Navigate to the photo in Spotlight (not finder)

    - Drag it out of the iPhoto Library and onto the desktop

    - Go back to iPhoto

    - Select "Reveal in Finder" on the broken thumbnail

    - iPhoto will go to the location the photo USED to be

    - Go back to Finder

    - Drag the photo back into its old location

    - Go back to iPhoto

    - Move that photo, and any other problem photos, to a new album

    - Empty Trash if there are any problem files there, too

    - Restart iPhoto

    - Problem solved

     

    That's what worked for me, though I admit it is wonky and illogical. Maybe someone can shed light on why this worked.

  • azhar Level 1 Level 1 (5 points)

    Hi Larry ... sorry for the late response ... been away for a few days.  OK, downloaded ILM per your suggestion, but I don't see a 'rebuild' command therein.  What am I missing?

     

    Across the top the menu screen: New Library, Add Library, Remove Library, iPod Folders then all the way over on the right, Quit iPhoto & Relaunch iPhoto.

     

    I tried clicking the Relaunch iPhoto button from ILM, and then holding down OPTION & COMMAND to rebuild database from startup options in iPhoto, but no change.

  • Terence Devlin Level 10 Level 10 (132,335 points)

    File -> Rebuild