2 Replies Latest reply: Aug 10, 2012 11:36 AM by John Caradimas
John Caradimas Level 1 Level 1 (10 points)

I do not know if anyone else has noticed these things, but now I have concrete evidences about both things mentioned in the subject.

 

Short description of my system:

 

Mac Mini server (mid 2010) with two internal 500GB disks, one of them used as a system disk, and the other one as a Time Machine backup disk of the first one. User directories are located on a third external disk, except the "admin" account whose home directory is on the system disk (thank God!).

 

The Mini was running Lion server, fully updated when Mountain Lion was released. I performed the update, per Apple instructions, downloading and installing the Mountain Lion client software first, and then the Mountain Lion server software. The upgrade procedure didn't work as it should, a problem surfaced in the /Network/Servers directory. Instead of the two links that should exist there, pointing to the root directory of the system, there was one subdirectory with the system long name and in it, there was another subdirectory named with the same name as the external disk, in which the user directories were. Eventually, I deleted those directories and created the two links manually, after that everything worked OK, as far as the Mountain Lion server was concerned, with two small issues:

 

1. Since the upgrade to Mountain Lion, I noticed extreme CPU usage. My server was running the following services: Address Book, iCal, AFP File Sharing, Mail, Wiki, Open Directory and Software Update. With these services running, the Activity Monitor was showing anything from 70% to 93% Idle CPU, in other words, maximum CPU usage was reported to be about 30%. After the update to Mountain Lion, I constantly had about 60% CPU usage sometimes peaking even to 99%, probably when the system was doing a Software Update download.

 

2. With Lion server running, my CPU temperature was at a comfortable 50-60 degrees Celsius (122-140F) with the exhaust fan working at 2400 rpm. Ever since updating the system to Mountain Lion, with the same services running, my CPU temperature jumped to 70-80 degrees Celsius (158-176F), at a higher fan speed of about 4000 rpm. Temperatures and fan speeds are monitored by iStat Menus and controlled by Fan Control.

 

Just to make sure that I was not dreaming, this morning, I took notes of all the things mentioned about about the Mountain Lion and then booted the system from an external disk which had Lion server installed and did the comparisons. So, it's not as if I do not remember things correctly.

 

This morning, I called Apple Support and discussed those issues with them. The technician I talked with told me that the server he had in front of him was showing the same CPU consumption so he considered my numbers to be "normal". He didn't have any software to check out the machine's temperature, so he couldn't comment on that, but the CPU usage, was for him normal. Whatever.

 

Other issues I noticed after the upgrade, was of course the "can not send emails" issue, which was fixed after Apple pointed me towards their upgrade documentation at: http://support.apple.com/kb/HT5381. I've also have some issues with the APC monitoring daemon (apcupsd) which some times refuses to connect to the computer which controls the UPS and finally the fact that the nrpe daemon doesn't start correctly, I have to manually restart it in order for Nagios to monitor the Mini server using nrpe.

 

Since I do not like my computers being used as frying pans, I am now running Lion again, until Apple can figure out what the heck is wrong with the new server software.

 

If someone has any ideas, they'll be appreciated.

  • 1. Re: Mountain Lion excessive CPU usage, high temperatures and other issues
    laurienzo Level 1 Level 1 (5 points)

    this is the 1st release ...

    on my macbook this "overloading" is causing battery life to decrease sooner then usual ...

    hoping in a quick fix too.

  • 2. Re: Mountain Lion excessive CPU usage, high temperatures and other issues
    John Caradimas Level 1 Level 1 (10 points)

    This problem was solved.

     

    After a lot of frustration (restoring Lion backup and performing the update several times), I managed to have a stable installation without the problem of high CPU usage and high temperatures.

     

    It seems that the installation procedure has an issue, when your user directories are located in an external disk. In this particular case, after the installation of the server software, the two links in /Network/Servers directory, pointing to the / directory, do not get created, so you need to do that manually.

     

    That, in itself, was not causing my excessive CPU usage, but it didn't allow my users to log in the server. Thinking that this was the issue described in http://support.apple.com/kb/TS2938, I was running the command described in the previous link to fix the issue. That command (sso_util configure -r REALM_NAME -a diradmin afp) was what was killing my CPU.

     

    All is well, when it ends well, I guess.