8 Replies Latest reply: Jun 2, 2015 10:48 AM by jbef
Dedo Level 2 Level 2 (205 points)

I'm trying to password lock a folder and believe I've followed all the steps using Disk Utility.  I rebooted and tried again and continue to get the same response.  I've also tried to create the .dmg disk using the same folder on my external drive.  I continue to get the same error message: Unable to create 'Blank.dmg' Resource busy..  Can someone help with the steps or is there a work-around?


iMac, OS X Mountain Lion
  • Dedo Level 2 Level 2 (205 points)

    Bump ......

     

    Is there no fix for this issue?  I've created a .dmg disk before and have tried everything I can think of this time to create another.  I did not get the 'Resource busy' when I did it before but it was on Leopard then.

     

    I've closed all apps, rebooted, then opened Disk Utility, and followed the steps.  Same thing: Resource busy.  I've tried repeating the above steps but creating the .dmg disk by selecting the folder from my backup drive so nothing there could be running.  I've trashed the diskutility.plist, cleared items from the Resource Folder (although I assumed 'Resource busy' referred to something in the folder I was trying to copy to the .dmg disk).

    I've booted from my Backup HD and tried it all from that side: same result.

     

    Disk Utility sees the .dmg installer disk and the named disk within it.  I can repair and mount it, but it's empty.  I can copy the folder I want in it, but it's not locked, and won't be.  If I try to copy it to my HD from the desktop, it only creates an alias.

     

    I've tried Disk Utility:File:New:Disk Image from Folder, and also Disk Utility:File:New:Blank Disk Image.  Same result: 'Resource busy'.

     

    I've read the posts on Apple Discussions and Googled info re: creating a .dmg disk and what 'Resource busy' means and tried any suggestions.  I still think my hope for any help is here.  :-)

  • LCohen Level 1 Level 1 (0 points)

    Same problem.  I am running Mountain Lion 10.8.2.  I create dmg's to store the files from Sony Camcorder in a format that I can read them with FCPX and archive them.  This feature from disk utility is important to saving my movies for archival and future use purposes.

     

    I found a workaround by dupicating a previous dmg and then using it as a shell for a new dmg (that disk utility wouldn't create).

  • LCohen Level 1 Level 1 (0 points)

    Anyone have an idea about a fix for this?

  • LCohen Level 1 Level 1 (0 points)

    After some more research I found that I had a third party conflict between drive genius (driveplus module) and disk utility.  In the preferences for Drive Genius I turned off driveplus, and then disk utility was able to create a custom dmg.

  • Dedo Level 2 Level 2 (205 points)

    Thank you for the update (and for sticking with it).  We weren't having much luch with responses which is unusual for this Discussion site. 

     

    I've just turned off DrivePulse, too.  Now I'll see if it works for me, too.  I'll post back after I try it. 

  • Rowan Morrigan Level 1 Level 1 (15 points)

    That fixed it! I don't think I would've thought of turning off DrivePulse. Thanks!

  • chibidraco226 Level 1 Level 1 (0 points)

    For anybody else having this issue that doesn't have DrivePulse, I discovered booting into safe mode that Symantec Endpoint version 12 also causes this issue.  If you're using that as your virus protection then you'll see this same Resource Busy error.

  • jbef Level 1 Level 1 (0 points)

    THANK YOU! This was driving me insane, it was definitely my AV (Trend Micro) that was causing this issue.