4 Replies Latest reply: Oct 22, 2012 9:30 AM by bflack
landon.s Level 1 Level 1 (0 points)

Hi Everyone,

 

I need help. Ever since Lion came out, when I share a Epson TM88v printer on a mac mini. My 2008 R2 server will not install the printer. It worked great in Snow Leopard. I have the checked marked the box under printer share, the printer check marked, and the everyone can print. I also tired to using the Bonjour app for windows server. I get the same error. Does anybody have an idea?

 

Thanks!

  • 1. Re: Bonjour Error 1796
    mac d mini Level 1 Level 1 (0 points)

    Same here, I'm using Mountain Lion.

    Help!

     

    they archive the thread since nobody in apple can fixed this.

     

    https://discussions.apple.com/thread/3087891?start=0&tstart=0

     

    whata!

  • 2. Re: Bonjour Error 1796
    bigredkitty Level 1 Level 1 (0 points)

    Here's the fix:

     

    On your Mac, open a Terminal window. In this window, type: cupsctl WebInterface=yes and press Enter.

     

    Then in Safari on your Mac, enter http://127.0.0.1:631 and press Enter. This brings up the CUPS web management interface.

     

    Click the Administration tab.

     

    Under Server Settings, enable Allow printing from the Internet.

    Under Server Settings, enable Allow remote administration.

     

    Click Change Settings.

     

    On your PC, run the Bonjour Printer Wizard again. Your USB-connected printer will appear and you will not get the error 1796 message.

    screenshot.png

  • 3. Re: Bonjour Error 1796
    landon.s Level 1 Level 1 (0 points)

    Thanks, but that didnt work either. I dont know what it is. It works for all snow lepoard machines. Just not Lion or ML.

  • 4. Re: Bonjour Error 1796
    bflack Level 1 Level 1 (0 points)

    I've waisted countless hours trying to print from a windows 7 laptop through a Mac (Mountain Lion) desktop to a shared printer --following lots of good thoughts on this thread and others --no luck. Keep getting the infamous Error 1796 ... UNTIL I connected the printer to the network, using a wi-fi connection, rather than "sharing" the printer through the Mac. Bingo! Works like a charm.

     

    This only helps if the printer can be connected to the network; in my case with built-in wi-fi, but I could have also plugged the printer into a wireless router usb jack (available on my Airport). Hopefully this will save some frustration.

     

    None of this explains why Bonjour, ML and Windows 7 don't work with printer sharing.