9 Replies Latest reply: Aug 8, 2012 8:55 AM by Hardeepa
Hardeepa Level 1 Level 1

I can not add video mp4 files to itunes library


iPad, iOS 5.1
  • Skydiver119 Level 7 Level 7
    expertise.ipad
    iPad

    How are you trying to do it and what messages are you getting?

     

    YOu can add files by either importing them into iTUnes or dragging them, from teh folder/location they are in, into iTunes.

  • Hardeepa Level 1 Level 1

    I am using Itunes 10. The folder in the library is FILMS. I have tried drag and drop. Nothing happens, not even an error message. I have also tries File>Add file to library>selected the file and clicked the open button but still nothing happens, not even an error message. I contacted apple support, they adivised me to uninstall and reinstall itunes. Did that as well. It is still not working.

  • Hardeepa Level 1 Level 1

    I am sure about the mp4 version of the files as I have downloaded sample files from Quicktime and tried to add these as well, so the point of file format being incorrect is also ruled out.

  • Menneisyys Level 4 Level 4

    So, iTunes simply doesn't accept the movies when you drag them to the Movies tab (or the link section at the top left)? 

     

    Can you provide some links to these QT movies so that I can test them myself? They SHOULD work - after all, the desktop iTunes (as opposed to the rather silly synchronization restrictions of the iPad player) accepts all kinds of H.264 / MP4 content.

  • Hardeepa Level 1 Level 1

    I downloaded the mp4 file

  • Menneisyys Level 4 Level 4

    Thanks, checking it, will report back very soon.

  • Menneisyys Level 4 Level 4

    No problems at all (iTunes 10.6.3 (25) running on OS X 10.6.8), can even be synched to the iPad 2.

     

    Could you try to drag-and-drop other mp4 (mov / m4v) videos to iTunes? For example, the one at http://dl.dropbox.com/u/13100693/html/042012RetinaHDVideoPlayers/2AACAudioAndMan ySubs.mov

     

    If nothing else works, I think you could consider completely removing and reinstalling iTunes.

  • Hardeepa Level 1 Level 1

    Thanks a lot for your help and time devoted for helping find a solution.

    As mentioned above already removed and reinstalled itunes but it was still not working.

     

    I contacted apple support again. we found two problems.

     

    One on checking the properties of the mp4 files it was showing " type of file - Nokia multimedia file". this was due to a nokia software installed on  my computer. I was asked to remove it.

     

    Secondly on removal of itunes completely quicktime was also uninstalled. On reinstalling itunes I  had not yet reinstalled quick time. So I did that as well.

     

    On doing these steps -

    Uninstalling the nokia software

    Installing latest quick time

    and most importantly, had to restart the computer. (This is important as it was still not working properly before restart)

     

    It is now working all right.. I can add mp4 files or drag and drop the mp4 files to itunes.