Skip navigation

Infinite password prompt won't allow app download

223 Views 0 Replies Latest reply: Aug 7, 2012 8:57 PM by Actualize20 RSS
Actualize20 Calculating status...
Currently Being Moderated
Aug 7, 2012 8:57 PM

I have an iPhone 3GS and iPad 1. After latest software update, I can't download free apps. When I install new free apps, I get the "improve apple ID security" prompt to add security questions. When I choose "continue," I get a prompt to enter my apple ID password. After I enter it correctly, there is a shift to a grey page with "loading" and again I am prompted to enter my apple ID password. After entering it correctly, each time the same prompt returns over and over again. End result - I can't download any new free apps (I haven't tried paid apps since this started). I was able to download free updates of existing apps before this happened. Please help.

 

Thank you.

iPhone 3GS (8GB), iOS 5.1.1

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.