14 Replies Latest reply: Mar 19, 2013 11:54 PM by GalaxyT25
CX888 Level 1 Level 1

When trying to update my Mail Account Mailbox Behaviours settings, after making the changes when I try to close the settings pane the following messages occur: Invalid Incoming Mail Server The “Incoming Mail Server” field cannot be empty. The incoming mail server box has in light grey colour: p02-imap.mail.me.com in it and I cannot edit its content. Any ideas what is going on and how to fix it?

  • Winston Churchill Level 10 Level 10
    expertise.macosx
    Mac OS X

    Try turning mail syncing off and on again in your iCloud settings.

  • astamm78 Level 1 Level 1

    I'm having a similar problem, turning off mail syncing within my iCloud settings did not help.

  • janl Level 1 Level 1

    Same issue here... tip didn't help.

  • Philipp Ringli Level 2 Level 2

    Same issue here.

  • DK Quilter Level 1 Level 1

    I'm having same issue.  Has anyone found a solution?  Thx !

  • David Press Level 1 Level 1

    same issue here too... can't change any preference for the .me account.. get that stupid error message.

  • blume Level 1 Level 1

    Same issue for me. Anyone tried contacting Apple Support?

  • mattreichenbach Level 1 Level 1

    i have been having the same issue for about the past few days. my icloud mail is still going to my iphone...i can send and receive...however i havent changed anything on it in months. what i cant do now is setup my icloud mail on my mac. i get the P02-imap error. my mail was working last week...i lost internet connection...now i am unable to setup my email.

  • jayakanth Level 1 Level 1

    instead of adding your .me or icloud email in your "mail", go to www.icloud.com and enter your apple ID and password. Then add your .me or icloud email account in your "mail" application in your computer.

    This will solve your problem.

    regards

    JAY

  • mikaell Level 1 Level 1

    This from KenCaston helped me:

     

    .Mac and .Me accounts try to automatically configure themselves in Mail.  This doesn't work very well.  To solve this you must force the system into manual configuration.

     

    Delete the account you're trying to work on.  Recreate it, but leave the password field blank and select next.  This will force manual configuration mode.  Select IMAP (NOT iCloud IMAP) enter the incoming and outgoing servers you wish to use.  The account will automatically reconfigure itself as a iCloud IMAP account with an entry in the Incoming mail server slot.

  • pghedges Level 1 Level 1

    Thanks mikaell, but this did not work for me either. I do not see any way to choose the type of account or change iCloud IMPAP to simply IMAP. iCloud IMAP is chosen automatically during the configuration process. Anyone had any luck?

     

    Screen Shot 2012-12-07 at 3.22.07 AM.png

  • supermurph Level 2 Level 2

    I did this, but left it on iCloud IMAP and it worked for me.  At first the box showed a strange server name that had "example" in it, but I rolled with it and it changed it to the normal one similar to p06-imap.mail.me.com once it started syncing.  It's working fine now. 

  • mattreichenbach Level 1 Level 1

    this worked for me: 'reset all settings'

     

    go into settings > general > reset > reset all settings

     

    then setup up your icloud email again.

  • GalaxyT25 Level 1 Level 1

    Hi all,

     

    Mattreichenbach is probably on the right track here with a reset of settings.  I think I've determined the issue has to do with cached account information and inconsistencies for the account name.  This seems to crop up when I've changed my password and it hasn't propagated fully to all the servers, devices, certificates, etc.

     

    Hopefully many here are on their way to restoration of service by now but it's clear that a lot of people are having the same issues.  Very frustrating and definitely something Apple needs to resolve:  incoming mail server field grayed out, incorrect autopopulation of different fields, other unanticipated behaviors.  If you're still having issues, though, here's what worked for me...

     

    First, head to the iCloud preferences pane in System Configuration and choose "Sign Out".  When I did this it prompted me with a number of "are you sure" type questions about retaining information on my local machine.  I chose to delete/remove the info each time simply because it should all be restored by the cloud and I didn't want to risk a massive duplication of my data... I will say, I'm back up and running with no issues so I suspect you can make the same delete/remove choices...  But use your own judgment.  I don't want you to lose any data (ie.. please use care as you do this because I cannot bear the thought of causing anyone to experience the pain of data loss).

     

    Once you've signed out of iCloud, restart your system.  When you get back in, head to the Mail, Contacts and Calendars section of your System Preferences and add your account back by choosing the brushed aluminum "iCloud" button.  When it asks for your account name, use your @iCloud.com email address.  I am all but certain my issue had started because one of my devices (iPhone or whatever) had been set up with an email alias specified instead of my @iCloud.com address.

     

    Apple, if you're reading through any of these issues (there are TONS of users having this same problem).  Take note, that your icloud service somewhat frequently is not responding and yet tells the user that the password is wrong and this prompts people to be changing their passwords unnecessarily.  This has happened to me on numerous occasions.  Also, I noticed that last week's outage corresponded to a VERY similar outage exactly one year ago to the day.  Sounds like planned maintenance to me and I think you could do a better job notifying folks so we're not wasting HUGE amounts of time troubleshooting a problem that we have no hope of fixing.

     

    Hope that helps some of you!

    Terry Mullane

    Washington, DC