7 Replies Latest reply: Aug 14, 2012 3:20 PM by Graham Perrin
Dennis Madsen Level 1 Level 1 (0 points)

I was trying to enable FileVault on my iMac where I just have been installing a clean OS X Mountain Lion. My iMac has a SSD and a HDD, and the OS is installed on the SSD.

 

I enabled the FileVault in System Preferences, but after the iMac reboots it gives me the following error:

 

There was a problem enabling FileVault.
Problems were encountered with the disk “Crucial M4 SSD”. Please turn off FileVault, verify and (if necessary) repair the disk with Disk Utility, and try enabling FileVault again.

 

I've verfied and repaired the disks in Disk Utility. I have been rebooting into the recovery partition to run the Disk Utility from here. Here I'm not able to mount the SSD drive.

 

When trying to decrypt the volume is tells me that the volule is not encrypted, and when trying to encrypt the volume is tell me, that the volume is already encrypted. Very confusing

 

Denniss-iMac:~ dennis$ diskutil coreStorage decryptVolume 4FDED44E-EC4B-4B11-9FF5-9C958BD8CEAB
Passphrase:
Error beginning CoreStorage Logical Volume decryption: The target Core Storage volume is not encrypted (-69755)

 

Denniss-iMac:~ dennis$ diskutil coreStorage encryptVolume 4FDED44E-EC4B-4B11-9FF5-9C958BD8CEAB
New passphrase for existing volume:
Confirm new passphrase:
Started CoreStorage operation on disk2 Crucial M4 SSD
Error: -69696: The target Core Storage volume is already encrypted

 

How can I enable FileVault on my iMac?

 

Here is a list om by disks:

 

Denniss-iMac:~ dennis$ diskutil coreStorage list
CoreStorage logical volume groups (2 found)
|
+-- Logical Volume Group 52C795EE-D034-4F54-9691-EF6D04AD5FF9
|   =========================================================
|   Name:         Crucial M4 SSD
|   Size:         255200755712 B (255.2 GB)
|   Free Space:   16777216 B (16.8 MB)
|   |
|   +-< Physical Volume AB27C53B-03C1-481D-9E02-B21DA84AE0F4
|   |   ----------------------------------------------------
|   |   Index:    0
|   |   Disk:     disk0s2
|   |   Status:   Online
|   |   Size:     255200755712 B (255.2 GB)
|   |
|   +-> Logical Volume Family BB92E15C-2063-4F56-99EB-5AD588AECDBB
|       ----------------------------------------------------------
|       Encryption Status:       Unlocked
|       Encryption Type:         None
|       Conversion Status:       Failed
|       Conversion Direction:    backward
|       Has Encrypted Extents:   Yes
|       Fully Secure:            No
|       Passphrase Required:     No
|       |
|       +-> Logical Volume 4FDED44E-EC4B-4B11-9FF5-9C958BD8CEAB
|           ---------------------------------------------------
|           Disk:               disk2
|           Status:             Online
|           Size (Total):       254865207296 B (254.9 GB)
|           Size (Converted):   -none-
|           Revertible:         Yes (unlock and decryption required)
|           LV Name:            Crucial M4 SSD
|           Volume Name:        Crucial M4 SSD
|           Content Hint:       Apple_HFS
|
+-- Logical Volume Group F0D53CC0-68D7-44FA-B2F9-0874A4FD181D
    =========================================================
    Name:         Storage
    Size:         999860912128 B (999.9 GB)
    Free Space:   0 B (0 B)
    |
    +-< Physical Volume BFD4B09C-0CE5-40B4-BB3D-9C7E96589573
    |   ----------------------------------------------------
    |   Index:    0
    |   Disk:     disk1s2
    |   Status:   Online
    |   Size:     999860912128 B (999.9 GB)
    |
    +-> Logical Volume Family B86F5A3A-C642-4956-8D21-B724CFDC3028
        ----------------------------------------------------------
        Encryption Status:       Unlocked
        Encryption Type:         AES-XTS
        Conversion Status:       NoConversion
        Conversion Direction:    -none-
        Has Encrypted Extents:   Yes
        Fully Secure:            Yes
        Passphrase Required:     Yes
        |
        +-> Logical Volume 97EDE534-A8B0-494B-8D1F-C79D136C8327
            ---------------------------------------------------
            Disk:               disk3
            Status:             Online
            Size (Total):       999709908992 B (999.7 GB)
            Size (Converted):   -none-
            Revertible:         No
            LV Name:            Storage
            Volume Name:        Storage
            Content Hint:       Apple_HFS

 

Here is some people with some problems like this:

https://discussions.apple.com/message/19078311

https://discussions.apple.com/message/19120311


iMac, Mac OS X (10.7), 27", 3.4 GHz i7