7 Replies Latest reply: Mar 8, 2013 5:20 AM by hengy
Italian Stallion69 Level 1 (0 points)

iTunes was unable to load data class information from Sync Services


iPhone 4S, iOS 5.1.1
  • b noir Level 9 (72,060 points)

    In the course of your troubleshooting to date, have you worked through the following document?

     

    iTunes for Windows: "Unable to load data class" or "Unable to load provider data" sync services alert

  • xSilver Level 1 (0 points)

    Did so, still no-go.

     

    Configuration:

    ----

    Win 7 Pro x64 SP1

    iTunes 10.7.0.21

    iPhone 4S iOS 6.0 (10A403)

    iPad 1 3G-WiFi 64G iOS 5.1.1 (9B206)

     

    - fresh install W7 + updates

    - fresh instal x64 iTunes (as offered on apple.com)

    - direct USB PC-cable-iDevice (no USB hub)

    - user account is Administrator class

    - no error message under different Admin account, but also no data in library (same appleID used) :-(

    - disabled ZoneAlarm (Checkpoint firewall) does not matter

    - msconfig and limited start as mentioned in advanced troubleshooting - no resloution

    - reinstall iTunes - no resolution

    - iTunes display message from topic but after OK they sync at least something to/from iDevice

    - iTunes also shows that they backed-up iDevice but Device Backups in Edit-Preferences-Devices shows nothing

    - time to time shows "iTunes could not backup the iPhone XYZ because a session could not be started with the iPhone"

    - Home Sharing turned off - no resolution, turned ON - still same + share not visible on iDevices

     

    - previous installation of Windows + iTunes (older version, probably 10.6) - no problem

     

    It just *doesn't* work!

  • b noir Level 9 (72,060 points)

    Okay. On rare occasions the data class messages can be associated with LSP troubles, and LSP trouble is also a possible factor in back-up failures. So, just in case, try the following document:

     

    Apple software on Windows: May see performance issues and blank iTunes Store

  • xSilver Level 1 (0 points)

    thanx for help, good point, lot of symptoms seen (low iTunes performance, sync crashes, no data from library seen by other users) but still no-go.

     

    - used autoruns but only winsock shown is Apple

    - used msconfig befor to troubleshoot possible conflicts, turned off everything except apple* bonjour*

    - turned of even mobile helpers and then started those services manually

    - library created from scratch on internal RAID field (iTunes were unable to read old library from that RAID datadisk)

     

    all this haven't helped so far

    - ocasional synces

    - no backups

    - no home shares

    autoruns-winsock.PNG

     

    Message was edited by: xSilver iTunes - Help - Run Diagnostics always pass even sync tests

  • b noir Level 9 (72,060 points)

    - used autoruns but only winsock shown is Apple

     

    ... okay. Pursuing the possibility a bit further. We might be looking at damage to the Winsock key(s) rather than a conflict.

     

    If that's what is afoot, we might be able to clear the key(s) manually.

     

    Let's try wiclee's instructions from the following post:

     

    Re: i cannot connect to itunes on my laptop

  • xSilver Level 1 (0 points)

    did so, still nothing .. checked my other computer at work (which works normally)

    - similar set of apps installed

    - iTunes 10.7.0.21 also

    - same Win 7 Pro SP1 x64 (different license key but both comps genuine)

    - slightly different HW (home= built, work=DELL)