9 Replies Latest reply: Sep 10, 2012 7:49 AM by Stepppy
Stepppy Level 1 (0 points)

I have a mid 2011 iMac i5 27'' on which I have installed Mountain Lion.


Everything is working great, except for one thing.


I have my Energy Saver set to the default Sleep of 10 mins of non use. Whenever I was downloading anything under Lion it would always stay awake until the download had finished, even if that was 2 or 3 hours. Since changing to Mountain Lion my iMac sleeps exactly as per Energy Saver settings regardless of the fact that there is network/hard drive activity. 


It does this whether downloading to the internal hard drive or an external USB drive.


Is there a setting somewhere which needs tweaking? I have tried checking/unchecking "Wake for Network Access", but that doesn't make any difference.


Any ideas?

iMac (27-inch Mid 2011), Mac OS X (10.7.4), 12GB RAM 1TB, AMD Radeon HD 6970M
  • cocciasik Level 1 (0 points)

    I had exactly the same problem.


    5 minutes ago I tried the "usual" reset of PRAM and SMC and now it seemes to work correctly!




  • Stepppy Level 1 (0 points)

    Just tried the above, but didn't make any difference

  • cocciasik Level 1 (0 points)

    So sorry, I replied too early


    I have just submitted a bug report to Apple.

  • evertdin Level 1 (0 points)

    Hi Stepppy,

    I have always used uTorrent on windows for my torrent-downloads. When I got my first Mac 1 month ago, Mac Mini (mid 2011), I was amazed at how Lion handled uTorrent! The Lion slept, while the torrents were downloading. For 2 days I worked like this. When I saw a FREE upgrade possibility for Mountain Lion I did not hesitate and downloaded...... expecting it to be better ofcourse..... I was wrong.


    I use the mac solely for downloads and watching movies and shows(hooked up to my Sony LED 46HX820...sweet!).

    After some browsing I finally found the caffeinate command to be the best work-around see (h t t p : //apple. stackexchange. com/questions/57951/mountain-lion-sleeps-too-aggressively), that is until the guys at uTorrent update the software, which they promised to do see (h t t p : //forum. utorrent . com / viewtopic . php ? id= 122652)


    This is my setup for uTorrent:

    My sleep settings for screen and hard disks are set to 1 minute, just because, I don't know, just because!


    I open Terminal and use this command everytime I start downloads with uTorrent:

    caffeinate -i open -W -a utorrent.app

    (for other apps use that app's name instead of utorrent.app)  


    This should keep the system awake as long as uTorrent is running and not idle. To prevent any sleep at all, use -s instead of -i.


    And I always set my uTorrent to Sleep After Downloads Complete.


    I hope this helps you and some others.

    Ofcourse, this is not what we want eventually, but I don't find it necessary to go back to Lion for this problem and I just hope the app will get an update!

    Good luck

  • Stepppy Level 1 (0 points)

    Hi evertdin

    Thanks for the advice, but I don't use torrents, so your tip doesn't apply in my case, but it may help others

    I am just hopeful that an update from Apple may put it back to the way it was before.


  • Stepppy Level 1 (0 points)

    As an update, my iMac will now stay awake if I am downloading from Safari, but not if I am downloading from Opera, so it looks like something may have changed in Opera

  • joebelow Level 1 (0 points)

    Stepppy, nothing changed in Opera. And that's the problem... in Mountain Lion, there's a new system for how it determines whether to go to sleep or not. In the past, Lion and earlier would check if there was any disk or network activity, and stay awake if there was. Not anymore. Now, every single program for the Mac has to be individually updated by its developers with new code that tells Mountain Lion not to go to sleep, if it's busy doing something.


    I'd imagine it has something to do with "Power Nap", since now the Mac can still do things like get notifications etc., while it's sleeping in a "Power Nap", so checking network/disk activity isn't valid.


    Anyway it's the stupidest thing. There are going to be millions of people frustrated by this, because so many apps have not (and maybe never will, for older ones) been updated - Opera, Firefox, uTorrent, jdownloader, etc., etc.,... So people are just going to take the easiest approach and set their computers to never sleep, and leave them there. Now you can kiss all the energy savings of this "new and improved" sleep system goodbye!

  • joebelow Level 1 (0 points)

    p.s. - there won't be an update from Apple to put it back the way it was before. But hopefully they will find a better solution to improve the way it is now. In the meantime, you can still use the tip from evertdin:


    open Terminal and use this command everytime I start downloads with uTorrent:

    caffeinate -i open -W -a utorrent.app

    (for other apps use that app's name instead of utorrent.app)

  • Stepppy Level 1 (0 points)

    Thanks for the info.


    I have solved my problem and switched out Opera for Chrome and it works just as it did before... result!


    So now I can leave my energy settings at the standard 10 minutes and even if my download has another hour to go my iMac stays awake until its finished, then it goes to sleep, just as it should