Previous 1 2 Next 19 Replies Latest reply: Feb 8, 2013 5:08 PM by
samuelsk Level 1 (0 points)

After installing OS X Mountain Lion, I haven't been able to add my printer back into the queue or find the appropriate software. I downloaded all the appropriate drivers from the Canon website and still can't print. What is going on?

iMac, OS X Mountain Lion
  • sberman Level 7 (32,307 points)

    I don't see your printer as being supported in the list of supported printers from Apple below:

    Click on Printer and Scanner Software to see the list I'm referring to.


    This list is not new for Mountain Lion - it even applies to Lion.

  • PAHU Level 6 (16,105 points)

    If you had an older version of the Canon UFR2 driver installed on Lion and then you upgraded to Mountain Lion, you often need to remove the older driver. This procedure is documented in the Guide included with the UFR2 driver you downloaded from Canon.


    With the old driver removed and the latest driver installed, you can then try to add the printer again. With it connected to the Mac via USB cable, it should appear in the Default printer view. If you don't see the printer, then check the USB cable.


    And regarding the list that sberman is referring to, the Canon laser products are not available for download from Apple and thus are not on that list. So just because a printer is not on that list, does not mean that it is not supported. It just means that the supporting driver is not available from Apple.

  • MyMac8MyPC Level 4 (1,460 points)

    The printer is listed and Canon has updated their drivers for 10.8 just a few weeks ago, so you should be good to go.


  • Malkie13 Level 1 (0 points)

    I just noticed that my MF4350D wasn't working today (oddly enough, because Excel started freaking out). Upgraded to Mountain Lion on release date.


    I tried what PAHU recommended in other threads for removing old versions, etc., and I still cannot print.


    In my case, the printer is connected to a Win 7 Ultimate machine in the other room. Up until Mountain Lion, I was able to print to it just /fine/. Now, I apparently cannot. At best, I get the -50 error. ANY suggestions?


    EDIT: (more info)

    When I try to print, I get a popup with the follwing:


    The printed output may be incorrect because the printer information has not been acquired.

    Start Printer Utility to get the printer information.


    Then I get the -50 error. The printe utility populates the info just fine.

  • PAHU Level 6 (16,105 points)

    The issue is that the most recent versions of UFR2 driver that you need for Lion and Mountain Lion cannot be used when the printer is being shared by Windows.


    Canon will be releasing shortly a new driver that may work when the printer is shared by Windows. So until then you will have to connect to the MF via USB cable.

  • Malkie13 Level 1 (0 points)

    Interesting. The printer worked fine under this setup with Lion since Lion originally released.

  • PAHU Level 6 (16,105 points)

    You must have been using an older UFR2 driver. The v2.30 meant for Lion and the current v2.41 for ML do not print when the printer is shared by Windows. You get the -50 error you mentioned previously.

  • Malkie13 Level 1 (0 points)

    There's a very real chance that's the case. I upgraded to a new MBAir this Spring, but I imported my profile over from my MacBook, so it probably pulled the driver over from that. It was probably the driver off of the original install disk. Wonder if I still have that just to try.

  • PAHU Level 6 (16,105 points)

    From memory it was probably v2.21 or earlier. This was the last time I remember the UFR2 working via a Windows share, although that was for XP sharing the printer. Windows 7 adds more constraints to printer sharing so check that you have Homegroups disabled and the network profile set to Home rather than Public.

  • Malkie13 Level 1 (0 points)

    Looks like it was 2.0 (that's what was on the original disc). Just gives the -50 error and the Printer Utility can't find the printer.

  • Malkie13 Level 1 (0 points)

    I'm starting to wonder if, perhaps, it had to do with some AirPrint Activator silliness I'd done at one point to be able to print from my iPad to the printer. By default, this printer doesn't seem to play nice with Windows Bonjour, but it used to show up as a Bonjour printer (on the Mac side) under Lion and Snow Leopard.

  • Malkie13 Level 1 (0 points)

    It looks like I will have to resort to USB for the Macs in the house (one Lion, the other Mountain Lion), since I can't even seem to get it to share wirelessly between the two of them either (FUN!). *sigh* I figured if I could at least get that to play nicely, maybe I could look into a used Mac Mini to use as a server for printing or some such.


    I called Canon, and near as the tech was able to guess was that since the printer had been working originally under XP Pro shared to OSX 10.5 and then the various machines were upgraded (including a profile transfer to new machines this spring) that /something/ carried over. As soon as I though to myself "Hrm, it's not working, well, lets clean install some new drivers all around" I broke the magical chain of whatever the heck kept it working. In /theory/ there should be new drivers at some point, but really, I can't say I want to hold my breath on that.


    Any advice for another multi-function laser (doesn't need to be color) that CAN be shared from Windows to Mac w/out giving myself an aneurysm in the process?

  • PAHU Level 6 (16,105 points)

    If you want to replace the printer then aim to get a printer that has networking support built-in. This way you won't have to rely on cross platform support or that sharing computer to be turned on to print. So a device with Ethernet or wifi support would be best. If you are happy to stick with Canon then I can recommend the MF4580dw, which is has built-in wifi.

  • b.nett Level 1 (0 points)

    A little help, please. I've OS 10.8.2, the Canon MF4350d, installed the proper printer driver that works with 10.8, connected the (turned on) printer using USB to the computer, when I try to add the printer, system preferences recognizes the printer but asks me to choose a driver or printer model. I need to select printer software but can't find any link to the software just installed on my computer & system preferences can't find it automatically. Appreciate your help.

Previous 1 2 Next