Skip navigation

Problems ejecting external drives

1254 Views 9 Replies Latest reply: Feb 25, 2013 11:46 AM by Steven Forwood RSS
glenmac45 Calculating status...
Currently Being Moderated
Aug 8, 2012 1:23 PM

I have a number of external drives used for backup, and apart from the drives failing (which has been too often for comfort) I have never had a problem with the ejection mechanism.  Until Mountain Lion.

I have just spent an afternoon trying to make a LaCie disk work properly.

For the past week or so the computer kept saying that the disk could not be ejected - do I want to force eject, which I did.

Today it did not even give that option, merely saying that the disk was in use.  This certainly wasn't the case unless there is a rogue program somewhere on my system.  One message did indicate that the System UI Server was the culprit, but other messages gave no clue.

Having saved all the files on the disk to the main hard drive, I played around with some disk utilities, but got nowhere because the utilities, including Apple's own, couldn't unmount the drive.

Having tried everything rational I decided on the irrational and just unplugged the disk.  This appeared to work.  It responded normally initially and I was able to reformat the disk.  But the problem came back.  I assumed that the disk had become corrupted and put it to the side.

I then tried another external disk.  And this one will not eject either.  The system says it is being used, which is certainly not the case.

I never ever had a problem with ejecting disks before Mountain Lion.

Is anyone else having this problem?  Has anyone found a work around? 

iMac, Mac OS X (10.5.8), Macbook
  • Knucklesmac Level 4 Level 4 (2,225 points)
    Currently Being Moderated
    Aug 8, 2012 1:44 PM (in response to glenmac45)

    Hello,

     

    Looks like the drive is being indexed by Spotlight. If you don't want that drive indexed open the Spotlight pane in System Prefs and add the drive to the Privacy tab. That will stop the indexing and you can eject.

     

    Best of Luck

  • Steven Forwood Calculating status...
    Currently Being Moderated
    Dec 26, 2012 10:25 AM (in response to glenmac45)

    This does not work for me. All of my external drives will not eject. Eject works fine with Snow Leopard and Lion using the same external drives. Can't find anything in Activity Monitor  or applications accessing the drives. Seems to me Mountain Lion is full of bugs. I am using 10.8.2. Anyone have any idea what in Mountain Lion is accessing these drives all the time. Spotlight is not accessing the drives as they are set up in Spotlight not to access them. With mountain lion I can't even run the combo updater again to fix any problems. Wish I could go back to Lion.

  • Eric Root Level 6 Level 6 (13,850 points)
    Currently Being Moderated
    Dec 26, 2012 1:21 PM (in response to Steven Forwood)

    You can download the updates:

     

    10.8.2 combo updater: http://support.apple.com/kb/DL1580

     

    10.8.2 supplemental update: http://support.apple.com/kb/DL1611

     

    You also might file a bug report with Apple so they know that some people are having a problem:

     

    Feedback: http://www.apple.com/feedback/

  • Steven Forwood Level 1 Level 1 (15 points)
    Currently Being Moderated
    Dec 26, 2012 2:09 PM (in response to Eric Root)

    Thanks but I've done all those updates and a lot of other troubleshooting and web searching. I guess I will file a bug report. Thanks.

  • baltwo Level 9 Level 9 (59,150 points)
    Currently Being Moderated
    Dec 26, 2012 6:13 PM (in response to Steven Forwood)

    Boot into safe mode and retry installing the COMBO update.

    27" i7 iMac SL, Lion, OS X Mountain Lion (10.8.2), G4 450 MP w/Leopard, 9.2.2
  • JohnMantooth Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 9, 2013 7:17 PM (in response to glenmac45)

    I had the same problem -- never an issue ejecting this drive in Lion, but once I made the jump to Mountain Lion, the drive seemed to be in a perpetual state of indexing.  As suggested above, I booted into Safe Mode and was able to eject the drive with no problem.  But before ejecting the drive, I added it to the privacy tab in Spotlight (so that indexing would not commence once I rebooted).  This worked, and I am now able to mount and unmount the drive without any issues.

  • Steven Forwood Level 1 Level 1 (15 points)
    Currently Being Moderated
    Jan 10, 2013 2:09 PM (in response to JohnMantooth)

    Thanks for your suggestions. I have already tried everything you mentioned in the months since I have been using Mountain Lion. The drives (USB 3.0 and firewire connected via Thunderbolt) will eject fine in Safe Mode but not after rebooting. They also all eject properly on my computers running Lion and Snow Leopard.  I have long ago completely turned off Spotlight completely and added the drives to the Privacy area. The only way I can eject any of these drives is to shut down the computer or Force Eject - which is not a good idea. Thanks anyway. I know it has something to do with Apples implementation of usb 3.0 and firewire via thunderbolt, but so far I have not figured it out.Thanks anyway.

  • Steven Forwood Level 1 Level 1 (15 points)
    Currently Being Moderated
    Feb 25, 2013 11:46 AM (in response to glenmac45)

    Finally solved the problems of external drives not ejecting. Get an application called LaunchControl. This app solved this problem I have had for months. The app showed me that a Steam launchagent was looking for a game on those drives for some kind of clean up process. I removed references to those drives in the Steam launchagent and all my drives now eject properly. This was not a problem with the system after all. LaunchControl is a very good application, I highly recommend it if you want a closer look at your launchagents and deamons.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.