3 Replies Latest reply: Aug 8, 2012 4:05 PM by Stymied again
Stymied again Level 1 Level 1 (0 points)

I've run into an annoying problem.

 

I've been given a CD, presumably originating from a PC, with a large number of jpegs. Having copied them onto my hard disk I find that most of them are not worth keeping. Unfortunately they're proving difficult to delete. They all ask for the system password before they can be put in the trash. In all cases the permissions are set to Read Only which is presumably why the password is required. However even after changing that to Read & Write I still can't trash them without a password. This only seems to apply to this particular set of files and I've not met it before.

 

What have I missed here?


OS X Mountain Lion, iMac 2.8 GHz Intel Core i7
  • William Lloyd Level 7 Level 7 (20,490 points)

    Where did you copy them?  Somewhere in your home directory?  Or to the root of the file system?  The latter could be troubling.

     

    It just be that the ownership or the permissions on the files is goofed up.

     

    This would be easy to make quick work of if you know the 'chown' command, because you could open a termina window and type something like:

     

    chown -R <yourusername>:staff

     

    And then before typing return, drag the folder with all the files on top of it.

     

    However if you haven't used the terminal there's a chance of getting it wrong.  <yourusername> is short for whatver your UNIX username is... also known as your user short name.

  • Stymied again Level 1 Level 1 (0 points)

    I dropped them on the desktop.

     

    I've tried the chown trick on both a folder and individual files but nothing seems to happen.

  • Stymied again Level 1 Level 1 (0 points)

    Problem solved.

     

    The 300 jpegs were on cd in three separate folders. I originally copied them to my computer in their folders and that's when the problems began. I managed to delete the folders and started again, this time just copying the files (not their enclosing folders) and they are behaving fine.

     

    Oddly enough the permissions still say Read only but I can delete them and change their file names without needing to use a system password.