13 Replies Latest reply: Nov 13, 2012 9:46 AM by PaddyRick
moneyman76542 Level 1 Level 1 (10 points)

(To see this exact same discussion but with the Log Files included, Click the link below)

https://discussions.apple.com/message/19210347

 

Randomly, When I restart my rMBP or boot up the screen goes black after i put my password and press enter. This forces me to hard reset. It sometimes does not even stop unless you boot to Safe Mode and toggle with the graphics settings. I thought it was GfxCardStatus Conflicting with a driver but this does not happen to be the case. I still use GfxCardStatus and just to be on the safe side for now, I open it from my Documents Folder after each boot. This really stupid and embarrassing at times when you have friends over and want to show off your mac's power and performance like Start up times for example and you have to explain to them that there are some bugs in "The World's Most Advanced Operating System Ever" OS X Mountain Lion. I live around Apple Haters who stick to Windows till death; If they saw this it would just add more fuel to the fire that "Windows is better than Apple". I'm paying for Premium high quality products from Apple, not garbage. Now this is an insult to the software, not the hardware but if I wanted to get black screen and errors then I could have just stuck with Windows and I could get that for free in 5 minutes visiting low quality ***** websites. lol.

 

Lastly, I want to note that during one episode of my rMBP's ******* blackout moment, after I got out of Safe Mode, restarted the computer, and logged in; Error messages involving KeyChain Access popped up. Apparently App Store, iMessage, iCloud, Address Book, Mail, and all other applications that used your accounts information was unable to information fro KeyChain. I don't remember exactly but it something like this "024739-39-a70h-892hh Could Not Access KeyChain. Would you like to Reset to Default?" I clicked "Reset To Default" but the messages continued to pop up that KeyChain cannot be accessed. It wasn't until a few Google Searches later that I can go to Utilities>KeyChain Access and use the First Aid Feature to fix the corrupted KeyChain File.

 

If you go to Utilities>Console and Open the System Diagnostics Report, The Window Server Crashes I believe to be the Blame as it involves the CoreGraphics. I have posted 2 most recent crashes of this nature and one of Security Agent which I believe is KeyChain Access.

To see the Logs go to my detailed discussion. Same subject but with "(Detailed)" added on to the end of the subject.


MacBook Pro (Retina, Mid 2012), OS X Mountain Lion
  • moneyman76542 Level 1 Level 1 (10 points)

    I uploaded the log files on a zipped folder:

    http://www.mediafire.com/?6lyp3rezqvpaxwe

  • cozar Level 2 Level 2 (340 points)

    Tough one. I don´t get any further than your own conclusions. Possibly, the fact that you are able to login to Safe mode is usually an indication of a bad startup item and often results in a kernel panic (which you don´t seem to have had).

     

    Still it can´t hurt to (in Safe mode) open Terminal and paste this (don´t type) at the command line:

     

    kextstat | grep -v com.apple

     

    and post the resulting list in the thread.

     

    I suppose you have done the usual routines of (in Safe mode) verifying the disk and repairing the disk permissions, as well as resetting pram and resetting smc.

  • aesk Level 1 Level 1 (0 points)

    I get the same thing, it has happened to me about 4 times, I just hard reset and on reboot it logs in ok.

     

    For me, this is coincides with another issue i'm having; once on external display disconnect and three times on wake, my display glitches (screenshot attached) – I think it's this issue - https://discussions.apple.com/thread/4036736?start=0&tstart=0. Though being unable to see anything useful, i'm forced to restart. When I do, the first login gets me the blank screen mentioned here.

     

    Gen 1 hardware..

     

    Screen-Shot-2012-08-05-at-9.12.54-AM.jpg

  • MarCB720 Level 1 Level 1 (0 points)

    Right there with you!

     

    I did not dropped 3 grand just to baby sit a machine. I exchange it for Air 13" 2.0GHz/512GHz/8.0Gb fully loaded instead.

     

    I know I will buy the 2nd iteration of rMBP, but not now. It's suppose to be a "Pro" for cryin out loud.

  • moneyman76542 Level 1 Level 1 (10 points)

    I hear that OS X 10.8.1 update will be released soon. I really hope they fix all these issues!

  • Joseph Buoscio, Level 1 Level 1 (15 points)

    I started having the same problem yesterday and today.  I would start up my rMBP enter my login info and get a black screen.  Could not wake up, all I could do was force shutdown and start up in Safe Mode.  Since the rMBP is only a couple of weeks old I contacted Apple and talked to a tech.  She had me go to my Root library file and remove any non-apple files from the Launch Agents and LaunchDaemon files.  She then had me check the StartupItems in the same Library folder and the Syster/Library folder.  I did not have any files in these folders.  She finally had me check my account Library file (Use the Go Menu and hold down the control key)  There she had me removed any non-apple files from the LaunchAgents.  I emptied the trash started up and all is well at this time. 

     

    Hope this helps

  • cameronring Level 1 Level 1 (0 points)

    I'm also having this same problem. Seems to happen about once every 3 boots. My crash is in the same place (sys_show_cursor + 840):

     

    Thread 5 Crashed:

    0   com.apple.CoreGraphics                  0x00007fff9198b2c8 sys_show_cursor + 840

    1   com.apple.CoreGraphics                  0x00007fff9198c817 update_cursor_data_callback + 207

    2   com.apple.CoreGraphics                  0x00007fff91641f7f run_timer_pass + 299

    3   com.apple.CoreGraphics                  0x00007fff917b25a4 eventTimerCallback + 13

    4   com.apple.CoreFoundation                0x00007fff8a0844b4 __CFRUNLOOP_IS_CALLING_OUT_TO_A_TIMER_CALLBACK_FUNCTION__ + 20

    5   com.apple.CoreFoundation                0x00007fff8a083fcd __CFRunLoopDoTimer + 557

    6   com.apple.CoreFoundation                0x00007fff8a0697b9 __CFRunLoopRun + 1513

    7   com.apple.CoreFoundation                0x00007fff8a068dd2 CFRunLoopRunSpecific + 290

    8   com.apple.CoreFoundation                0x00007fff8a077a81 CFRunLoopRun + 97

    9   com.apple.CoreGraphics                  0x00007fff917b2207 eventThread + 379

    10  libsystem_c.dylib                       0x00007fff870ea782 _pthread_start + 327

    11  libsystem_c.dylib                       0x00007fff870d71c1 thread_start + 13

  • mdproctor Level 1 Level 1 (0 points)

    I found one issue was related to Skype, for rMBP. It would not resume from sleep if Skype was loaded. I could log in, but the screen would be black, as I moved the cursor around and windows, stuff would display but corrupted. So now I never let my rMBP sleep, however I'm still getting black screens,that won't even let me login and I have to power reset - for which I have no answer yet.

  • mdproctor Level 1 Level 1 (0 points)

    Here is a nopaste of my log, http://pastebin.com/furjszPy, from the recent blackscreen issue.

  • cameronring Level 1 Level 1 (0 points)

    here are full logs for my most recent (yesterday) WindowServer crash.

     

    crash log:

    http://pastebin.com/YNK3C2sG

     

    system log:

    http://pastebin.com/swsg6YAM

     

    it looks like WindowServer restarts after the crash but apparently not in a way that actually works.

  • PanzrKunst Level 1 Level 1 (0 points)

    In my case it's due to a full screen app (Chrome) that is relaunched at login.

  • PaddyRick Level 1 Level 1 (0 points)

    I had the same problem. My graphics caused the problem, everytime it switched from NVidia to Intel I got that black screen, even on login.

    I don't know if it helps, but today I found a tool to reset the "PRAM" (I used iFunctions. Probably you can do that via "Terminal" or however), don't know if this fix is reproducible. I hope for you guys.

     

    ______

    (Fixed it since minutes, maybe the problem will come back)

  • PaddyRick Level 1 Level 1 (0 points)

    Edit: Doesn't fix the problem, sorry for spam.