Previous 1 2 3 4 Next 56 Replies Latest reply: Jun 1, 2015 7:48 AM by tsoanes1 Go to original post
  • tom17 Level 1 Level 1

    I went with Jose Rodriguez Alvira's solution and it seems to have worked for me.


    I had been using Time Machine with Snow Leopard (10.6.8) for well over a year with no problems, then the upgrade to Mountain Lion seemed to cause massive backups, some reaching well over 60GB.


    Having installed TimeTracker, I checked the individual backups and it seems that, occasionally, TM would only backup my Users folder (no Applications, System folders, etc), meaning that the next backup would include all these folders from scratch.


    By deleting the plist file (Macintosh HD - Library - Preferences - and making sure it was deleted from the trash, I was able to continue doing normal backups.

  • willmtaylor Level 1 Level 1

    I tried the above-mentioned fix to no avail. My backup size is still ever-increasing despite having followed the steps. Not sure what to do next.

  • Jose Rodriguez Alvira Level 1 Level 1

    After deleting the files, when you turn TM on, you should not see a previous back up date. If you see a previous backup date it means the plist files were not deleted. In my case I deleted the files and then emptied the trash. If you see the previous back up date, you may want to try that. Also be sure to unmount the backup disk and turning off TM before deleting the files.

  • Richatom Level 1 Level 1

    This solution worked for me for a few days only. I am now back to 20GB+ backups.

  • dape_75 Level 1 Level 1

    Same problem here. Every once in a while my hourly backup grows to 35GB. Comparing the 35GB backup to the one before I see that it backed up the entire library, application and system folders. But this happens only when I back up to my time capsule. I do not get these huge backups when I plug my external HD via USB.

  • Ivo G. Level 1 Level 1

    I had a sparseimage disk mounted while doing a backup. I think this problem might have something to do with this; it might not have backed up properly the last couple of times, maybe because this sparseimage disk wasn't included in the exclusions or something.


    TM semed to work OK without this - it performed a large backup with a fixed total size properly estimated (no moving-target problem now!), and then after that it performed a small (appropriately tiny!) backup the second time I clicked.


    P.S. Also, after I unmounted the sparseimage disk, I also disconnected and then reconnected the backup disk.


    I don't know why, but I suspect this has something to do with it, though probably there are other causes for this problem.

  • dape_75 Level 1 Level 1

    I deleted my Timecapsule and did a full new backup. I followed the steps to delete the backup plist file. Everything worked fine for 2 days. Then again a 35GB backup again. This drives me nuts as it is not happening when i do parallel backups to an external HD via USB.



    11.12.12 12:06:45,998[18389]: Starting automatic backup

    11.12.12 12:06:49,175[18389]: Attempting to mount network destination URL: afp://David%20xxx;AUTH=SRP@David-xxx-Time-Capsule.local/Data

    11.12.12 12:06:58,103[18389]: Mounted network destination at mount point: /Volumes/Data using URL: afp://David%20xxx;AUTH=SRP@David-xxx-Time-Capsule.local/Data

    11.12.12 12:07:47,031[18389]: Disk image /Volumes/Data/David xxx MacBook Pro.sparsebundle mounted at: /Volumes/Time Machine Backups

    11.12.12 12:07:47,035[18389]: Backing up to: /Volumes/Time Machine Backups/Backups.backupdb

    11.12.12 12:08:00,280[18389]: Using file event preflight for Macintosh HD

    11.12.12 12:08:01,690[18389]: Will copy (60.6 MB) from Macintosh HD

    11.12.12 12:08:01,696[18389]: Found 135 files (60.6 MB) needing backup

    11.12.12 12:08:01,705[18389]: 2.22 GB required (including padding), 1.5 TB available

    11.12.12 13:08:00,190[18389]: Copied 19.21 GB of 19.21 GB, 277398 of 277398 items

    11.12.12 14:08:00,755[18389]: Copied 29.28 GB of 29.28 GB, 470803 of 470803 items

    11.12.12 15:00:31,064[18389]: Copied 715064 files (34 GB) from volume Macintosh HD.

    11.12.12 15:00:32,071[18389]: Using file event preflight for Macintosh HD

    11.12.12 15:00:33,499[18389]: Will copy (16 MB) from Macintosh HD

    11.12.12 15:00:33,506[18389]: Found 114 files (16 MB) needing backup

    11.12.12 15:00:33,508[18389]: 2.62 GB required (including padding), 1.47 TB available

    11.12.12 15:01:18,452[18389]: Copied 3231 files (16.2 MB) from volume Macintosh HD.

    11.12.12 15:01:20,293[18389]: Created new backup: 2012-12-11-150118

    11.12.12 15:01:28,938[18389]: Starting post-backup thinning

    11.12.12 15:01:42,750[18389]: Deleted /Volumes/Time Machine Backups/Backups.backupdb/David xxx MacBook Pro/2012-12-10-115649 (15.4 MB)

    11.12.12 15:01:42,751[18389]: Post-back up thinning complete: 1 expired backups removed

    11.12.12 15:01:43,289[18389]: Backup completed successfully.

    11.12.12 15:01:46,292[18389]: Waiting for Spotlight to finish indexing /Volumes/Time Machine Backups/Backups.backupdb

    11.12.12 15:02:51,305[18389]: Waiting for Spotlight to finish indexing /Volumes/Time Machine Backups/Backups.backupdb

    11.12.12 15:04:14,035[18389]: Ejected Time Machine disk image: /Volumes/Data/David xxx MacBook Pro.sparsebundle

    11.12.12 15:04:14,461[18389]: Ejected Time Machine network volume.

  • Richatom Level 1 Level 1

    Same here.


    Deleted Time Capsule, did a full back up. Everything fine for a couple of days - then suddenly a huge 35GB backup. So I deleted the backup plist file as suggested. Everything worked fine again for a few days - then suddenly huge backups again.

  • ukboris Level 1 Level 1

    I tried this and it worked perfectly - thank you!

  • KrisKinD Level 1 Level 1

    2 applications, Diablo III and Guild Wars 2, caused my TM backup size getting biggger and bigger. These are huge container apps and whenever files get updated within the container (happens quite often), the whole container gets backed up again. I excluded these apps and now the size is down to normal.

  • Marcus Muench1 Level 1 Level 1

    Well, my original problem is not the size of the backups itself, it's that many backups start with an estimated size of i.e. 6GB, and at the end of the backup process the resulting size of this backup session is about 80GB, although no application was started or running while the backup was in progress. I think TimeMachine should be able to make better size estimations than this. The miscalculation leads to another problem: Before the backup starts, TimeMachine is cleaning up the TimeMachine volume so there is enough space on it for the backup. But if the estimated size is 6GB, and there are 8GB free on the volume, TimeMachine cannot finish the backup and fails with "not enough disk space". I never had this problem with Snow Leopard or Lion, only with Mountain Lion.

  • Jose Rodriguez Alvira Level 1 Level 1

    It happened again today. A backup that started at 431 MB kept growing until I stopped it at 8 GB!


    No idea of why it happens. No new apps, no system updates, I had not worked with any big files. Just when the backup was reaching the 400 MB the estimated backup size kept growing and growing.


    Repeated the steps previously described (delete the plist file etc.) and now back to normal after a big backup (116 GB). All my previous backups are there. Who knows until when...


    I hope Apple does something about it.

  • hyperlinked Level 1 Level 1

    Massive Time Machine backups have been really driving me crazy for a while. I've finally discovered the cause of my massive Time Machine backups. The culprit was TechTool Pro. The directory backup feature in it creates massive directory data files for every volume it is aware of including past Time Machine disks that I've used.


    I was previously using a Snow Leopard MacPro with one of my four drive bays occupied by a 2Tb Time Machine disk. It was doing massive backups then too, but since I didn't suffer notable performance issues when it would backup, I wasn't aware something weird was going on.


    Now that I'm on a Mountain Lion Laptop synching to a Time Capsule disk over WiFi, I'm much more aware that my backups were out of control. I was having no luck finding the cause for the past two months until just now.


    I looked in /Library/Application Support/TechTool Protection and the directory size was 90Gb. It was generating directory backup files that were more than 4Gb in size several times a day. Ok, that would explain how my backups could get so massive with so little seeming to happen. In all, my TechTool Protection folder was over 90Gb in size.


    I turned off the directory backup feature in Techtool and my Time Capsule backups have been pretty manageable since.

  • Jayachandran B Level 1 Level 1

    I stumbled upon this page while searching Google for a solution to the exact problem most of the users seem to have here; Time Machine back up size are increasing (or not changing) even if there is no change in the system.


    I couldn't find the proper answer here, so I looked elsewhere and found a very useful program Time Tracker via


    Basically it shows you all the backups in a list form and the files that were backed up. So its essentialy the delta. Allow your backup to be complete (even if you think the size is large) and then check Time Tracker to see which files were backed up.


    This will give you a clue as to whether you had modified the file or not.


    In my case the issue was caused due to an encrypted disk image file I keep with all my important files. I load it everytime I am infront of my mac and then unload it before leaving :-). So what was happening was that each time the disk image loads and I make a small modification to one of the file in there and eject it, for TM the dmg changed. Thus it tries to back up the 32GB of dmg everytime I touched any file in it. I have excluded the file and for the last 5 times my back ups are of normal size (less than 1GB, which is what I expects as well).


    Hope Time Tracker will give you all what your root cause as well.


    PS: It is an independent download, so please use it at your own risk. I do not take responsibility if something goes wrong. It worked for me and that's all I can say about it.

  • Gilby101 Level 1 Level 1

    Nothing against Time Tracker, but (I am a user, not the developer) is more capable.  I recommend it for tracking the size of all your TM backups and for investigating what files are causing large backups.