Previous 1 2 3 4 Next 56 Replies Latest reply: Jun 1, 2015 7:48 AM by tsoanes1 Go to original post
  • Jayachandran B Level 1 (0 points)

    After trying backuloupe, I like it better than time tracker. Better looking and has some additional features. Thanks for sharing.

  • DocMojo Level 1 (0 points)

    Same problem here - I tried deleting preferences and restarting TM, but continue to get backups that start at around 250meg, but continue growing up they get to 11gig and the backup drive unexpectedly runs out of space.  Installed Time Tracker and I can see these large backups seem to occur every few days, then it goes back to normal.  Contents of the large backups are not a full backup (Mac HD used space currently at 70GB) but it always includes folders Applications, bin, Library, private, sbin, System, Users, and usr.  I'm not running VMware and have a single disk partition.  How do you get a problem like this fixed?  Does Apple provide tech support for these kinds of issues, or are these forums the only way to get help?

  • Gilby101 Level 1 (10 points)

    DocMojo,  You problem sounds like the problem I had.  For a single backup TM decides to NOT backup Applications, etc.  The result is that on the next backup it does a complete backup of all those files (in my case an extra 60 GB).  And then it is happy for a few days.  Please look at my comment near the start of this thread and in thread:


    Since I have removed the ExcludeByPath key (look in my postings for this), everything has been stable for me.


    This may or may not work for you.  In any case it may give some hints as to where to look.

  • DocMojo Level 1 (0 points)

    I deleted the plist again and before I backed up I took a look.  Neither the IncludeByPath nor the ExcludeByPath keys were there.  The backup included all the system files and completed successfully.  AFTER the successful backup, I looked again at the plist and saw the following:













    I then did a manual backup with this IncludeByPath key, and all that was backed up was a 2meg file - none of the system files were backed up, even though the IncludeByPath key was in the plist.


    This leads me to believe that this key does not force backups of the system files, but includes them in the selection criteria if they have been updated since the last backup . . . ?  Don't know why this would be needed, since there is another key SkipSystemFiles (which is FALSE in mine).


    So now I'm still confused as to what is going on.  Without getting to far into the weeds, looks like my only option is to exclude system files and then manually include them on a regular basis (weekly?) or buy a big backup disk.  Hmmm, maybe this is a ploy to try and sell more hardware in a down economy?

  • Gilby101 Level 1 (10 points)

    My experience is that everything is happy so long as the IncludeByPath key continues to be present (as you have it) and the ExcludeByPath never appears.  If this is so, then I don't think you need to go into contortions over manually excluding/including system.  But your experience my be different.


    I don't properly understand the relationship between the IncludeByPath and SkipSystemFiles keys - you may well be right that IncludeByPath's role is to make them available for selection.

  • DocMojo Level 1 (0 points)

    I sure hope you are right Gilby101 - I will monitor TM over the next few days to see if it returns to a state of happiness or not.  Thanks for your help.

  • Shabab28 Level 1 (0 points)

    I am having the same issue and the ext USB HDD is brand new. I don't understand it's kind of worrying. I thought the disk was corrupted like it did so many times when I used the Airport extreme but disk utility said disk is ok but back ups keep on getting larger. Having plugged it straight to the computer I am not supposed to have the same issues I had with Airport extreme, it is a bit weird. It is not the first time I am observing these behaviours each time I had to start an 8 hours back up it is getting really annoying!

  • hyperlinked Level 1 (0 points)

    Are you using anything that would be taking directory snapshots like TechToolPro? That was my problem. Directory snapshots can be responsible for several gigs of data changes every few hours and cause some massive massive backups.

  • Shabab28 Level 1 (0 points)

    No I am not! I don't even use none of what the other users mentioned (e.g. Parallel desktop)

  • ivansky Level 2 (265 points)

    I have read through this thread because this problem is rapidly consuming my Time Machine disk space too. I don't think any of the suggestions in this thread so far will solve my problem. For instance, I don't run any virtualisation software so I don't have any giant image files that change all the time.  I don't run TechTool Pro. However, I have installed BackupLoupe and there are some concerning results that I'm not sure have been described here, even though it sounds like others are having the same problem I am.


    When I look into the files being backed up, it appears that some files, particularly applications in my Applications folder, are being backed up for no obvious reason.  Of course, some applications have updates installed from time to time, for instance, Firefox has regular updates. However, my entire Applications folder (as far as I can see) is being backed up perhaps every two or three days (I haven't ascertained an exact frequency). This is odd because most of those files aren't changing, as far as I can tell.


    Today, not only was my Applications folder backed up, it appears that every mobile app (from Music/iTunes/Mobile Applications) was also backed up. A few of these were updated a couple of days ago and so were legitimately due for backup. The others claim they were modified at the time of backup (according to BackupLoupe's history window) but there is no reason for them to have been modified. Finder tells me the files were last modified over a month ago.


    So I think there is a problem here - whether TimeMachine is incorrectly identifying files for incremental backups, or if something is modifying the time/date/metadata for these files to cause them to be backed up regularly for no good reason. It seems to be a new "feature" of Mountain Lion, as I have not had this problem before.  I have just encountered it on my new MBP. I think I will try to use my 90 days of telephone support and see if Apple can come up with any suggestions, as soon as I get a chance to call them.  If I find any solutions or useful information I will try to post it to this thread.

  • dingsquidge Level 1 (0 points)

    This has just started happening to me: today's back up is 329GB (incl padding, 272GB net).  That's over two thirds of everything on my HD (380GB).  ???  I was having problems with Aperture 3 today so rebuilt the library and repaired permissions, but my library is only 126GB so that's not it. 


    My backups dated back to December 2010, and the machine is now deleting old backups like crazy to create space for this new one, so already my oldest back up is now June 2011.


    I have no idea what has set this off.  I'm forever having to rebuild my Aperture library (that's another forum of Apple irritation) but that hasn't caused this to happen before.  Have had ML for months too. 


    I have no idea what Windows is like nowadays but just feel that Apple is now where Windows was when I felt forced to jump. 

  • Pondini Level 8 (38,715 points)

    This might be related to some other reports we've seen lately.  They have different (and much worse) symptoms, but may have the same or similar cause.


    Please see this thread:

  • Pondini Level 8 (38,715 points)

    To those with this problem:


    We've now got a clue about some other users with what seems to be a similar problem.  The difference is, once their system folders stop getting backed-up, they don't start again, as yours seem to.


    Obviously, we don't know if you're having the same problem, but would like very much to get your help running this thing down. 


    If so, a fix (likely temporary in your cases, though) is to replace the plist, per #A4 in Time Machine - Troubleshooting


    We don't know yet, but it seems this may not really be a problem with Time Machine at all, but some app, somewhere, that's telling Time Machine not to back up those folders, for some reason.  If any of you have any idea of what app that might be, please let us know.


    And please, if any of you can, while the folders in question are not being backed-up, send a copy to me at the address on my website's Contact page.  Feel free to post here or e-mail me there if you have more info or questions.


    Also, if you can determine when it switches from proper operation to not backing-up the folders, and what you were doing, or had installed, about that time, that might point us towards a culprit.


    Thanks very much for anything you can do.

  • mrkgoo Level 1 (10 points)

    Had my first occurrence of this phenomenon.


    Just tried updating my iPhone to iOS7, new term and agreements in itunes (which actually timed out), then a Time Machine was HUGE (16GB).


    I doubt the situations were related, but just reporting what happened. TimeTracker suggests a bunch of system files and Applications folder were included in my backup.


    edit: on inspection, this is the issue relating to D10 in Pondinis TM page. Some of my backups don't have teh System, Library, or Applications folders.


    For what it's worth, I'm on a 2012 iMac with a fusion drive, and I have restored from Time Machine once.


    ML 10.8.5

  • mrkgoo Level 1 (10 points)

    As an aside, if this happens, and then you get a HUGE back up - does this correctly restore the System Library, and Applications folders to the Time Machine backup? i.e., will that Time Machine still be ok to do a restore from? (not the date with the missing  folders, obviously)