Previous 1 2 Next 19 Replies Latest reply: Dec 10, 2013 6:24 AM by iWhacko
Scantor22 Level 1 Level 1 (0 points)

After a lot of difficulty, I was able to open up the App Store properly due to a black screen and it saying I was connected to the internet when I really was.


The real problem now is how to sign in. When I press the sign in button on either the Store tab, then Sign in, nothing happens, also, when I go to the purchases tab or the featured tab and I press the sign in button, the text window does not pop up. Please help me just figure out how to get the app store to respond to me pressing sign in.




On a side note, this never happened to me when I was on lion or Snow Leapord, only Mountain Lion have I encountered this problem.

iMac, OS X Mountain Lion
  • Carolyn Samit Level 10 Level 10 (100,440 points)

    Mac App Store: Sign in sheet does not appear, or does not accept typed text

    Disable anti virus software and try turning off the Firewall in System Preferences > Security & Privacy > Firewall

  • Scantor22 Level 1 Level 1 (0 points)

    Firstly, I don't have any anti virus softwares and my Firewall is also turned off.



    Secondly, By reading over that page you suggested me too, it made me think that I possibly may have deleted something that shouldn't have been deleted. I use this application, "Clean my Mac," in order to clean out the computer and delete certain items, caches, etc. There's a chance by using that application, I checked off a few too many boxes for which items to delete... If this is the case, is there any way to recover those items or I guess you could call it "resetting the App Store?"


    Also, I've tried restarting the iMac numerous times, which hasn't helped.

  • Mayemac Level 1 Level 1 (5 points)

    Why do we have to disable the Firewall? I do also have this problem since upgrading to ML. I have been wanting to buy something for the past two days without any luck since I can't login or download any software. The suggestion in the link above is to re-install the OS again but I dont want to do that. Any other tips or suggestions?

  • Scantor22 Level 1 Level 1 (0 points)

    I just tried to reinstall OS X although it came up with an error message saying that the disc could not be installed on this drive or something similar to that. Basically, it showed a picture of the Hard Drive although with a yellow exlamation point. If I could re-install it, I would, just any fix to this issue as well to reinstall OS X (Snow Leapord) or is there another way to do reinstall it, by the way, I'm also using the disc I bought the computer with.

  • Carolyn Samit Level 10 Level 10 (100,440 points)

    Your profile indicates you are running Mountain Lion which means you cannot use the original disc that came with your Mac to reinstall OS X.


    You must use OS X Lion: About Lion Recovery


    "Clean my Mac," in order to clean out the computer and delete certain items, caches, etc. There's a chance by using that application, I checked off a few too many


    A word to the wise...  third party so called cleaning utilties such Clean My Mac cause far more harm than good on a Mac. Your Mac runs maintenance for you in the background.


    Definitely uninstall that software. Download this free utility > Download AppCleaner for Mac - Uninstall your apps easily.


    That will not only uninstall the Clean My Mac app but all the associated files.


    Then try the App Store BEFORE using Lion Recovery.

  • uzzel Level 1 Level 1 (10 points)

    I had the same problem and I tried almost everthing. The Apple support now suggested to run a fresh and new Lion on an new hard disk partition. The App Store runs after that. It seems that Apple has problems with Lion or Mountain Lion sytems that have been installed over a Leopard System. That is what I did. I recovered my hole system from a Leopard Time Machine Backup and than updated to Lion. Antivirus Sofware can have an effect on the App Store loggin too, but it wasn't in my case. I uninstalled my Antivirus Software without success to the App Store Problem. I Hope this information is helpful.


    Install a fresh new System and the App Store will run again.

  • Mayemac Level 1 Level 1 (5 points)

    You are right, removing the anti-virus software or turning off the firewall doesn't solve this problem. That's not a good step to take since the App store should work with the anti virus without problem. I started having problems with this once I upgraded to ML. Before that, everything was working fine with my computer with the antivirus and firewall on. An update should be put in place for this problem ASAP. They are loosing money with people that can't buy apps!!

  • ajistewart Level 1 Level 1 (0 points)

    if you go into network preferences, go to your network connection's advanced settings and manually add the DNS servers for your ISP, don't point it to your modem, and that should solve the issue

  • Tenaciousgreen Level 1 Level 1 (0 points)

    No that didn't work for me either!  This is an apple problem and they must provide a fix.

  • Mayemac Level 1 Level 1 (5 points)

    Not sure if this will work for everybody and I'm not sure how I fixed it but this was the last thing that I did:

    1. Opened system preferences
    2. Opened the Security and Privacy options
    3. Under the General tab/options I changed the option from Anywhere to Mac App Store and identified Developers under the Allow Applications downloaded from options.
    4. Re-started the mac and the App Store started working again.

    Again, I'm NOT sure if this was exactly what fixed the problem since I did a few things and unfortunately didn't write them down. So hopefully this will help somebody here.


  • joshfreeman Level 1 Level 1 (5 points)

    I've tried everything I've seen on these forums except a complete system re-install. Really not looking forward to doing that. I've lost enough time to this problem as it stands. Anyone have any further information?

  • that_rat Level 1 Level 1 (0 points)



    I stumbled upon this post because I was having a similar problem with a parentally managed account.  The main administrator account had zero issues accessing the Mac App store, but the parentally managed account just wouldn't access the Mac App store [black screen on just about all of the sections, wouldn't authenticate with Apple ID].  I decided to create a new test account to see if the problem existed there as well.  The new test account didn't have any issue accessing the Mac App store [no black screen and able to authenticate with Apple ID].  In the new account, I sorted the preference files from newest to oldest and noticed that was towards the top of the list.  In the parentally managed account that was having issues, I deleted that file so it could be re-created when I re-opened to Mac App store, and the app opened properly with no black window and I was able to authenticate.  I thought I would post this here since I stumbled upon this post while researching this seemingly bizzare problem.  Granted this is many months after the original post, but this worked for me.

  • TPTS Level 1 Level 1 (0 points)

    I had this same issue and this is what I noted on my end:


    From the top Menu Bar->Store I noted that the sign in option had sign out, so I knew that the application thought that it was signed in even though it would not allow me to view my purchases.  Thus, it was caught in a loop of some kind.


    Below menu item: Menu Bar->Store->Sign Out I clicked on “View My Account (My Apple ID)” which prompted me for my password to my Apple ID which I entered.  Once doing so, this seemed to reset the account info within the App Store application and allowed me needed access.


    Hope this help.  :-)

  • Ed Hovanec Level 1 Level 1 (0 points)

    I recently developed a problem with the App Store sign-in sheet. Whenever I tried to enter my password, I'd get trapped in a loop with my password never being accepted.


    I tried a TechTool pro File Structure test and it flagged "com.applestore.plist" as  (Unexpected character c at line 1)


    I went to  Users/Username/Library/Cookies/ and deleted "com.applestore.plist"


    I also discovered a file "Cookies.binarycookies corrupt." Deleted that as well, as there was a clean version of it there.


    I'm now able to log into App Store, view my account information, download updates, as well as view Purchases.


    This is in OSX 10.8.4, so not sure if it applies to Snow Leopard.


    Good Luck.

Previous 1 2 Next