Skip navigation

Can't Sign into the App Store?

12571 Views 19 Replies Latest reply: Dec 10, 2013 6:24 AM by iWhacko RSS
  • David Johen Calculating status...
    Currently Being Moderated
    Jun 19, 2013 11:23 AM (in response to Ed Hovanec)

    Thank you so much, Ed!


    it worked!

  • Coi-l Calculating status...
    Currently Being Moderated
    Jul 1, 2013 10:45 PM (in response to Ed Hovanec)

    Thanks Ed!


    I was getting this problem in red text when I tried to sign in:

    ConnectionManager::invoke::Failed to find service connection url.


    Sure enough, quitting App Store and deleting the two App Store files under Library/Cookies did the trick.


    I also just did an upgrade from Snow Leopard to Mountain Lion.

  • Daniel Shock Calculating status...
    Currently Being Moderated
    Nov 21, 2013 11:22 AM (in response to Ed Hovanec)

    I just wanted to add my thanks - because this also worked for me - however, I had to modify it for my situation.  And here is my modificaiton - for anyone else who has the problem:


    I had the same problem as described - except that I noticed that I COULD login when logged in under the guest account (or any other account).  Just deleting the cookies and allowing them to recreate was not enough for me.  I had to


    1. login to the guest account,

    2. then login to mac app store

    3. copy the newly created cookie ( to another drive

    4. logout

    5. log back in to my regular account

    6. copy the cookie from external drive back to my library.

    7. open mac app store and login - it worked!


    So, I assume that some corrupt data is being copied from icloud or something and that's why re-creating the cookie wasn't working.


    Anyway - thanks for pointing the way!!!

  • easii Calculating status...
    Currently Being Moderated
    Dec 1, 2013 8:27 AM (in response to Ed Hovanec)

    I tried Ed's solution (deleting the suggested files from the Cookies folder) but it didn't work for me on my Mountain Lion system (upgraded from Snow Leopard).  I hunted in Library/Preferences (access by holding the option key and selecting from the Go menu while in Finder) and found:  Dragged that to the trash, and voila!  App Store worked again.

  • iWhacko Calculating status...
    Currently Being Moderated
    Dec 10, 2013 6:24 AM (in response to Scantor22)

    this worked for me: -in-os-x/


    I did have to do a restart aftwerwards before I was able to login again and update my apps.

1 2 Previous Next


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.