Previous 1 2 3 4 5 Next 69 Replies Latest reply: Jun 14, 2013 11:59 AM by jtclary89 Go to original post
  • gregory73 Level 1 Level 1 (0 points)

    Where do you go to uncheck those items.  I'm having the same problem.  I went to activity monitor and stopped the SystemUIServer and that worked, but I don't want to have to keep doing that.  I also use time machine and notice the freeze after the system goes to sleep.  I have a 2007 iMac.

  • Pete Davis Level 1 Level 1 (5 points)

    Yes that did it for me too - thank you sooo much - my laptop is back to humming along with almost none of the occasions where it took 10 minutes or more to wake from sleep etc

     

    I removed the following from menu bar - and haven't bothered testing if any particular one is the culprit - but am most suspicious about Time Machine - as I think I was having the most problems when Time Machine tried doing a back up while 'sleeping' - may not make sense technically but it is the only 'random' event i can pin it down to - random as in the machine both being in a particular state, and something being scheduled to happen.

     

    Anyway - happy punter now.

    For others - go to Preferences, find Time Machine, uncheck the 'show in menu bar'

  • Pete Davis Level 1 Level 1 (5 points)

    Go to System Preferences, find Time Machine, uncheck the 'show in menu bar'

     

    As an indicator of how well things are chugging along I also suggest

     

    setting your clock to show seconds - then you can instantly see if the systemUIServer is running too hard afaik

     

    Have Activity Monitor running and set it to

    - Window -  CPU Usage

    -  View - Dock Icon - set CPU

     

    That way you have another indicator if something starts sucking up lots of cpu

  • MatFont Level 1 Level 1 (0 points)

    I've experienced the same problems you guys reported until now - SystemUIServer using +/- 2.5gb of mem, almost 100% of CPU.

     

    I own 2 different Macs and in one of them (MacMini - mid 2011) this problem occurs constantly when its stays turned on for a long period, including sleeping periods. The other Mac (MBP - late 2008) this problem had never occurred, and it also stays turned on for days!

     

    Both Macs runs MLion 10.8.2. But the problem only occurs in the mac that came with with OS X Lion already installed - MacMini. The MBP late 2008 came with Leopard, and it has been upgraded with all versions of OS X since then, up to MLion.

     

    I think that the problem is because of the migration to MLion from different versions of Lion, because its starts happening since this migration. 

     

    Att

  • jag2009 Level 1 Level 1 (0 points)

    Looks like there are actually a couple ways to fix this.

     

    I have been having the same problem, and today I also noticed my clock hadn't been showing the correct time in about 2 hours, and when I hover over the clock I get the spinning beach ball.

     

    So I found from this article that you can simply kill the SystemUIServer process and it will just restart itself and all should be well again.

     

    In order to kill the SystemUIServer process, you can simply open Activity Monitor, Filter by Process Name or %CPU (as it will likely be the highest CPU user), then select "SystemUIServer", and choose "Quit Process" from the options at the top of the window (button that looks like a stop sign).

     

    Once you kill the process, OS X will simply re-initiate the process, and you should be back on track. However this seems to be only a temporary solution, and you may encounter it again.

     

    So for a more permanent solution (if you are not afraid to venture into terminal land), try the process outlined in this article, which was provided by Joshua Taylor where you add a cron job to OS X that restarts SystemUIServer at the beginning of every other hour (automating the solution above to this problem):

     

    Open your terminal (/Applications/Utilities/Terminal.app).

    Type:

    crontab -e

    ..and hit enter.

    Hit the letter "a" on your keyboard.

    Enter the following, using tabs for the large separations:

    0     */2     *     *     *    killall SystemUIServer

    Hit the escape key on your keyboard.

    Type:

    :wq

    ..(that's colon, w then q) and hit enter.

    Close Terminal.app.

  • pixelkitten Level 1 Level 1 (0 points)

    Your solution involves restarting SystemUIServer once every 2 hours... but I've had to kill it about every 2 MINUTES and it keeps hogging the CPU and freezing everything. I've never used Time Machine and it was never in my menu bar. I did have the Wifi icon, but I've removed that and had no luck.

     

    Anyone got another solution to this?

  • MatFont Level 1 Level 1 (0 points)

    Thanks for the solution provided by Joshua Taylor, jag2009. It seems better than keep killing SystemUIServer every time it freezes my MacMini.

     

    I've already suspected that iStats were causing these problems, and I'm still not 100% sure that its not involved.

     

    Pixelkitten, take a look at your Spotlight Privacy setup. It might be one of the responsible. Check all the process that are running in Activity Monitor, filter them by My Process, that means your user, see what is consuming more memory and quit them. Check how long it takes to freezes.

     

    Btw, I use Time Machine and it had never caused me any freezing problem. I don't think active icons in the menu bar is causing a 2 minutes freezing problem. It might be a bigger ou heavy process running togehter.

  • pixelkitten Level 1 Level 1 (0 points)

    MatFont, every time I check Activity Monitor, SystemUIServer is the only "culprit" using all my system resources. I've timed it and it will literally take anywhere from 1 to 10 minutes for SystemUIServer to hog the CPU after it relaunches itself, every time. I have tried:

     

    - restarting my computer

    - running a full system "clean up" with Onyx

    - removing all other apps which have icons in the menu bar (including iStat Menu, which I do have installed)

     

    I'm not sure what you'd want me to check under Spotlight Privacy; I went to this tab under Spotlight Preferences and the list of locations to skip is blank.

     

    I do not have any external drives connected to my machine, so that can't be the issue either.

     

    Any other ideas? Suggestions? This is becoming extremely frustrating!

  • MatFont Level 1 Level 1 (0 points)

    Well pixelkitten

     

    Restart your computer will not solve anything permanently, neither as a full system clean up procedure.

     

    The Spotlight Privacy setup prevents to run a search in places like external drives & etc, what may overcharge de system.

     

    The 1 to 10 minutes you've timed really is a very short period to freeze you Mac.

     

    The previous solution provided by Joshua Taylor mentioned by jag2009 in the article http://www.macnative.com/systemuiserver-recover-ram/ seems to solve the problem, until Apple releases a pack that can solve it definitely.

     

    I hope it works!

     

    Att

  • Jaydon134 Level 1 Level 1 (0 points)

    Hey, I am working with Apple to find a solution to this problem. Please reply to this post with the names of any 3rd party applications that are always running on your Mac. Alfred, Wallpaper Wizard, etc. I will try to find an app that causes these problems and if a 3rd party app isn't the culprit I can identify the Apple software that causes it. Thanks!

     

    Jaydon

  • MatFont Level 1 Level 1 (0 points)

    Well, it happens with some apps running on the background, like DropBox, Fantastical, Growl, ClamXav Sentry, iStats Menu's monitor, Messages.

     

    There are also Apple's apps running: dock, dashboard, CalendarAgent, Notification Center, etc.

     

    Att

  • FilipL Level 1 Level 1 (0 points)

    The problem occured not long ago with my macbook pro mid 2009. After searching a while on internet and trying some of the possible solutions, i found something that works for me.

     

    The first thing i tried was uncheck the 'show input menu in menu bar' found in system preferences -> language & text -> Input sources. After this the problem occured less than before, but wasn't totally gone.

    I also removed the day of the week in the date & time preferences, so only the time would be in the menu bar.

     

    Then I noticed the problem occured when my battery status changed to service battery. In the apple menu bar in the top right corner, the show percentage was checked. After unchecking it, the problem was solved.

     

    So, there are probably some things that i checked of unchecked unnecessarily, but after all, i got rid of the gigantic cpu load.

     

    Hope this could help.

  • RobertNY9 Level 1 Level 1 (0 points)

    Skype and Dropbox are my only 3rd party apps.

     

     

    Not to complicate this issue, but I also had the "Mail problem," where Mac Mail consumes over 100% CPU, especially when using an Exchange account; unfixable other than temporarily, so I am using MS Outlook as my mail client.

     

    Net-Net...very annoying Apple and disappointing; and with the slight hope that Mr. Cooke can be reached via these discussions, there is a reason why the stock has gone down from $700 to $500:  the company is rapidly losing the support of fan-boys like me and others with your avoidance of taking responsibility for problems.

  • Jaydon134 Level 1 Level 1 (0 points)

    Alright then. It appears that Dropbox is the only thing that we all have in common and I'm fairly sure that it is not the app causing the problem. Lately I haven't had any issues with SystemUIServer. Although, I have tried to cut back on the number of third party apps I am using. Anyway, thanks for your input. I will keep trying to get it fixed.

     

    Jaydon

  • Dand666 Level 1 Level 1 (0 points)

    Any luck?