Announcement: Upgrade to macOS Mojave

With features like Dark Mode, Stacks, and four new built-in apps, macOS Mojave helps you get more out of every click. 
Find out how to upgrade to macOS Mojave > https://support.apple.com/macos/mojave

Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Automator Runner not working in Mountain Lion

After installing Mountain Lion, the Automator Runner app no longer works. At the same time, opening a workflow through Automator app and pressing the Run button executes the code flawlessly.


Is there a quick fix for the Automator Runner, or have we got to wait for a Mountain Lion update?

OS X Mountain Lion

Posted on

Reply
Question marked as Solved
Answer:
Answer:

Thanks to both of you, but, unfortunately, none of your suggestions have fixed the problem.


However, I have managed to find a solution, and it's a doddle, really!


All one needs to do is convert the workflow into an application, by selecting File>Convert to and choosing "Application". One must be careful, though, to make sure it is saved as an application; specifically, once the workflow is converted into an app, hit command+save, and in the popped up window, set File Format to "application" (note that it is set to "workflow" by default).


This is simple to do, of course, though it has become a small bit of a niggle, hasn't it? I do not quite understand why Mountain Lion impels us to make a (not exactly trivial) extra step where Lion didn't. Must be something about the low pressure up there...


Cheers!

Posted on

Question marked as Helpful

Aug 9, 2012 8:47 AM in response to zimbanik In response to zimbanik

Try repairing your permissions. Go to applications then to the "other" folder then go to disk utility, on the left hand side you will see a white box. Select the second option, usually called "mac HD" with that selected click on "repair permissions" in the center towards the bottom of the screen. Wait for it to complete, then see if this fixes the issue.

There’s more to the conversation

Read all replies

Page content loaded

Question marked as Helpful

Aug 9, 2012 8:47 AM in response to zimbanik In response to zimbanik

Try repairing your permissions. Go to applications then to the "other" folder then go to disk utility, on the left hand side you will see a white box. Select the second option, usually called "mac HD" with that selected click on "repair permissions" in the center towards the bottom of the screen. Wait for it to complete, then see if this fixes the issue.

Aug 9, 2012 8:47 AM

Reply Helpful (1)
Question marked as Solved

Aug 11, 2012 6:57 PM in response to calebfrom84042 In response to calebfrom84042

Thanks to both of you, but, unfortunately, none of your suggestions have fixed the problem.


However, I have managed to find a solution, and it's a doddle, really!


All one needs to do is convert the workflow into an application, by selecting File>Convert to and choosing "Application". One must be careful, though, to make sure it is saved as an application; specifically, once the workflow is converted into an app, hit command+save, and in the popped up window, set File Format to "application" (note that it is set to "workflow" by default).


This is simple to do, of course, though it has become a small bit of a niggle, hasn't it? I do not quite understand why Mountain Lion impels us to make a (not exactly trivial) extra step where Lion didn't. Must be something about the low pressure up there...


Cheers!

Aug 11, 2012 6:57 PM

Reply Helpful

Apr 1, 2013 11:19 AM in response to zimbanik In response to zimbanik

Look in the Activity Monitor or atMonitor. If Automator Launcher is running but not active, then try running the service and watching the Launcher for activity. If you do not see a surge of activity when you try running the service, then the Launcher is probably hung. Try killing the Launcher process and running the service again. That worked for me.

Apr 1, 2013 11:19 AM

Reply Helpful
User profile for user: zimbanik

Question: Automator Runner not working in Mountain Lion