Previous 1 4 5 6 7 8 9 Next 126 Replies Latest reply: May 1, 2013 2:26 PM by icerabbit Go to original post
  • John P. Level 4 (1,145 points)

    Same error.


    Running Safari 6.0.2 on an Early 2011 Macbook Pro with Mountain Lion 10.8.2.


    Safari just quits, no crash or error message. The only thing I find in Console is:


    Safari[5639]: Received an invalid message from the web process with message ID 323002f


    Extensions installed: Click to flash (not enabled)


    Not happy.

  • Javier Bonafont Level 1 (0 points)

    That "invalid message ID 323002f" is the constant.

    As far as i know nobody has ever identified what that actually means, but if you search for that string you will get a bunch of discussion threads where it shows up.


    What is most peculiar is how, at least for me, i cannot replicate the crash even doing the identical steps with the identical links.  A few weeks ago it was crashing all the time, and now it hasnt for a week at least.  totally odd.

  • John P. Level 4 (1,145 points)

    Javier: Strangely, I haven't been able to replicate it, even by retracing my steps or clicks prior to it unexpectedly quitting.


    The only constant I've been able to nail down is that it only happens when clicking a new lin; it doesn't matter if I am opening it within the current window, new tab, or a new window.


    Since it's not [technically] crashing Safari but rather seems to be quitting out of the app, I'm starting to wonder if it has something to do with Adobe Flash Player. I do not believe it is an extension because I've had this happen with all extensions disabled/off but I still had Flash Player installed.  I have done a complete uninstall of Adobe Flash Player for the time being, or at least until the issue happens again. Here is a link to the uninstaller if anyone wants it: Uninstaller for Adobe Flash Player for Mac


    I have noticed there has been a lot of updates to Flash Player recently so that may be a factor as well. I did not notice this issue until a week or two ago, although I see it has been going on longer for some.

  • cotton.mill Level 1 (10 points)

    I have no Adobe Flash installed at all and no extra software even, only been using it to surf for a month or so from new!


    Still have the same problem



  • John P. Level 4 (1,145 points)

    You're right, and it just happened again to me. humph!


    I just contacted AppleCare about it--it's definitely strange. The representative I spoke to said they had heard of this issue and recommended deleting from ~/Library/Preferences -- I just tried that, will have to wait and see if it works or not.


    I did not have Adobe Flash installed when it happened and extensions were all turned off.


    I did notice that my safari .plist was approximately 3KB larger than the new .plist but I do not know if that is of any significance.


    Has anyone found a workaround, or is the group consensus that this is merely a bug that Apple has yet to fix?

  • Jason Barker Level 1 (15 points)

    Yesterday, I trashed the from ~/Library/Preferences.


    I just saw the same crash again today. Console showed:

    2/19/13 12:20:11.615 PM [0x0-0x15d15d] Received an invalid message from the web process with message ID 323002e


    No other signs of a crash (No Crash report). In other words, typical.


    So, to answer John P.'s question ("is the group consensus that this is merely a bug that Apple has yet to fix?")


    I think it's just a bug. A weird one that is not consistently reproducible.

  • John P. Level 4 (1,145 points)

    Well, I just got off of the phone with AppleCare for the fifth time.


    The representative suggested going into /System/Library/StagedFrameworks/Safari/ and delete the folder "WebKit.framework"


    Run Software Update, it will trigger a re-download of Safari 6.0.2.


    So far, no disappearing Safari. The rep said that sometimes Safari updates do not refresh the webkit folder so doing this will trigger it to reinstall it.


    Anyway, something to try. I have not had Safari disappear on me yet.

  • robbgoblin Level 1 (0 points)

    Hate to pop the bubble of what seemed like a solution, but I tried this method and after updating Safari, the problem re-occurred again a few minutes later. This is becoming a joke!

  • tgasc Level 1 (0 points)

    I'm having this annoying problem on both of my Macs since upgraded to ML. I simply cannot believe that Apple just let this problem sits there for so many MONTHS without a fix. Safari keeps crashing all the time during my daily use with the same message in Console as other people, APPLE WHERE ARE YOU?!

  • John P. Level 4 (1,145 points)

    Looks like I spoke too soon, it's still doing it.  Oh well.


    It is strange that Apple has let this go on for so long. I just installed Chrome as a backup and so far I've not had this or any other problem with it.

  • John P. Level 4 (1,145 points)

    One other thing I was recommended to try:


    Quit Safari.


    Going into /System/Library/StagedFrameworks/Safari/ and delete the folders "WebKit.framework" and "WebKit2.framework"


    Then run Software Update, install Safari 6.0.2....


    Thus far, it hasn't quit/crashed on me....something to try while we wait for Apple to fix it.

  • John P. Level 4 (1,145 points)

    One last thing I've noticed.


    If you have, or have ever had the Google Analytics Opt Out extension installed, simply disabling or uninstalling it doesn't always help because it's a Javascript file (not a true extension). I'm certainly no web design expert but I believe you have to uninstall it and Reset Safari for it to truly be removed.


    I noticed the issue pop up again when right after I installed the Google Analytics extension, and only that extension. It may be of little consequence but I removed the Analytics plugin, reset Safari, and it hasn't happened since (knock on wood).


    I don't know how much this will help you all but I thought it would be worth mentioning. I do not believe it is WebKit or anything to do with WebKit in my case; it appears to have been the Analytics plugin....

  • tgasc Level 1 (0 points)

    I believe it has nothing to do with any extension or plugin, if you have browsed through out this thread you may have noticed that some users including me do not have any 3d-party extension or plugin installed / enabled but still have this annoying issue. I started facing this problem since I upgraded to Mountain Lion on my MBA, and tried to convince myself that it was my own problem, until I got my new iMac late 2012, which keeps crashing to death just like my MBA with not extension installed (with the same message in Console - Received an invalid message from the web process with message ID 323002f).

  • Michael Battenfield Level 1 (135 points)

    Sigh.... tgasc, it doesn't require any plugins installed for the plugin manager to be causing the issue - I personally believe it is the manager itself that is the problem.  Deactivating plugins did not help for me.  Uninstalling plugins didn't help.  Only turning off the plugins extension manager altogether that brought any relief.

  • track2 Level 1 (0 points)

    Face it, this has been going on for 7 months now and I don't believe apple aren't aware of the issue.  They clearly can't or won't solve it, so the best solution is to move on to another browser.  You never know, you might actually prefer it?

Previous 1 4 5 6 7 8 9 Next