Previous 1 2 Next 25 Replies Latest reply: Oct 31, 2015 9:07 PM by pgAesthetics
galxcbaby Level 1 Level 1

I've had this macbook three years (since late 2009), but bought it refurbished. I had the battery replaced in January of this year and had no problems with it until today.

Last night I turned it on for a few minutes, it had 90% power, then I turned it off for the night. When I tried to power it up this morning, it would not turn on. Only when I plugged it in would it turn on. The power indicator light is green on the cord, but the battery icon has an X over it and reads "batteries not available". If I unplug it, it turns off. I ALREADY tried sleeping it, restarting, and reseting the SMC; no change. No software updates are available, and nothing else appears to be wrong.

What the heck happened and what can I do? This came out of nowhere!

MacBook Pro (13-inch Mid 2009), Mac OS X (10.6.8)
  • Baby Boomer (USofA) Level 9 Level 9


    When was the last time you calibrated your battery? 


    You didn't plug in your MBP when you shut it down for the night?   Go to your System Profile and copy/paste the battery info here.  DO NOT POST ANY SERIAL NUMBERS!!!!!


    More than likely you need a new battery.




    Apple notebook batteries – maintenance and troubleshooting

  Apple Portables: Tips for maximizing your battery charge

  Apple Portables: Calibrating your computer's battery for best performance


    Maximize the battery life















  • Bimmer 7 Series Level 6 Level 6

    your battery probably needs to be replaced......


    click on your apple logo - about this mac - more info - system report - power and see what it says under battery....


    if it doesn't detect or says service battery - time to replace it....


    good luck - hope you get it sorted out...

  • galxcbaby Level 1 Level 1

    1. I didn't pulg in the battery for the night becaue I always drain my battery to 10% before charging it, and it had 90% power left.

    2. My first battery lasted 2 1/2 years, this one is only 8 1/2 months old, so it better not need a new one.

    3. I don't think the battery is the issue because the computer doesn't recongnize that the battery is even installed (se below):


    Battery Information:


      Charge Information:

      Charge remaining (mAh):          0

      Fully charged:          No

      Charging:          No

      Full charge capacity (mAh):          0

      Health Information:

      Cycle count:          0

      Battery Installed:          No

      Amperage (mA):          0

      Voltage (mV):          0

  • donisback Level 1 Level 1

    Any update on this? I have the same issue and sadly, I don't have Apple Care protection plan. It has been less than 2 years since I bought it.

  • ecammit Level 1 Level 1

    I just had the EXACT same happen to me this morning. If I solve it I'll let you know.

  • ecammit Level 1 Level 1

    I just shut everything down completely, disconnected the power adapter, and started the machine back up again and the battery appeared. I don't think this is the same issue you have, but the symptoms were identical.

  • donisback Level 1 Level 1

    I had to take to the local Apple store here and he provided a temporary fix. He said the battery sensor is burnt on motherboard. After the fix, whenever I close the lid, the MacBook Pro doesn't sleep.

  • pvblivs Level 1 Level 1

    After re-installing Mountain Lion on my August 2009 15" MBP (1 yr old battery) for the second time, this morning I had the exact same problem. My battery indicator showed an X, stating a battery could not be found. I restarted serval times with power cord plugged and unplugged and managed to get to a 0% indicator with the message "battery can not be charged".


    After searching for a while (in this article, too), I stumbled over that article by Apple: It basically said: If nothing works, try an SMC reset.


    And that worked for me.


    You can do an SMC reset as explained by Apple here:

  • jlgaddis Level 1 Level 1

    After backing up all of my data and performing a clean installation of Mountain Lion on an "Early 2011" 15" MBP, I ran into this issue as well (sounds identical to what pvblivs experienced).  I came across the SMC reset procedure while troubleshooting the issue and am about to give it a shot myself (as soon as some data is done restoring).

  • jlgaddis Level 1 Level 1

    Well, my issue now appears to be resolved, although following the NVRAM/PRAM reset procedure (once) and the SMC reset procedure (several times) were not successful.


    A little backstory:


    I've been using the MBP on an almost daily basis since I purchased it in early June 2011. The only "issue" I've had with it is that the battery doesn't last as long as it used to (which is obviously normal). I used the MBP for perhaps 15 minutes yesterday (Friday) while at a client's site and then closed the lid (like I always do and put it back in my bag).


    At home last night, I opened the lid and it did not automatically resume. Apparently, it might not have hibernated properly, leading the battery to eventually drain and so the laptop suspended to disk. I plugged it into the wall and it worked normally.


    I've been meaning to back up all of my data and do a clean install and finally did that late last night/this morning (with the laptop plugged in the whole time). Right after the re-install, the battery icon in the menu bar was red. Opening up "System Information" showed some crazy numbers. I didn't take a screenshot or note the numbers but, for example, the "Full Charge Capacity (mAh)" number was in the hundreds of thousands.


    Later, the icon went from red to the "X". I restarted a few times to no avail and, after coming across this post and others, attempted the SMC reset. No luck there; NVRAM/PRAM reset, no luck; SMC reset a few more times, still no luck.


    (In the middle of all of this, at the login screen, I pulled the power adapter out, waited a moment, and plugged it back in. Upon hitting the power button, the laptop began "unsuspending" from disk, *not* starting up as if it had been shut down. This was a clue to me that the battery wasn't actually dead. Also, if I hit the little button on the side, all eight or so of the little LEDs would light up.)


    Finally, I resolved to just taking the laptop to an AASC downtown come Monday. I closed the lid (at the logon screen), unplugged the power cord, moved from my office to the couch, plugged it back in, and hit the power button on the laptop. It came out of suspend and, interestingly enough, the battery indicator showed 100%. Checking the "System Information" it shows "normal" values (charge remaining/full charge capacity: 6298 mAh, fully charged: yes, charging: no).


    I began typing this post and thought my problem was solved.


    As I was in the middle of typing out this post, however, the menubar icon jumped back and forth from "100%" to "X" and back a few times. Now, it has apparently decided it wants to stay on "X"...


    ... and as I was typing those last two sentenced, it went to "0%" for a moment, then back to the "X". I hit the little button on the left side and it went back to "100%". Now, I'm looking at an "X" again.


    I think I'll think it to the shop Monday. I did purchase two additional years of AppleCare, so hopefully they'll cover whatever the heck is wrong. In the meantime, I think I'll try the NVRAM/SMC reset procedures again. It's possible I may not have done them correctly, although I'm a pretty technical guy (systems administrator/network engineer) and am fairly good at reading and comprehension.  =)


    I'll come back and post updates if I learn anything.




  • nkmower Level 1 Level 1

    Same problem.  Resetting the SMC worked for me...for now.

  • nkmower Level 1 Level 1

    Scratch my previous comment the dreaded X is back in my battery icon after 30 minutes normalcy.  Now what?

  • sonicsoundscape Level 1 Level 1

    Same thing happened to me from a faulty charger, my macbookpro had an 'x' throught th battery and the fan was at full speed.  I fixed it by keeping my computer on, letting the battery completely drain, so your mac shuts off. then conect it to charger and turn it on.  Now my mac works perfectly!!  hope this works for you

  • jswahn Level 1 Level 1

    I can confirm that this works, at least as a temporary fix.


    As said above unplug the Macbook Pro. Let the batteries run down. Plug in the adapter. It lights up as normal and the computer can be started with the battery indicator showning charging. Also the constantly running fan stopped.


    My spring 2011 Macbook Pro has been acting strangely for some time. Instead of going into sleep it has sometimes gone into deep sleep, sometimes coming up from such a deep sleep it has crashed afterwards, it has even abruptly shut itself off with plenty of battery left. I have searched for a fix. When I reset the PMU several times the condition with a constantly spinning fans, the battery not being found, an X in the battery indicator, the adapter light not showing orange or green, turned up. I tried different ways to fix it, but not until I did the abouve was the computer back to what seems normal.


    The original problem could have been related to the 10.8.3 software update, as there is some speculation about on the net, but it could also have been something that was wrong with my PMU settings that may have been fixed now. Or it may still be a hardware problem that needs to be fixed.


    If the problem returns, so will I.

Previous 1 2 Next