13 Replies Latest reply: Apr 14, 2014 7:42 AM by wmaw1972
Pamela Mullen2 Level 2 Level 2 (165 points)

If I open a PDF in Safari and then try to search it I'm always told that the word can't be found (even if I can see the word directly below in the document). So, I must download the document and open it in Acrobat or Preview to search it. I used to be able to search within Safari.

  • Linc Davis Level 10 Level 10 (165,200 points)

    Does this happen with all PDF's, or only some? If only some, can you post a link to an example?

  • kennyalive Level 1 Level 1 (0 points)

    I experience this behaviour too. For me it happens with every PDF I open from the internet. The search window always tells me that the word I'm looking for isn't found. I have OSX 10.8.1 and Safari 6.0, but it was the same with OSX 10.8. Additionally, I have Adobe Acrobat X Pro installed. Is this an issue?

  • Pamela Mullen2 Level 2 Level 2 (165 points)

    Here's a simple example. If I type "telephone" in the search box I get "not found":

     

    http://www.gephones.com/docs/30784-user-guide-english-f.pdf

  • DavidM3 Level 1 Level 1 (0 points)

    I have the same issue. It appears that I'm viewing the PDFs through an Adobe plugin. Wonder if it's a Mountain Lion issue with a slow update from Adobe (can't imagine that....geez).

  • PMHastings Level 1 Level 1 (0 points)

    I had the same problem.  I had installed Acrobat Reader a few months ago.  When I upgraded Safari to 6.0, Safari started using the plug-in files in /Library/Internet Plug-Ins/

    I deleted both of the AdobePDF files here, and I'm back to the native Safari PDF viewer.

  • rm architect Level 1 Level 1 (75 points)

    I was having the same problem with Safari 6.0 under Lion.  Couldn't search a PDF file within Safari it wasn't finding stuff that was obviously there, so I had to save the pdf to my desktop and search it there using preview. And, I had to use the save button in the pdf viewer, not from the Safari file menu, to even get the pdf onto my desktop.

     

    I removed the two Adobe files mentioned above, and the problem has gone away.  Thanks. 

  • StefanSchneider Level 1 Level 1 (0 points)

    Seems the shortcut cmd+F is just accessing the Safari search option, right mouse click (ctrl+click) and select search. This opens the Adobe search option, then search and find...

  • MM087 Level 1 Level 1 (0 points)

    Hi, Im having the same issue with my MacBook Pro. I was able to preview a PDF File within Safari and I could hover the mouse over the bottom of the screen and then click to download, print etc.

     

    Some update has taken place on my computer and I am now unable to either download a PDF File from certain sites like my University Portal nor Preview files within the Safari Brower.

     

    I do have the files mentioned on here if I go to: Library - Internet Plug-ins:

    - AdobePDFViewer.plugin

    - AdobePDFViewer.NPAPI.plugin

     

    Also in: Applications - Utilities - Adobe Reader*

     

    Now the Problem I have is I cant move to the desktop and delete from the desktop as I end up with a duplicate so to speak.

     

    When I try and delete them from the folders directly I get the following error message:

    "The operation can't be completed because some items had to be skipped. For each item, choose File > get Info, make sure "Locked" is deselected, and then check the Sharing & Permissions section. When you are sure the items are unlocked and not designated as Read Only or No Access, try again."

     

    *The 2nd issue is the Adobe Reader is faded out and has the circle going through it and is faded out ?

     

    I have re-installed the operating system, tried to deleted the items in safe mode to no avail !

     

    Please Help ...

  • rsxnsxmdx Level 1 Level 1 (0 points)

    I miss the keyboard shortcut... but this way works! Thanks

  • laspalmas.dk Level 1 Level 1 (0 points)

    This solved it for me. Thanks!

     

    Does not make sense that Cmd F does not return any answers though.

  • brennon Level 1 Level 1 (0 points)

    Thanks for the tip, PMHastings--no need to delete those plugins, though. Just move them to /Library/Internet Plug-Ins/Unused, restart Safari, et voilà!

  • apple4p Level 1 Level 1 (0 points)

    As stated before, the issue is command F is using Safari, as opposed to Adobe Reader "find" within Safari. It's been this way for years, downloading PDF's just to search them, and this morning I had enough, so here we go ...

     

    1. Open any pdf outside of Safari.

     

    2. Hover over empty toolbar space > control + click > edit > find. This will place the magnifying glass find button on your toolbar permanently.

     

    Apparently Adobe 9 had the find button, and if/when we upgraded to Adobe 10 (aka Adobe X) Adobe decided to remove the find button from the toolbar because ??? ... genius move, right? Clearly you can skip this step if you already have a find button on your toolbar.

     

    3. Now in Adobe go to edit > preferences > internet > and untick "Display in Read Mode by default".

     

    Steps 2 and 3 above should only need to be done once, and will work thereafter unless you start fiddling with Adobe again on your own or through update.

     

    4. Restart Safari, navigate to a PDF document and open it in the browser. You should see your toolbar, whereas before you would not. If you don't like your toolbar there, just go back to step 2 and reverse. Then you can bring up your toolbar when needed by hovering over the lower portion of an open PDF and clicking on the Adobe squiggly trademark (looks like a triangle in cursive?). Not sure why anyone would want to do this, but the option is there. I like my toolbar there 24/7, but depending on the answer to my inquiry below, that might change ...

     

    QUESTION:

     

    So now when I open a PDF in Safari and want to search it WITHOUT downloading it, I click the magnifying glass and search away. But what about searching with Command F? It still defaults to Safari's "find", not Adobe's "find".

     

    Anyone know how to make Command F search an Adobe PDF opened within the Safari Browser?

     

     

    Also, here is a link that helped me figure this all out - http://www.wyonewspapers.org/acrobat.html

  • wmaw1972 Level 1 Level 1 (0 points)

    Considering how basic a function this is and how often one might use it, this entire matter is COMPLETELY INSANE!

     

    Thank you Apple for the final straw as far as convincing me to use another browser.

     

    p.s.  Those directions supplied above by apple4p look more like what you'd expect NASA engineers to provide mission control as the sequence for a rocket launch.