Previous 1 2 Next 29 Replies Latest reply: Sep 24, 2015 6:39 PM by Kabeyun
scrmngfist Level 1 Level 1 (0 points)

Gamecenter is annoying and slows my phone at the start of game play. It is irritating when you start a game and gamecenter has to notify me that it's signed in, despite my notification settings to the contrary. It is very irritating when you don't have, or have deliberately removed the gamecenter credentials. That results in 2 popups! I would like very much to delete this app, but you can't. Alternatively, I would like to either have iOS block its notifications via a Notifications setting, or when there are no credentials it can ask once if I would like to sign up and never again.

iPhone 4, iOS 5.1.1
  • Meg St._Clair Level 8 Level 8 (47,590 points)

    I signed into Game Center once. Now, if the game supports it, there will be a little pop up across the top of the screen welcoming me back. That's it. It has no effect on gameplay. Have you tried simply signing in and forgetting about it?

  • Trumania Level 4 Level 4 (1,160 points)

    You could also try enabling restrictions to see if that helps out any.


    HT4213 iOS: Understanding Restrictions


    You can disable Multiplayer games in Game Center, and Adding Friends in Game Center.

  • Ckgirl Level 1 Level 1 (0 points)

    Thanks Meg. It has long annoyed me so I tried what you suggested. Perfect, as you say just a little pop up appears at the top which you can ignore.

    Thanks very much!

  • H S Rollans Level 1 Level 1 (45 points)

    You can COMPLETELY disable Game Center prompts and greetings, and still enjoy Game Center-enabled games.


    1) If you have signed up for Game Center and now wish to opt out, launch Game Center. Click on your account name, and select "Sign Out" from the pop-up.


    2) Launch "Settings" and select "Notifications." Under "In Notification Center" find and select Game Center.


    3) Turn all the sliders to "OFF," and set "Alert Style" to "None."


    That's it. You will have no more annoying alerts telling you you're not signed in to Game Center, and urging you to sign up. You will have no more annoying "Welcome back" greetings every time you play a Game Center game.

  • GameCenterSucks Level 1 Level 1 (0 points)

    No you can't.


    This doesn't work.


    Play Bejeweled and see what happens!

  • scifoso Level 1 Level 1 (0 points)

    iOS 6, iPhone 4s, shows welcome notification when launching NYT crosswords.  Notifications for game center is disabled.  It was not displaying a welcome before I upgraded from 5.1.1 to 6.0.


    Somewhat trivial, but still annoying that this kind of thing is suddenly pushed into our faces.

  • Andy603 Level 1 Level 1 (0 points)

    this does NOT turn off that annoying game center welcome screen!!  ***..I didn't get this until I upgraded to iOS6 now I can't get rid of the stupid logon screen when launching a game...I dont want game center....!!!! HELP!

  • Dirty_Mc Level 1 Level 1 (0 points)

    Okay, I think I figured it out. I was playing bubble which saga and every time the game center notification would pop up and ask me to sign in I would cancel it, go back load the app again and then it would pop up I would cancel it again. I did this repeatedly a few times Until finally the pop-up came up asking me if I wanted to disable Game Center. I chose the option "disable" and that was all she wrote.

  • scifoso Level 1 Level 1 (0 points)

    Dirty_Mc, that worked.  No more BS pop-ups.  Thanks!

  • Wout Mertens Level 1 Level 1 (0 points)

    Yeah that works for me to - until I reboot. Then suddenly I'm logged into gamecenter again for all games :-(

  • Andy603 Level 1 Level 1 (0 points)

    that is exactly how it works for me....frustrating....isn't there a way to shut this thing down??

  • Arthur Fenster Level 1 Level 1 (15 points)

    I think I disabled game center. First go into General Settings. Second find restrictions. Click on enable restrictions, go to the bottom of the page where it says game center and turn both sliders off. Close out settings, and re-boot your ipad. When it re-boots open your game and game center should be gone. I had the issue with my solitaire game, did what I described and when I rebooted solitaire game center quit popping up.


    Good luck.

  • JesalAM Level 1 Level 1 (0 points)

    The Restrictions route also doesn't work. I already had them set to OFF but the dumb thing still pops up. Even after I disabled it innumerable times. All setting in Notifications are also set to OFF, receive notifications set to Only from contacts... Still...


    One dumb and stubborn app this is. Doesn't take no for an answer...

  • Bogie955 Level 1 Level 1 (0 points)

    I've been around the block a few times in computer support over my 33 year career.  I have been dealing with this annoying issue regarding Game Center for quite some time now.  I had already previously tried everything I've recently read with the exception of logging in.  Logging in to get rid of annoyances from an App is not an answer, when you don't want the App in the first place.  Especially, when you don't want it to know your credentials to login in the background.  Each of the posted suggestions of getting rid of Game Center have seemed to work for a short while and then Lo and Behold, here comes Game Center again.  At this point, other than Apple Support making some IOS modifications to allow the user back the control of whether they want to see that ugly Game Center Login, I am only sure of one way to get rid of Game Center.  If you take your Otter Defender Case off, get on the roof of your house, and throw your iPhone as far as you can to reach the street, and if the iPhone makes it directly to the street, your problem with Game Center will no longer exist.  Of course, then you will have a new set of issues to deal with.

Previous 1 2 Next