10 Replies Latest reply: Jan 7, 2014 3:09 PM by dritchey
whatshername100 Level 1 Level 1 (0 points)

Snow Leopard won't update, no matter how many times I try. I suspect Flashback is the reason. How can I scan and remove it? Complete Mac novice. Any assistance is appreciated!!!


MacBook Pro, Mac OS X (10.6.8)
  • Kappy Level 10 Level 10 (260,210 points)

    Since 10.6.8 is the last release for Snow Leopard, there are no other updates. So what is it you are trying to accomplish?

  • whatshername100 Level 1 Level 1 (0 points)

    The 12 Software Updates it says it needs. I've tried four times, but after my mac restarts, I check the software updates, and the same ones are needed AGAIN. (Trying to watch Netflix, but both Safari and Firefox end up "Not Responding")

  • Kappy Level 10 Level 10 (260,210 points)

    What are the ones that keep repeating? Have you tried downloading and installing the standalone updates directly from Apple - support.apple.com/downloads?

  • whatshername100 Level 1 Level 1 (0 points)

    iTunes, Security Update 2012-002, SMC Firmware Update, just to name a few. I haven't tried installing the standalone updates. I'll try that next. So this isn't malware or a virus?

  • Kappy Level 10 Level 10 (260,210 points)

    I doubt that very much. I'd also be sure to do the following:

     

    Repair the Hard Drive and Permissions

     

    Boot from your Snow Leopard Installer disc. After the installer loads select your language and click on the Continue button. When the menu bar appears select Disk Utility from the Utilities menu. After DU loads select your hard drive entry (mfgr.'s ID and drive size) from the the left side list.  In the DU status area you will see an entry for the S.M.A.R.T. status of the hard drive.  If it does not say "Verified" then the hard drive is failing or failed. (SMART status is not reported on external Firewire or USB drives.) If the drive is "Verified" then select your OS X volume from the list on the left (sub-entry below the drive entry,) click on the First Aid tab, then click on the Repair Disk button. If DU reports any errors that have been fixed, then re-run Repair Disk until no errors are reported. If no errors are reported click on the Repair Permissions button. Wait until the operation completes, then quit DU and return to the installer.

     

    If DU reports errors it cannot fix, then you will need Disk Warrior and/or Tech Tool Pro to repair the drive. If you don't have either of them or if neither of them can fix the drive, then you will need to reformat the drive and reinstall OS X.


  • Kappy Level 10 Level 10 (260,210 points)

    Also, see the following:

     

    Fix for Software Update

     

    See Troubleshooting Automatic Software Update in Mac OS X.

     

    Delete the following files:

     

    • /Library/Preferences/com.apple.SoftwareUpdate.plist
    • /Home/Library/Preferences/com.apple.SoftwareUpdate.plist
    • /Home/Library/Preferences/ByHost/com.apple.SoftwareUpdate.xxx.plist where "xxx" is a number.
    • /Home/Library/Caches/com.apple.SoftwareUpdate/ (delete entire folder)
  • MadMacs0 Level 5 Level 5 (4,660 points)

    whatshername100 wrote:

     

    So this isn't malware or a virus?

    No, not unless it's something brand new.

  • MadMacs0 Level 5 Level 5 (4,660 points)

    whatshername100 wrote:

     

    iTunes, Security Update 2012-002, SMC Firmware Update, just to name a few. I haven't tried installing the standalone updates.

    The problem with that is that many updates must be installed in a specific order. This will help you with the order of release of the security related ones: http://support.apple.com/kb/HT1222. With the others you'll probably have to just insert them based on the file's modification dates.

     

    Be advised that the last person I tried to help that had this problem could not install the downloaded versions either. Your best bet is to trash the files that Kappy gave you.

  • tonyminnesota Level 1 Level 1 (0 points)

    Had the same problem - Software Update showed 11 items downloaded for installation, 4 requiring a restart, but when I clicked on 'Install and Restart' no installation or restart occurred (there would be  a pause, with a couple of blank or background screens, and then back to the login screen).  I tried unselecting many items and installing just one or a few at a time.  In particular. one item was an update to Softwrae Update itself (requiring a restart) and I selcted this one for installation on its own.  All the installations and required restarts then worked !  I suspect there may have been some kind of conflict between the update to Software Update and the other updates.

  • dritchey Level 1 Level 1 (0 points)

    tonyminnesota's solution fixed it for me !