14 Replies Latest reply: Nov 30, 2012 4:04 AM by JeroenPotters(Macpot.nl)
Teanne Level 1 Level 1

I've noticed a lot of people having trouble with tap to click in the forums. I don't use tap to click, but have found a really annoying behaviour since updating to Mountain Lion: with tap to click disabled, but a finger on the track pad (or two fingers on the track pad) the os will occasionally and randomly register a click without any force applied. I tend to rest my fingers on the track pad as im reading, to scroll more easily, and this behaviour has been resulting in a ton of right clicks that i didnt click through. More annoyingly, if I am moving the cursor, it will occasionally click in mid swipe. Again, this is with tap to click disabled, and not pressing hard enough to click hardware switch. Had anyone else been having this problem / have any suggestions? I've tried an SMC reset to no avail.


MacBook Air, OS X Mountain Lion, 2011 Sandy Bridge 1.8GHz 13" model
  • rosswillsimpson Level 1 Level 1

    I have this problem too on my macbook air, it's so annyoing and highlights everything when I try to two finger scroll and yes, my tap-to-click is unticked in the settings! HELP APPLE

  • infinitdotio Level 1 Level 1

    I have this problem too.

  • sortiz Level 1 Level 1

    I too have this problem.  I keep hoping Apple will fix it with a new update.  My trackpad on my i7 macbook air (with mountain lion) is nearly useless (it has become too eratic).  I don't even like opening mail anymore because simply moving the mouse over my folders relocates them or deletes them.  There is a serious glitch.

  • JeroenPotters(Macpot.nl) Level 1 Level 1

    Running 10.8.1 on my 2010 MacBook Pro 13" and annoyingly the same problem with my external TrackPad. Have to us a mouse again to work propperly. Apple please fix this issue!!

     

    (Haven't noticed this issue with my internal trackpad so far, or I would go mad).

     

    Please report this issue via http://www.apple.com/feedback/ so Apple will hopefully fix this in 10.8.2

  • Teanne Level 1 Level 1

    Sadly, 10.8.1 did nothing; still randomly taps to click if you have a finger sitting on the trackpad.

  • beechfork Level 1 Level 1

    I have this problem too. It's very annoying and interfere with my daily work.

    I cannot believe Apple don't have active trackpad users that didn't noticed this problem until now.

  • Chris Leishman Level 1 Level 1

    I have all the tap settings diasabled, and yet I'm constantly having text be randomly selected and dragged around the page.  This is driving me nuts.

     

    I definitely never saw this before Mountain Lion.

  • Chris Leishman Level 1 Level 1

    I've also noticed that a double tap followed by a drag does text selection/dragging.  Even with all tap-to-click options disabled.

     

    And unfortunately this is also an easy thing to accidently do.

     

    Really, really annoying.

  • sortiz Level 1 Level 1

    I went to Apple.  They had to send my MacBookAir to their repair center to replace the trackpad.  And this was odd because I didn't have any trackpad problems before I upgraded to Mountain Lion.  But now (with a new trackpad installed in my computer) it seems to work.

  • JeroenPotters(Macpot.nl) Level 1 Level 1

    I also went to Apple (Store) with my MacBook Pro and my Magic Trackpad. The Genius did a full reset and reconnect of the Trackpad. Also tested the trackpad for hardware failure, no failures detected.

     

    After using it for no more then half a day same issue occured, random selecting of text, clicking and so on ... Back on my old Logitech mouse again

     

    When I pass by the Store again, will drop by to talk to them again.

  • iaian7 Level 1 Level 1

    I'm using Logitech mice on a Mac Pro (at work) and an iMac (at home), both running OSX 10.8.2. The constant and insessant clicking issues are becoming a real problem! I'm barely able to move files in Finder, files are getting placed in random folders, windows are randomly selected or deselected, I can barely resize windows or perform other basic tasks. The issue appears to affect all applications, and performing system-wide cache cleaning and other maintenance tasks hasn't changed anything (I ran Onyx through the full sweep).

     

    I've never used the Logitech drivers (some people have reported issues there), though Better Touch Tool is installed (primarily for mouse button customisation and window snapping). However, dissabling BTT does not fix the catestrophic clicking failures. The mouse continues to randomly double click, lose clicks, and otherwise act out.

     

    Anyone know what's wrong? I want to say it's an OS issues, primarily because I haven't been able to find any other solutions!

  • Chris Leishman Level 1 Level 1

    I took mine to the apple store and they replaced the trackpad. Problem is now resolved.

  • iaian7 Level 1 Level 1

    None of my macs have built-in trackpads, and they're compeltely different models from completely different lines of computers. The only thing in common is the OS, the mouse model, (both are set up with a Logitech MX1000), and some similar utilities (both have Alfred installed, both have Better Touch Tool installed, though disabling BTT doesn't fix anything - the issues remain the same!).

  • JeroenPotters(Macpot.nl) Level 1 Level 1

    Also took mine to the Apple Store. Had to replace it and now the issue is gone. Most have been an hardware issue