7 Replies Latest reply: Nov 4, 2012 2:19 PM by Don Hutchinson1
David Witkowski1 Level 1 Level 1

No matter what website I go to if I need to display a pdf file especially on government sites which I deal with a lot being a paralized vet. I have to tell you I am disappointed with the last couple vers. of Safari. Half the time auto fill doesn't work. Many times i'll just type the name of the address and in past versions of Safari it would fill in the other stuff, www., .com, etc. Well not any more. I've switched to making Google Chrome since it displays pdf's. Apple, you cn do better than this!!! O, by the way I've been using Apple products since the iic, and I've been using the internet from it's beginnings.This is the first time I"ve had any complaint about Safari up until now it's been my browser of choice.



Mac Pro, OS X Mountain Lion, 2.93Ghz, 6GB, 2.6TB, USB 3.0,
  • Carolyn Samit Level 10 Level 10



    All browsers require some maintenance at one time or another, or troubleshooting whether it's Safari, or Chrome, Firefox.. etc. I've yet to have any issues with Safari 6 on Mountain Lion.


    For the PDF issue...


    Open the Finder. From the Finder menu bar click Go > Go to Folder


    Type this exactly as you see it here:   /Library/Internet Plug-Ins


    Click Go then move the AdobePDF Browser plugin (or just PDF Browser plugin) from the Internet Plug-Ins folder to the Trash.  Quit then relaunch Safari to test.



    For autofill. Try troubleshtooting the Safari.plist (preferences)


    Back to the Finder. Go > Go to Folder.


    Type this:   ~/LIbrary/Preferences/com.apple.Safari.plist


    Click Go the move the Safari .plist file to the Desktop. Quit then relaunch Safari to test.


    If that that helped the autofill issue, move the .plist file to the Trash. If not, move it back to the Preferences folder.


    If that didn't work, Go > Go to Folder.


    Type this:  ~/LIbrary/Caches/com.apple.Safari/Cache.db


    Click Go the move the Cache.db file to the Trash. Quit then relaunch Safari. Try autofill.

  • leaudulac Level 1 Level 1
    Mac OS X

    This worked for me. Thanks!

  • iWarwick Level 1 Level 1

    Thanks! Worked a treat!

  • Redrudy Level 1 Level 1

    I followed your step 1:  moving the adobe pdf browser plug in to the trash.  Well, I almost followed it.  I removed the file that looked closest to it -- the adobeviewer something or other plug in.


    Then I couldn't do step 2, because my keyboard doesn't have the squiggly line key.  Should I just reinstall adobe?

  • Don Hutchinson1 Level 1 Level 1

    I too suffer frrom not getting Adobe pdfs to open in Safari


    I folowed your instructuions for Adobe PDF and got a no file foundresponse. 

    I then searched withSporlight and again drew a blank

    I found AdobePDFViewer PLug ins  but when I opend the folders were empty except for several p.lists

    I am using Adobe Professional 8.3.1  andalsoo Acrobat ReaderX 10.1  with Snow Leopard


    Am I causing a conflcit  or saddled with out of date versions?


    Works fine with Chrome


    Don Hutchinson

  • Don Hutchinson1 Level 1 Level 1

    This worked for me with a few caveats, which may be helpful for others


    When I first tried, I found that I did not have the permissions. So I had to close down and reboot as Administratr, though I am both administrator and user.  Minor point


    The nameof the file was not exactly correct.  but recognizable  so I trashed it


    But then it didn't work until I emptied the trash


    Finally worked



  • Don Hutchinson1 Level 1 Level 1

    This worked the first time  (see my suggestions)

    And it worked

    But now the problem is back

    So something =  an app of extension -  is causing the problem


    How do I set about finding the problem app/extension and dumping the culprit?