Previous 1 2 Next 26 Replies Latest reply: Jan 4, 2016 11:53 AM by tijean
Nijntje Level 1 (35 points)

My girlfriend and I are sharing calendars. Every time she adds an activity, Calendar on OS X Mountain Lion notifies me via notification center AND from within the app. I disabled this when subscribing to her calendars on Lion and iOS 5, but it's enabled for Mountain Lion by default.

 

How can I disable both?


MacBook Air, OS X Mountain Lion, Late 2010
  • mr.k99 Level 3 (640 points)

    In calendar, click on the calandar menu and select preferances. Select "Alerts" at the top. Check "Turn off shared calandar messages in Notification center".

  • tmc Level 1 (0 points)

    I've been having this same issue and cannot get the alerts to stop. That tick box is NOT working for me. So any other suggestions are welcome...

  • DavidSLynch Level 1 (5 points)

    I, too, have "Turn off shared calandar messages in Notification center" enabled, but I still get alerts for all my wife's calendar events. There must be a way to selectively turn off her alerts!

  • tmc Level 1 (0 points)

    I was just in an Apple Store last week, and the guy admitted it was a bug. There own business guys share calendars and don't want the alerts, so they are frustrated as well. Hopefully in an update they'll fix this.

  • DavidSLynch Level 1 (5 points)

    OK, I have successfully stopped my wife's shared appointments from triggering alarms in my Notification Center!

     

    Go to Calendar (desktop machine), and right-click on a shared alarm in the left sidebar. Choose "Get Info" from the popup menu, and then click the check box next to "Ignore Alerts".

     

    If you have more than one shared alarm, you must do this for every one of them.

     

    For my iPhone and iPad, I was able to disable the alerts from the Settings app: Settings>Mail, Contacts, Calendars>Shared Calendar Alerts (turn slider off - it's the last item on that settings page). Too bad this operation isn't consistent between desktop computers and mobile devices - I thought that was what Apple's been trying to do since Lion!

  • tmc Level 1 (0 points)

    Been there. Done that. It doesn't work for me. Not sure if there may be some holdover from older sofware when they were created. Now iMac and MacBook Air are 10.8 and iPhone is iOS 6.

  • DavidSLynch Level 1 (5 points)

    Sorry to hear that - I wonder why that fix works for some people, but not others? I am running 10.8.2 and have also run the supplemental update. All my mobile devices are runnign iOS 6.

  • tmc Level 1 (0 points)

    Just read an article in Macworld that says...

    "On some peoples' computers and devices, a bug seems to be preventing these settings from sticking."

  • BrassHornet Level 1 (60 points)

    I think there is some confusion here.

     

    There are alerts -- which are like little alarms that you can attach to an event in your calendar.

     

    There are notifications -- which are not calendar specific; any app can send you notifications.

     

    There's some confusion, because alerts are also notifications.

     

    FWIW

  • toutla Level 1 (0 points)

    Thanks David, I too had been trying only the "Turn off shared calandar messages in Notification center" in Preferences on my Macbook Pro, but continued to receive shared notifications.   Then I used your suggestion above to "Get Info"and click "Ignore Alerts" on each shared calendar.   Funny thing, when I went back to preferences, it had unchecked the "Turn off shared calandar messages in Notification center", so I had to recheck this option.   Now both are sticking and it seems to have stopped the unwanted shared notices.   Thanks for your post!

     

    Others, if you are still having trouble, double check your MBP preferences as you may need to re-check this option.

     

    Thanks

    Tim

  • Billy Finn Level 1 (0 points)

    I tried all of the above suggestions and none of them worked.  What DID work -- holding down the Option key while clicking on the Notifications icon in the menu bar (top right of the screen).  This apparently disabled all pop-up notifications -- hooray!

  • RAY1212 Level 1 (0 points)

    I had this problem too and your solution helped me. thank you.

  • zeeloop Level 1 (0 points)

    Unfortunately no hooray here  :-(  because if i disable ALL the pop-up notifications, not only the shared calendar's notifications are gone, my own keep quiet as well. So i surely forget going to the Hair Stylist tomorrow ...  :-(

  • Skatenski Level 1 (0 points)

    Does anyone know if Apple have been officially advised of this bug, especially on the iPhone?  Because there have been 2 updates to IOS 6 and nothing has been fixed yet.  My wife and I had only just discovered the whole calendar Sharing and Invitation things on our iPhones for IOS 5 and it was great.  But now since IOS 6 it's hopeless.  I would have thought it would have been fixed by now?

Previous 1 2 Next