Previous 1 2 Next 17 Replies Latest reply: Feb 4, 2015 9:21 AM by ugichik
Baba Level 1 Level 1 (40 points)

I can't get Mail to accept my password ever since setting up 2 step verification on Google. I asks repeatedly for my password which doesn't work. I deleted and set up my gmail again, and the problem persists. Oddly, I can send an email to other accounts with my gmail account but can't recieve any in the account. I went to Google settings and made sure all the right check boxes were clicked. Ideas?


iMac, OS X Mountain Lion
  • Baba Level 1 Level 1 (40 points)

    I went to Google settings and turned off 2 step verification until they figure this out. All the test emails I sent to myself showed up. The process for setting up the 2 step has to be streamlined.

  • alsifius Level 1 Level 1 (0 points)

    I was having the same issue and I found that the problem was my password for logging in to gmail to receive mail and the password for sending mail were out of sync, and this was causing me to have to revoke and re-issue passwords for the application. Everytime I would check or send email after a reset the behavior would repeat itself. I reset the pasword, chnaged the passwords to match in 'Keychain Access' and I have not experienced a problem with it since.

     

    Hope this helps, as I couldn't find any solutions elsewhere.

  • AKAK2 Level 1 Level 1 (0 points)

    You do not have to turn off 2-step verification.  The simple solution is to obtain an application-specific password that you will use once to apply for Mail.  Use the helpful steps as posted here by Cheesesilk:

     

    Steps for anyone else stuck:

     

    1. Go to Apple icon (top left of screen) > System Preferences > Mail, Contact & Calendars

    2. Delete your current gmail account by selecting it and pressing the "-" button

    3. Add a new Gmail Account by pressing the plus and selecting Gmail

    4. Type in your account details but when you get to the password stage, generate a new application specific password from:https://accounts.google.com/b/0/IssuedAuthSubTokens#accesscodes

    5. Type that new password in (you can copy paste it)

    6. Hit Setup and it shoud be now syncing up your calendar and mail account again!

  • 55cards Level 1 Level 1 (0 points)

    alsifius wrote:

     

    I was having the same issue and I found that the problem was my password for logging in to gmail to receive mail and the password for sending mail were out of sync, and this was causing me to have to revoke and re-issue passwords for the application. Everytime I would check or send email after a reset the behavior would repeat itself. I reset the pasword, chnaged the passwords to match in 'Keychain Access' and I have not experienced a problem with it since.

     

    Hope this helps, as I couldn't find any solutions elsewhere.

     

    Thank you for this — this is exactly what had happened to me! Two different 2-step verification passwords, one for imap, one for smtp. I would never have worked it out.

     

    Using Keychain Access to interrogate and replace both passwords with a new one has fixed it for me.

  • murray98 Level 1 Level 1 (0 points)

    55cards wrote:

     

    alsifius wrote:

     

    I was having the same issue and I found that the problem was my password for logging in to gmail to receive mail and the password for sending mail were out of sync, and this was causing me to have to revoke and re-issue passwords for the application. Everytime I would check or send email after a reset the behavior would repeat itself. I reset the pasword, chnaged the passwords to match in 'Keychain Access' and I have not experienced a problem with it since.

     

    Hope this helps, as I couldn't find any solutions elsewhere.

     

    Thank you for this — this is exactly what had happened to me! Two different 2-step verification passwords, one for imap, one for smtp. I would never have worked it out.

     

    Using Keychain Access to interrogate and replace both passwords with a new one has fixed it for me.

    SMTP vs IMAP logins - that was the issue for me and now it works. Thanks!

  • Mikhail Tuknov Level 1 Level 1 (0 points)

    Here it is! I finally fixed the issue! I've literally tried everything and this is what i did! I downloaded the Gmail App and setup my email account. After that, i went back to a regular pre-installed Iphone mail app and added my Gmail account information and it worked. Basically, the app Gmail app from the Apple store somehow pushed the signal to Gmail, saying Here it is, it is working account.

     

    I've spent about 3 days to figure out what was the problem, tried everything on the net, 2-step verification, Google display capture, deleting account and setting it up again, changing the password on Gmail account. I was going nuts! And i know there are so many people out there who are also having the same issue. They get this crazy message "Cannot Get Mail - The user name or password for 'Gmail' is incorrect." It was so annoying. I hated it!

     

    The solution to this problem is: Go to App Store on your Ipad or Iphone and search for "Gmail". Download the first one, Free version, install it and setup an email account with your existing credentials, the ones that didn't work earlier, and to your surprise, it will allow you to add your account back.

     

    Next step is to click Settings (on your Iphone, Ipad) --> Mail, Contacts, Calendars --> Add Account --> Gmail (Enter your lovely email credentials and you will see, it is working again, just like in early days!

     

    I hope it will solve your frustration and disappointment.

  • haag0031 Level 1 Level 1 (0 points)

    Really helpful AKAK2. Thanks!!!

  • browncoat101 Level 1 Level 1 (0 points)

    I just finished manually moving stuff to a new mac and I was having issues getting gmail hooked up again. Your post was the answer. I made sure the password was correct in the system preferences window, then opened Keychain Access and sure enough, the passwords weren't synched up. Changing the one to match the other fixed the problem immediately. Thanks for the great tip!

  • unsu Level 1 Level 1 (10 points)

    AKAK2 wrote:

     

    You do not have to turn off 2-step verification.  The simple solution is to obtain an application-specific password that you will use once to apply for Mail.  Use the helpful steps as posted here by Cheesesilk:

     

    Steps for anyone else stuck:

     

    1. Go to Apple icon (top left of screen) > System Preferences > Mail, Contact & Calendars

    2. Delete your current gmail account by selecting it and pressing the "-" button

    3. Add a new Gmail Account by pressing the plus and selecting Gmail

    4. Type in your account details but when you get to the password stage, generate a new application specific password from:https://accounts.google.com/b/0/IssuedAuthSubTokens#accesscodes

    5. Type that new password in (you can copy paste it)

    6. Hit Setup and it shoud be now syncing up your calendar and mail account again!

     

    THANK YOU SO MUCH!!!!!!!!!!!!!!!!!!!!!!! It works!

  • Tips and Tricks forum Level 1 Level 1 (0 points)

    You have to try the application-specfic password - an other function of gmail account to access your gmail account on iphone. Try it here : http://tipsandtricksforum.com/Thread-How-to-access-gmail-account-after-enable-2- Steps-Verification

  • Eileen Shipman Level 1 Level 1 (5 points)

    Thank so much. This has been driving me crazy and now it works!

  • kagor Level 1 Level 1 (0 points)

    Now Gmail has an option for this, you can generate your own password for each app that you use to check your gmail account. Google Support - troubleshooting

  • MCDBA Level 1 Level 1 (0 points)

    I had the same issue so I  deleted the account from the iPhone then reenable the account.  I am using SMTP and dissabled POP.  I then created a application-specific passwords using the two step process and all worked fine!

     

    The issue was the account was so old on the iPhone, I was not able to sync Mail, contacts Calendars and Notes. 

     

    I was only able to Sync Mail and Calendars with the old setting. 

     

    I am having no issues now.

  • bakermandwb4 Level 1 Level 1 (0 points)

    This solution worked for me...Thanks alot!

Previous 1 2 Next