2 Replies Latest reply: Aug 13, 2012 1:40 AM by dpcam1
dpcam1 Level 1 Level 1 (0 points)

I am having a major problem with getting my groups to behave separate of each other and I'm wondering if anyone has the answer. I have created a simple project with two video layers, a camera and a background. I have placed the two video layers in a group and the background in its own group. I've done this so I can manipulate the background layer. There is a camera at the top of the stack. The Group with the two video layers sits above the background layer. My problem is that if i select the group with the video layers, the background layers moves as well. If I select the background layer I am able to control that separate of the video layers. What is going on here as I have created two distinctly separate groups but the video layer group is acting as a master group. What is correct way to add a new group that can be controlled completely separately to all other layers?

Final Cut Pro 7, Mac OS X (10.7.2)
  • fox_m Level 5 Level 5 (4,650 points)

    In all likelihood, the background isn't moving, the camera is. When you add a camera to a project, ALL groups are converted to 3D. If you want to have a stationary background with a camera, turn the group back into 2D. You can do that by clicking on the little "stack" icon to the right of the group name, or select the group, and in the inspector > Group set the Type to 2D.


    If you're not moving the camera, then you might think you have two separate groups when in fact you have a group for your background inside the group for the 2 video layers so that the arrangement is something like:



         Video layer 1

         Video layer 2

         Background Group



    In Motion -- that's a really easy mistake to make. 


    To make the "Background Group" at the same "level" as TopLevelGroup, click on the Background group, drag the mouse all the way over to the checkbox column (you should see a blue line with a circle end -- and it will change length as you drag to the left.) When you get all the way to the left column AND the blue line is showing, release the mouse. IF the background group doesn't change it's level (Motion 5 doesn't always work dragging groups below the layers list), then drag the background group ABOVE the TopLevelGroup and to the left to the checkbox column and release. THEN drag the TopLevelGroup above the Background Group (should not be necessary in a 3D environment *unless* you add filters that rasterize layers in the group -- therefore, I recommend keeping the layer order arranged top to bottom.)

  • dpcam1 Level 1 Level 1 (0 points)

    Thanks a lot for your reply.....to the best of my knowledge the background layer was outside the video layer group. I have had this problem ab before and that is one of the first things i look for. I'm pretty sure im not manipulating the camera because i always check to see if all layer s are deselected before i click on the background layer to check if its functioning separately to the other layers. I wonder if its a bug because if i close the program and when reopen that project it works properly. Very weird.