Previous 1 2 Next 23 Replies Latest reply: Feb 21, 2013 2:54 PM by Ralph Johns (UK)
BasmaRasheed Level 1 Level 1 (0 points)

I had OS X Mountain Lion installed and iMessage was not opening so I reinstalled Mountain Lion. It currently opens but keeps telling me that I am not singed in and that iMessage is 'inactive'. I tried logging out and logging in again and I've tried changing my apple account password but nothing seems to be working. Is there anyone who knows what I can do to make it work again?
It's urgent.


MacBook Pro, OS X Mountain Lion
  • Phunku Level 1 Level 1 (0 points)

    Well seems to be something wrong on apples side. On my mac i get no messages in or out, on ipad and iphone i can send and receive but it says that it couldn't be delivered, but actually it does get through...

  • Chronus Level 1 Level 1 (0 points)

    I have a lot of problems with imessage after I've updated to mountain lion. Doesn't matter if i am sendindimessage from my iphone, ipad or mac it says that my message was not delivered.

  • Ralph Johns (UK) Level 9 Level 9 (68,670 points)

    HI,

     

    Is it possible for you to launch Messages and then access the Preferences (Messages Menu > Preferences)

    Once there can you access the Accounts section ?

     

    If you can get to this part can you untick the "Enable this Account" box so that the iMessages side does not log in at present.

     

     

     

     


    10:14 PM      Friday; August 17, 2012


    Please, if posting Logs, do not post any Log info after the line "Binary Images for iChat"

     

      iMac 2.5Ghz 5i 2011 (Lion 10.7.2)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),

    "Limit the Logs to the Bits above Binary Images."  No, Seriously

  • Tuckerman Moss1 Level 1 Level 1 (5 points)

    Hi Ralph,

     

    I've been having this problem too - the iMessages account is not working.  I have an AIM account that works fine.  But you suggest we go to the Accounts section of Prefs and untick the "Enable this Account box".  That certainly is doable and iMessages for that account doesn't log in.  But that's hardly a solution.  But you actually say '...does not log in at present."  Do you mean by that that you think Apple is having problems at the moment and we should just wait around til they fix it?  Or maybe something else is going to happen?

     

    Also of interest.  If only the Apple iMessages Account is enabled the Buddy List is not available.  It's not available in the Window menu and command-1 does nothing.  Turn the AIM account to enable and the Buddy list returns both to Windows and command-1.

     

    Slightly puzzled,  Tuck

  • Ralph Johns (UK) Level 9 Level 9 (68,670 points)

    Hi,

     

    When starting up  Messages for the first time it insists on having an Apple ID and if this does not  work then Messages can get stuck in this sort of endless loop of not logging in the Apple ID and therefore not giving you access to the rest of the App (Buddy Lists)

     

    My suggestion was to try a  break that circle by stopping the Apple ID part logging in to iMessages.

    (to the extent the app would work across Shut Downs and Start ups)

     

    If you get to this point and have Other "Accounts" of the iChat type (AIM, Jabber or Yahoo) then you should have at least a combined Buddy list (CMD + 1)

    If you log all the other accounts Off line then you have nothing in the Window Menu (only CMD + 0) from the Messages window itself.

     

    What you can do then is click the Account Details Button in Messages Menu > Preference > Accounts ? iMessage account and the use the Sign Out button

    Messages
    Uploaded with Skitch!

     

    This fully disengages that Apple ID with the iMessages server

    You can then try to add a different Apple ID or re-try with the one you are haiving issue with.

     

    At this point it is possible to create two iMessages accounts in the Accounts list.

    You have to delete com.apple.imservice.imessage.plist to correct this.

    This file can be accessed via the Finder > Go Menu > Hold ALT key and select Library > open Preferences folder.

     

     

     

     

     


    8:43 PM      Monday; August 20, 2012


    Please, if posting Logs, do not post any Log info after the line "Binary Images for iChat"

     

      iMac 2.5Ghz 5i 2011 (Lion 10.7.2)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),

    "Limit the Logs to the Bits above Binary Images."  No, Seriously

  • Ralph Johns (UK) Level 9 Level 9 (68,670 points)

    See also

    https://discussions.apple.com/message/19325621?ac_cid=tw123456#19325621


    8:51 PM      Monday; August 20, 2012


    Please, if posting Logs, do not post any Log info after the line "Binary Images for iChat"

     

      iMac 2.5Ghz 5i 2011 (Lion 10.7.2)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),

    "Limit the Logs to the Bits above Binary Images."  No, Seriously

  • Tuckerman Moss1 Level 1 Level 1 (5 points)

    Hi Ralph,

     

    Thanks for the suggestions - but I either misunderstood or it did nothing.  To review:

     

    1) Two iMessage accounts - one iCloud, one AIM.  The iCloud has been active and working for several months.  Stopped two days ago.  And by stopped I mean no Buddy list, nor Buddy List in Window or command-1

     

    2)  Enable AIM account and the combined Buddy List appears.  Enable both accounts Buddy List remains.  Turn off the AIM account and Buddy List Vanishes.

     

    3)  Now I will uncheck Enable on the AIM Account.  Then do the same on the xxxx@me.com account.  On me.com account I click the Sign Out button and it signs out.  I then re-enter the right password and am told Failed to Verify - the account is in use.  The only option available is Remove Email.  If I do that I am then caught in the endless spinning gear wheel.

     

    4)  What is not clear to me is what I do from here.  I un-enable the me.com account and continue using the AIM account - but that's not the account I want to use.

     

    5)  I do use the same me.com account in FaceTime successfully

     

    6)  You suggest removing the com.apple.imservice.imessage.plist file - but that file does not exist in Mt Lion.  All I can find in preferences are:  ~/Library/Preferences/com.apple.imessage.bag.plist and .../com.apple.imessage.plist

     

    Your thoughts would be most welcome.

     

    Tuck

  • DBW Level 1 Level 1 (30 points)

    Hi Ralph. I saw an ealrier post of yours regarding screen sharing via Messages vs iChat and am wondering if you could help me. I recnelty upgraded to ML and tried to share screens with my daughter also on ML. We both have an AIM account plus an iMessage account. Both (cant verify for daughter however), showed the AIM account to be active. We could iMessage each other and do Facetime just fine.

     

    "invite to share screen" was greyed out. I researched and found out that it doenst work with iMessage accounts, only AIM etc. So i went to the Account drop down and verified AIM was online, and active. It was. Then i switched to "talking from" my iMessage account to AIM account and tried to contact my daughter. Kept getting that she was offline. She says she was online.

     

    Any ideas.. am i missing a step? I cant verify she was online.

     

    Do i need to switch accounts to AIM to initiate a screen sharing, or if she was online, would it have not been greyed out, even though we were on our iMessage accounts?

     

    It used to be so simple to use in iChat... ugh.. i could do a video chat, switch to audio / screen sharing etc.

    Now i have messages sometimes showing up in Messages, sometimes on my phone, sometimes on my ipad, sometimes all three, depending on whether or not hte sender chooses my phone number or my imessage account name ( for which i cant control), and lastly, i had an embarrasing text message that came to all three, yet when i deleted it from my phone, it still stayed glaringly open, front and center on my computer at home of which i was not at home to erase.. what a mess......I have since disabled my imessage account in message...

     

    Any advice would be welcome. thanks!

  • Ralph Johns (UK) Level 9 Level 9 (68,670 points)

    OK,

     

    Lets try to sort out the semantics again

     

    The App is called Messages.

    It is effectivley iChat +

     

    In setting it up you need an Apple ID to Register with the iMessages Servers

    This then gets listed as an "Account" in the Messages Menu > Preferences > Accounts

    Your Messages may then pick up on any iChat style Buddy list/Accounts you had prior to Mountain Lion and these will be in the list as well.

    There will also be a Bonjour Option (everyone gets Bonjour)

     

    If you have two "Accounts" in the list listed as iMessages there has been an error.

     

    The iMessage Account only appears in the Preference > Accounts list and the Messages Menu > Accounts sub item (where it will be ticked in Logged in)

     

    IF....

    The iCloud ID is the one you used for iMessages and you also have an AIM Account you will only see the AIM list in the Window Menu > CMD + 1 (Buddies) Unless the Bonjour Account is also Active/Enabled or you have other "Buddy List" accounts that are Enabled and logged in.

     

    Your 3) is the bit that makes me think we are talking about an iChat Style "Aim" account and an Apple ID used as the iMessages registration

     

    Pause ....... >>>>>>

     

    OK Your iCloud Apple ID is also an Valid AIM Screen Name meaning it can also be Added as an "Account"  in the Preferences via the + Button as a AIM account listing the EMail type name in full with the @Me.com bit as well.

     

    Like What I have

     

    Messages Accounts
    Uploaded with Skitch!

     

     

    Staying with this Pic and your 3) I presume you mean you are using the Account detail Button and then the Sign Out button on the next pane ?

     

    Re 6) I have this file in Mountain Lion

    I can only Presume it has not been created yet as the Apple ID in question has not been Registered.

     

    Can you use this Apple ID on the iPhone or an iPad in Messages (In iOS version) ?

     

    It may pay to remove the two .plists you do have  (the first lists the Apple Server iMessages connects to and the second looks like a hold-over from Messages Beta)

     

    If you have com.apple.IMAgent.plist then delete that as well.

     

    Restart Messages

     

     


    11:17 PM      Tuesday; August 21, 2012


    Please, if posting Logs, do not post any Log info after the line "Binary Images for iChat"

     

      iMac 2.5Ghz 5i 2011 (Lion 10.7.2)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),

    "Limit the Logs to the Bits above Binary Images."  No, Seriously

  • Ralph Johns (UK) Level 9 Level 9 (68,670 points)

    HI,

     

    I would do it this way.

     

    Go to the Preferences > General Section.

    Untick the item that gathers all Accounts in to one list  (this is actually only non iMessage Accounts - the one that have Buddy lists)

     

    You may find you have the AIM and a Bonjour Buddy list now.

     

    Click the Status Message in each Buddy list that appears

    Check it is not set to Invisible for any AIM Login.

    Double check that the Bottom item for Making all Statuses the same is not selected in ANY Buddy list.

     

    There are some odd cross over things that should not happen regarding Statues

    The Bonjour "Send as I type" from previous iChat versions can still be active as it is in the .plist and this can effect Yahoo Accounts.

    Yahoo and AIM account can do "Invisible" but if it is globally set it seems to effect Jabber accounts as well.

     

    If nothing seems amiss then deliberately make yourself Invisible and then change it back.

     

    Obviously most of this is aimed at your daughter.

     

    Next she should double check the Preferences > Accounts > Security tab and make sure you are Allowed or not Blocked.

     

     

     

     

     


    11:26 PM      Tuesday; August 21, 2012


    Please, if posting Logs, do not post any Log info after the line "Binary Images for iChat"

     

      iMac 2.5Ghz 5i 2011 (Lion 10.7.2)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),

    "Limit the Logs to the Bits above Binary Images."  No, Seriously

  • BasmaRasheed Level 1 Level 1 (0 points)

    I changed the region in iMessage prefrences and that solved my problem. Apparently, my region was set to the US on my phone but was not set on my Macbook Pro, and that is what caused iMessage to not work.

  • Ralph Johns (UK) Level 9 Level 9 (68,670 points)

    Thanks for letting us know

     

     


    9:03 PM      Thursday; August 23, 2012


    Please, if posting Logs, do not post any Log info after the line "Binary Images for iChat"

     

      iMac 2.5Ghz 5i 2011 (Lion 10.7.2)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),

    "Limit the Logs to the Bits above Binary Images."  No, Seriously

  • Ralph Johns (UK) Level 9 Level 9 (68,670 points)

    Thanks for the Points.

     

     


    8:01 PM      Saturday; September 1, 2012


    Please, if posting Logs, do not post any Log info after the line "Binary Images for iChat"

     

      iMac 2.5Ghz 5i 2011 (Lion 10.7.2)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),

    "Limit the Logs to the Bits above Binary Images."  No, Seriously

  • floatpod Level 1 Level 1 (0 points)

    Ralph, I've just spent the past two hours trying to find a solution to my AIM user in Messages not connecting/working; it stopped working when I upgraded to Mountain Lion.  I found my solution just now in this 2011 thread where someone had a similar problem and you helped them out.  Deselecting the SSL box in the Account preferences fixed things immediately (too bad that I didn't view this thread first two hours ago!)

     

    Many, many thanks!

Previous 1 2 Next