13 Replies Latest reply: Oct 10, 2012 7:02 PM by jamesgilbert
Julian999 Level 1 (0 points)

Very frustrating. In previous versions of the shuffle I was able to select to listen to all podcasts in a row automatically. Now I can't seem to figure it out, I tried creating a playlist as I do with music, however the shuffle is smart and figures they are podcasts so just enters them in as such. Then I go to play them and it separates them into different playlists depending on the podcasts.


Engineers: it wasn't broken to begin with so stop playing around with features and just create something usable... maybe it's too much to expect from Apple with Steve Jobs gone. A waste of $50 if you can't help me figure it out.

iPod shuffle
  • Kenichi Watanabe Level 7 (33,042 points)

    FYI - I think it works the same as the 3rd gen shuffle, and Steve Jobs was around to "approve" that model...


    If you play with the switch in shuffle mode, podcasts are skipped on playlists.  Podcasts are always skipped when playing from the All Songs list. 


    If you put podcasts on a playlist, and use the VoiceOver button to switch to that playlist, with the shuffle's switch set to play in order mode, then the podcasts should play in playlist order.

  • Julian999 Level 1 (0 points)

    thank you Kenichi.


    I could swear I had tried that exact approach and the podcast playlist didn't transfer (and I was using it in the play in order mode). Regardless, after making a big deal of my frustration, it worked.


    thanks again.



  • Jshuffle1 Level 1 (0 points)

    How does that solve anything? I have the same problem since a few software updates back. I manage manually, always play in order, and i can't get podcasts to play in a playlist (have tried reclassifying as music, that didn't work either). To add insult to injury, to switch between podcasts the voiceover cycles through the ENTIRE list of podcasts loaded, from the top, every time. I used to just load a dozen or so different podcasts into a playlist, in MY preferred order, and it worked perfectly. Now I'm back to burning CDs for the car--all this switching is not safe. It wasn't broke!

  • Kenichi Watanabe Level 7 (33,042 points)

    There was actually nothing to "solve."  If you create a playlist with podcasts, set the shuffle's switch to play in order, and switch to that playlist using the VoiceOver button, the podcasts should play in playlist order.


    If it does not work that way for you, you may want to do a Restore, using the Restore button on the shuffle's Summary tab.  This will erase the shuffle, re-install the latest software, and set it to default settings.  If there is a software glitch causing your problem, the Restore should fix it.

  • Jshuffle1 Level 1 (0 points)

    sorry, despite high hopes (hardly justified--I had restored several times previously), each podcast is still a separate playlist.Nothing has changed. This is true on 2 separate Shuffles. My software is the current version (10.6.3).

  • Kenichi Watanabe Level 7 (33,042 points)

    Even if you have only one playlist (the one with your podcasts) on your shuffle, you still need to switch to it using the VoiceOver button.  I realize that you must be using the VoiceOver button, because you can find each podcast as its own separate "playlist." 


    So, it's not just the All Songs list and each separate podcast list.  It's the All Songs list, a list of playlists (or just one playlist if there is only one on the shuffle), and the separate podcast lists. 


    My guess, especially since it does not work for you even after a Restore, and on two shuffles, is that you are not noticing that there is a playlist there that you need to select.  You are trying to play the podcasts from the All Songs list (where they will not play), or from the podcast lists (where there are separated by podcast).  If you select the playlist with the podcasts (not the All Songs list or the separate podcast lists), and the switch is set to play in order, they will play in playlist order.


    The other possibility is that you do not have a playlist on your shuffle.  You are dragging podcasts directly to the shuffle (or syncing podcasts directly), and they are NOT on a playlist on the shuffle.  If that is the case, they will not play on the All Songs list, because podcasts do not play there, and the only place they will be available is from the seperate podcast lists.


    See this Apple document about using VoiceOver




    in particular, Changing playlists and To choose an item from the playlist menu.

  • Jshuffle1 Level 1 (0 points)

    The podcasts are in one playlist. That playlist is the only thing on the Shuffle. (If there is an All Songs playlist, it is invisible and inaudible. Remember, I'm managing manually.) The voiceover lists each separate podcast on the playlist (treating multiple episodes of the same podcast as one entry) and nothing else. I think the thing's been switched to shuffle mode maybe twice in its life (and the other device, never), and that was unintentional. I've been listening to podcasts in playlists for 5 years at least, on an old nano before it died a couple years ago, and it's always worked--except a brief stint about IIRC 2 years ago, when it was magically repaired a couple weeks after people started complaining.


    I just loaded 2 playlists to see what would happen. Voiceover mashes them together, does not distinguish between the two, just lists each podcast in whatever mysterious order it prefers (provider, maybe?).


    I notice we have quite a few page views.  Folks, if you could spend the few minutes to register, we could use some more data here.



  • Kenichi Watanabe Level 7 (33,042 points)

    Select the shuffle in the iTunes sidebar (under DEVICES), and click the little triangle next the the shuffle, so that it points down.  You should see media categories indented under the iPod.  If there are podcasts and music on the shuffle, it should have Music and Podcasts indented under the iPod.  Under those categories, you should see any playlists that are on the shuffle.


    Do you see your playlist (the one with the podcasts) there, indented under the shuffle in the iTunes sidebar?  Is that playlist where you are dragging your podcasts, when you load your shuffle manually?

  • Jshuffle1 Level 1 (0 points)

    With the Shuffle loaded with one podcast playlist (whether or not the genre has been "rebranded" to music), the device list displays Music (empty) and Podcasts (the list of podcasts on the playlist--not the playlist title).


    I loaded a couple Music playlists to see what would happen. Suddenly my podcast playlist appears, by name, below the Music and Podcast categories,  as its own thing. The Music list does not display the names of the 2 playlists, just the individual song titles from both, in their original order. The Podcast list still displays the names of the individual podcasts on my playlist. Voiceover announces, in order: 1) All Songs (no distinction by playlist), 2) Name of Podcast Playlist; 3) each individual podcast by name, in default order (not mine). (None of these choices are nested--it's a flat list. I divided into 3 for reference.)


    If I select option (2) I get a podcast playlist that works properly. If I actually wanted those music playlists to function as such, though, I'd be out of luck. As a temporary workaround, I can live with it.

  • Kenichi Watanabe Level 7 (33,042 points)
    whether or not the genre has been "rebranded" to music


    FYI - The way to "rebrand" an item to reclassify it as a different type of iTunes media is NOT with the Genre setting.  Instead, select the item in iTunes and do a Get Info.  In the Info window, go to the Options tab.  Change Media Kind to Music, Podcast, Audiobook, etc.  Changing the Genre setting does nothing to change how iTunes categorizes the item.


    I loaded a couple Music playlists to see what would happen.


    Playlists are playlists...   There in no distinction between a "Music" playlist and a "Podcast" playlist.  It's up to you do load them as desired.


    If I actually wanted those music playlists to function as such, though, I'd be out of luck.


    I don't understand.  Just load a playlist that only has podcasts on it (your "Podcast playlist"), AND one or more other playlists that only have music.  Then VoiceOver will read then off separately, and you can choose the one you want to hear.  If you take a look at the artcle I linked previously




    where is says Changing playlists and To choose an item from the playlist menu, your description basically matches what it says there.  So, glad to hear your shuffle is working as designed... 

  • Jshuffle1 Level 1 (0 points)

    "The way to "rebrand" an item to reclassify it as a different type of iTunes media is NOT with the Genre setting. Instead, select the item in iTunes and do a Get Info. In the Info window, go to the Options tab. Change Media Kind to Music, Podcast, Audiobook, etc." That was helpful, I had misremembered the fix. That actually gets a podcast playlist to play like a playlist, without having to load music. Still a pain in the neck, and it didn't use to be necessary.


    "Playlists are playlists... " well, of course they should. Surely the whole point of this thread is that suddenly playlists stopped functioning correctly, at least for many of us.


    My voiceover still refuses to recognize my two music playlists. I don't see that as "working as designed." It worked fine for years. Now it doesn't. I can live with the workaround, but please fix it.

  • Kenichi Watanabe Level 7 (33,042 points)
    Surely the whole point of this thread is that suddenly playlists stopped functioning correctly


    At this point, can you explain what is still not "functioning correctly"?


    My voiceover still refuses to recognize my two music playlists.


    When you look under the shuffle the iTunes sidebar, do you see your two music playlists there, in addition to the other playlist that only contains podcasts?  If you do, when you use the press and hold VoiceOver button command on the shuffle, ALL of those playlists should be read by VoiceOver?


    NOTE:  When you use the Manually manage music setting, you can create a new playlist directly on the shuffle by right-clicking on the shuffle in the sidebar and selecting New Playlist.  These playlists will exist only on the shuffle.  Then, with the playlists you want created on the shuffle, drag items such as podcasts and songs to their respective playlists on the shuffle, instead of dragging them to the "overall" shuffle.


    Alternately, you can create new playlists (for items you want on the shuffle) in your iTunes library (not on the shuffle).  In your case, one for podcasts and two for music.  Put the items you want on the shuffle in those playlists.  Then, set up the shuffle's Music tab (in iTunes) to automatically sync ONLY those playlists to the shuffle.  Make sure the total content on those playlists will fit on the shuffle.  The playlists and the items they contain will be loaded on the shuffle when you click Apply.  Going forward, you can update those playlist at any time, even when the shuffle is not connected.  The next time you connect the shuffle (or when you click Sync), your shuffle will be updated with the changes you made automatically.  That's the way I recommend you use your shuffle.

  • jamesgilbert Level 1 (0 points)

    I have just had this exact same problem and eventually discovered how to fix it.  For me, it was an embarrassingly simple *facepalm* realization.


    The problem was that I had been creating my smart playlist of podcasts *in iTunes* and then trying to sync that playlist to the iPod shuffle. This resulted in the problem that Julian999 described, i.e. although all the podcasts in the list synced successfully to the iPod, the playlist itself did not appear on VoiceOver, and the podcasts would appear separately, grouped by podcast, and in alphabetical order, whatever I did with the playlist.


    The solution was instead to create the smart playlist *on the iPod Shuffle*.  In other words, select the iPod Shuffle in the left hand sidebar first, before hitting Command-Option-N (or selecting File>New Smart Playlist).  This creates the smart playlist not in iTunes but on the iPod itself.


    Having done that, the smart playlist actually appears as a playlist in the ipod and it is possible to play the episodes continuously or shuffle them as desired.


    Hope that helps anyone that was tearing their hair out as I was.....