Previous 1 2 3 4 5 6 Next 86 Replies Latest reply: Nov 7, 2015 10:26 AM by c_buck88 Go to original post
  • greg sahli Level 7 (25,305 points)

    Doug - I don't have an HP/Ricoh color (compatible) printer to actually test this...

    I think you can change the limitations of the driver by going to the CUPS internal web page. Use a browser and go to:

    http://localhost:631/admin

    then go to Manage Printers > double-click on the printer, then select Administration > Set Default Options.

    Make changes, then click on Set Default Options at the bottom.

     

    Let us know if it works.

  • DougStod Level 1 (0 points)

    Thanks Greg,

     

    That option does not seem to work for me.  I guess the web interface is disabled for me.

  • greg sahli Level 7 (25,305 points)

    That's not likely. Try localhost:631, then click on the admin tab, to see if it asks for an admin user/password.

  • DougStod Level 1 (0 points)

    Same message.  Here is what I get:

     

    Screen Shot 2013-05-14 at 7.43.30 AM.png

  • greg sahli Level 7 (25,305 points)

    Interesting. Are you an admin user? Did someone else configure this mac?

    Open Terminal (utility) and run that command:

    sudo cupsctl WebInteraface=yes

     

    sudo means superuser do (admin). It asks for your admin password. It will hide what you type - don't be surprised.

  • nichlaus41 Level 1 (0 points)

    hi, RICOH multifunction printer/copiers/scanners/fax etc....  (Aficio MP & MP C), they've got an adobe postscript 3 option that will enable your mac to print from a mac os environment. its a SD card that will be purchase as an option, it will be installed on the machine and surely you can print from any mac os version....9 - 10.8.

  • PartyOnWayne Level 1 (0 points)

    Hey guys, very similar the same issue as original poster. I'm on 10.6.8, have downloaded and installed the 3 files listed earlier and I'm using the PXL drivers. Alas, still no luck.

     

    The print is either unable to connect to the printer, or gets stuck Spooling at X%, neither results in an actual print.

     

    Any ideas? How can I check the IP address? I PC that prints just fine, but it's the mac I want connected to the network.

  • greg sahli Level 7 (25,305 points)

    You should be able to see and set the IP address on the printer front panel menus.

    What IP print protocol are you using? I'd use IP > HP Jetdirect first.

  • PartyOnWayne Level 1 (0 points)

    The powers that be implemented a new printer. Same brand different model. HP Jetdirect works perfectly now.

     

    Thanks all! Great thread!

  • d4v1dv00 Level 1 (0 points)

    Thanks, you saved my day!

  • kiwiandy Level 1 (0 points)

    I cant print in color either..

    When I try to Modify the Printer settings it requires Authentication.

    This doesnt accept my username and password for my MB?

     

    Screen Shot 2013-12-19 at 1.23.27 PM.png

  • howdyisme Level 1 (0 points)

    Tomolas, you totally saved my life.

     

    As you refering to the installation of these three drivers that worked out with my mbp (Mavericks) and Aficio MP C4500 RPCS.

     

    Thank you.

  • david_gf Level 1 (0 points)

    Hi,

    I hope I have found the easy way.

    1. delete the printer from the printer list if it is already created.

    2. download latest driver from http://sourceforge.net/projects/gimp-print/files/gutenprint-5.2/5.2.9/gutenprint -5.2.9.dmg/download

    3. create a new printer, if the Ricoh is not offered find it with the IP number

    4. where it offers the driver choose select software

    5. one of the first printers drivers on the list will be the one you are looking for - Apollo P-2500 - CUPS Gutenberg or your printer model

    6. if you do not see it, go to the top of the list and look at the Apollo list

    7. select the one you want and hey presto.

     

    it prints for me, yet to see how well

  • Lizzy10000 Level 1 (0 points)

    Hi, I have just followed your instructiuons to print to an Alficio MP C2051 printer and it has worked except I can only print in black and white. Do you have any ideas why ? Thank you.

  • Simon Lim Level 1 (5 points)

    I'm on the same boat.  Got it to work but only in B&W.  Would be great if there's a driver out there that can print color as well.