Previous 1 2 3 Next 31 Replies Latest reply: Jul 21, 2015 1:55 PM by RandySK
Carl Muckenhirn Level 1 (5 points)

Can anyone provide some insight into what 's going on with the wiki (I think) app inside ML Server?


8/14/12 7:34:26.911 AM sandboxd[91711]: ([91794]) collabpp(91794) deny file-read-data /Library/Preferences/.GlobalPreferences.plist

The above error is all over my logs. I also have a bunch of errors like:


8/14/12 7:34:26.548 AM ruby[91794]: CFPreferences: user home directory for user kCFPreferencesCurrentUser at /var/teamsserver is unavailable. User domains will be volatile.


Help, please.

  • Richard0415 Level 1 (0 points)

    I have this exact same issue (log posted below).  This was from a clean install of ML server.  I had issues with the migration and decided to start over with a clean install.


    The only services that are running are:

    DNS, Mail, Open Directory, Websites, Wiki


    I replaced the stock SSL with a godaddy UCC cert and made it the default selection.

    I populated the OD with four names and one group for testing.

    Mail is a vanilla setup with auth set to auto.

    Websites has a few entries but nothing special (no custom config in apache).

    Wiki is untouched.



    I replaced my actual domain and extension with EXAMPLE.COM but the rest is correct.


    Aug 15 00:31:03 home.EXAMPLE.COM ruby[4175]: CFPreferences: user home directory for user kCFPreferencesCurrentUser at /var/teamsserver is unavailable. User domains will be volatile.

    Aug 15 00:31:03 home.EXAMPLE.COM collabpp[4175]: CFPreferences: user home directory for user kCFPreferencesCurrentUser at /var/teamsserver is unavailable. User domains will be volatile.

    Aug 15 00:31:03 home.EXAMPLE.COM sandboxd[4188] ([4175]): collabpp(4175) deny file-read-data /Library/Preferences/.GlobalPreferences.plist

    Aug 15 00:31:03 home kernel[0]: Sandbox: sandboxd(4188) deny mach-lookup

    Aug 15 00:31:04 home.EXAMPLE.COM sandboxd[4188] ([4175]): collabpp(4175) deny file-read-data /Library/Preferences/.GlobalPreferences.plist




  • Richard0415 Level 1 (0 points)

    Info from the console:


    8/15/12 12:04:37.886 PM ruby[14157]: CFPreferences: user home directory for user kCFPreferencesCurrentUser at /var/teamsserver is unavailable. User domains will be volatile.

    8/15/12 12:04:37.894 PM[1]: ([14157]) Exited with code: 1

    8/15/12 12:04:37.971 PM ruby[14158]: CFPreferences: user home directory for user kCFPreferencesCurrentUser at /var/teamsserver is unavailable. User domains will be volatile.

    8/15/12 12:04:38.004 PM collabpp[14158]: CFPreferences: user home directory for user kCFPreferencesCurrentUser at /var/teamsserver is unavailable. User domains will be volatile.

    8/15/12 12:04:38.000 PM kernel[0]: Sandbox: sandboxd(14162) deny mach-lookup

    8/15/12 12:04:38.159 PM sandboxd[14162]: ([14158]) collabpp(14158) deny file-read-data /Library/Preferences/.GlobalPreferences.plist

    8/15/12 12:04:38.892 PM sandboxd[14162]: ([14158]) collabpp(14158) deny file-read-data /Library/Preferences/.GlobalPreferences.plist

    8/15/12 12:04:46.262 PM collabd[3886]: [CSContentService:47 3731000 +15ms] Detected Magic Superuser Auth Token

  • Martyin Level 1 (15 points)



    Same problems here.. But it's not really new. It seems to be an old nabble from the past somewhere.

    I have currently 2 servers up, a Mountain and a "prior-mountain"

    Before that the Leopard etc. I have seen these errors on all of them.


    For this one,


    You can read more here. CFPreferencesUtils/Reference/reference.html


    Sorry for not answering, but I just ran in to it again with the installation of Mountain server.

    This night I took another shot in finding the source of it all.

    I'm not really quick as I am not a programmer... ;(

    It more and more seems to me that you have to be a programmer to solve a lot of problems nowadays... lol


    If I find anything, I'll post it here, otherwise I hope to read from you guys,,,...


    Have a good one..



  • Martyin Level 1 (15 points)

    In one of the older versions there was a similar problem with the same error messages...

    It might have to do with the same problem:



    A quick look at the logs on the server hinted that the issue was tied to home directories, with several warning messages about problems with home directories: CFPreferences: user home directory at /99 is unavailable. User domains will be volatile.

    Sure enough, when I looked in WGM, I had forgotten to assign home directories to the accounts. I quickly corrected this (relatively large) oversight & BAM! clients were logging in without issue!

    End quote



    ruby[14158]: CFPreferences: user home directory for user kCFPreferencesCurrentUser at /var/teamsserver is unavailable. User domains will be volatile.

    end quote.


    It seems strange though, as if the teams user needs a homedir ?

    Or what user are we talking about?

  • spacecaptain Level 1 (0 points)

    install Workgroup Manager for 10.8 and make sure that the teamsserver user has a user home folder set, I believe it should be /var/teamsserver


    My ML install didnt have this folder so I created it and chown'd it to _teamsserver:_teamsserver and that stopped the kCFPreferencesCurrentUser error.


    I am still seeing the collabpp deny file-read-data error though. some other posts ( indicate that this relates to the sandbox files in /usr/share/sandbox but I cant see anything in there to do with the collabpp service yet.

  • Martyin Level 1 (15 points)

    you'r just to fast...

    I was well on the way as the mail came in,...

    It did the trick.. how stupid can you be ?


    Just found out bout the new WGM. Cool...


    But there's another stupid little thing that makes life difficult hehe


    Of course we want the Users dir not on the osx startup drive..

    So i was able to create the "user" dir and share it etc...

    user came in the dir everything fine...

    But, system complains etc so changed it back and now users can login, (new OD) and there we have it.

    Information could not be saved. No key available in keychain.. etc etc

    created a new one. doesn't help.


    that's where I currently am...



    Thanks for the info ....

  • spacecaptain Level 1 (0 points)

    I'm a bit confused as to what you are trying to do.

    Do you want your OD users to have their Home Folder on another drive? If so, I assume you have done the following:


    In -> File Sharing: add the folder on the other drive, share it, edit the share point and make sure to tick the box 'make available for home directories' (are you using AFP or SMB?).

    Then open Workgroup Manager and assign the home folder to the users.


    You said 'the system complains'. What is the error message when your users login? Are they network accounts or mobile accounts? Is the OD running on the same server as the home directories?

  • Martyin Level 1 (15 points)

    Almost there...


    What I did was creating another home on another drive and then to the shares.

    of course I did not delete the original share that at the moment was no longer in use. What you get is a second User Folder, they (the people on the mac lol) take it in their own hands and to be convenient they rename the new User share to something that I didn't want. (I think it was something like Users - 1 )

    Anyway, to fix that I stopped sharing the original one, nobody in it thus, and renamed the New -1 one to the Users.

    Then of course I did what I had to do, and it worked.


    But then after some time : Messages in the log like: You took the Home dir away right underneath us..

    In the future system this will be Fatal.


    And I guess, that's what happened.

    Now I am trying to solve all the other messages.

    Yhe thing is that if there are more problems in the logging's, it\s harder to solve them, are they connected ?

    Is it something else.. ?


    Like I had a client of which I was unable to log on. That looked very related to the User folder Move.

    cause of key errors etc.

    BUT, I was able to log on, it just did not save the keys.


    Then I thought, before the move of the user folder I had almost everything on air... lol

    Even the Profile/device manager was working. Well you probably know that's a little more then flippin a switch...

    Well anyhow, the accounts are the ones that I had added earlier, then decided to do the users over again, and what happens ? The Profilemanager did not delete the user and that was the whole problem for not being able to logon ...


    Nice story? but true though...

  • pleyden1 Level 1 (0 points)


    I am seeting the same errors.  I am going to look into the WGM to make sure teamserver has it's home dir.


         The issue I have is that network users are not able to login reliably, in other words they try 5 times and the login window shakes as if it were a bad password, and then it will work no problem. Additionaly I also have users reporting they are losing the connection to the server while logged in, as in they cant save to their documents folder because the connection has dropped?

    Rebooting the server seems to fix the issue temporarily.


    Any ideas?


    Thank you!

  • spacecaptain Level 1 (0 points)

    Hi pleyden1


    I dont think that these plist read errors would be affecting the network user logins, especially because these errors seem to relate to the collabpp service. What are the errors on your client machines when they fail to login? Perhaps there are more details there.

    Are they AFP or SMB network homes?

  • Martyin Level 1 (15 points)



    Just a note.


    In my situation, I was able to track back what the issue was.


    The problems started after moving the Users map.

    The reason that it went wrong was, because I relocated the Users dir AFTER I started the configuration of profile manager that triggered the installation of the OD master in  case.

    That went wrong, the user creation etc was fine, but there are "some other" external issues related to the move of the Users folder that where left aside and assumed that the Usermap is on the same place. But it wasn't so it starts going wrong from that moment on. Endless....


    So I believe the correct sequence that worked for me was to:

    1 initial Mountain Lion, then install and setup OSX Server (basic)

    2 Adjust and or Check! the DNS for correct operation, as it is the only service started after the basic installation.

    3 reallocate the Users Map / groups map and or server data location.

    4 Create the "missing" teamsserver map and give appropriate rights

       (chown  _teamsserver:teamsserver  teamsserver

    5 Configure the correct ports / port forwarding

    6 Check if needed the Certs ( if needed cause you have a commercial one )

    7 Start the Profile Manager configuration (Without starting up the service, just configure)

    8 Check the logs after this

    9 Start Web server and Wiki and Messenger

    10 Start Profile manager

    11 Start rest of the services as needed

    12 After checking logs again and if everything seems ok, THEN start creating users and groups.


    As far as it go's now, its working like a charm...



  • ThomHughes Level 1 (0 points)

    Sorry for being a dummy, but when I use workgroup manager on 10.8.2, I see my network users but no teamsserver.  What am I missing?

  • Mark23 Level 3 (975 points)

    In Workgroup Manager 10.8 you should switch to the local directory and select Show System Records under the View menu bar item. If you have done those two things, the teamserver user can be found amongst in the Users

  • ThomHughes Level 1 (0 points)

    Thanks! That got me to the part in WGM where I can see teamserver, and see that teamserver does not have a group folder.  But I'm really fuzzy at this point about how I set up a new group folder for team server at /var/teamserver.  Could you point me in the right direction?  Thanks!  thom 

Previous 1 2 3 Next