5 Replies Latest reply: Jan 12, 2014 2:47 AM by Teri-lee
wesley88 Level 1 Level 1 (5 points)

Screen shot 2012-08-14 at 11.44.58 AM.png

I was in the middle of making a project and when i made a little edit to my movie, iMovie froze. I closed it

and when i re-opened it, it wouldn't play my movie. The red bar stays at the very begining of the movie and the screen is blank (as shown in the photo) and space bar does not play the video. It cannot be edited any further either. When i try to play it in full screen, the whole screen goes black and doesnt load the movie. Anything in the event library works just fine. Older projects play but only the audio, no video.

 

If anyone knows how to fix this bug or whatever it is, please comment and let me know. Things that didn't work;

  1. Restarting iMovie
  2. Restarting my macbook
  3. Mashing my keyboard ferociously

Also it is a very complex video (edit wise) and i do not want to redo it.

 

THANKS! - Wes


MacBook
  • wesley88 Level 1 Level 1 (5 points)

    Please help!

  • Bengt Wärleby Level 6 Level 6 (19,460 points)

    Hi

     

    When iMovie doesn't work as intended this can be due to a lot of reasons

     

    • iMovie Pref files got corrupted - trash it/they and iMovie makes new and error free one's

    • Creating a new User-Account and log into this - forces iMovie to create all pref. files new and error free

    • Event or Project got corrupted - try to make a copy and repair

    • a codec is used that doesn't work

    • problem in iMovie Cache folder - trash Cache.mov and Cache.plist

    • version miss match of QuickTime Player / iMovie / iDVD

    • preferences are wrong - Repair Preferences

    • other hard disk problem - Repair Hard Disk (Disk Util tool - but start Mac from ext HD or DVD)

    • External hard disks - MUST BE - Mac OS Extended (hfs) formatted to work with Video

    ( UNIX/DOS/FAT32/Mac OS Exchange - works for most other things - but not for Video )

    • USB-flash-memories do not work

    • Net-work connected hard disks - do not work

    • iPhoto Library got problems - let iPhoto select another one or repair it. Re-build this first then try to re-start iMovie.

    This You do by

    _ close iPhoto

    _ on start up of iPhoto - Keep {cmd and alt-keys down}

    _ now select all five options presented

    _ WAIT a long long time

     

    • free space on Start-Up (Mac OS) hard disk to low (<1Gb) - I never go under 25Gb free space for SD-Video (4-5 times more for HD)

    • external devices interferes - turn off Mac - disconnect all of them and - Start up again and re-try

    • GarageBand fix - start GB - play a few notes - Close it again and now try iMovie

    • Screen must be set to million-colors

    • Third-party plug-ins doesn't work OK

    • Run "Cache Out X", clear out all caches and restarts the Mac

    • Let Your Mac be turned on during one night. At about midnight there is a set of maintenance programs that runs and tidying up. This might help

    • Turn off Your Mac - and disconnect Mains - for about 20-30 minutes - at least this resets the FireWire port.

    • In QuickTime - DivX, 3ivx codec, Flip4Mac, Perian etc - might be problematic - temporarily move them out and re-try

    (I deleted the file "3ivxVideoCodec.component" located in Mac HD/Library/Quicktime and this resolved my issue.)

     

    buenrodri wrote

    I solved the problem by removing the file: 3ivxVideoCodec.component. after that, up-dated iMovie runs ok.

     

    Last resort: Trash all of iMovie and re-install it

     

    Yours Bengt W

  • Zebastian Larsson Level 1 Level 1 (0 points)

    Hello all. I'm not sure this thread is still open but I though't I'd leave my feedback.

    Just to explain I work for an Autorised Service Provider and I am usually the one that deals with software glitches here in my workshop.

     

    I just had a customers machine in with the following symptoms in iMovie.

    When first loaded iMovie will play what ever Project was open on load just fine. After swapping project playback stops completely. The red timeline indicator sometimes moves sometimes doesn't and audio is also intermittent.

     

    The solution for me was to quit iMovie and one by one move each project out from the ~/Movies/iMovie Project folder. Opening up and testing iMovie inbetween every move. After goinf through 3 out of 9 projects I found the culprit and iMovie now works fine every time.

     

    The customer in this case will unfortunetly have to re-create the project as adding it back causes iMovie to start missbehaving again. I should also point out that I didn't have to touch any of the media used for the project so re-importing data is not necessary.

     

    Hope this helps.

     

    Zeb

  • arigem1 Level 1 Level 1 (0 points)

    Hi everyone, I just spent several hours banging my head against this same issue (greyed out Project Library button, no playback, frozen red line, etc.). I'll share what worked for me, and it had nothing to do with iMovie itself.

     

    I have multiple large iPhoto collections and manage them as separate libraries using the iPhoto Library Manager app. I had most recently opened a library other than the one that contained the video clips in my iMovie project, therefore changing the default library that iMovie consulted when searching for the clips.

     

    Instead of a simple error message (which would have been nice), iMovie melted into utter buggyness. The good news is that as soon as I opened the correct library with iPhoto Library Manager and reopened iMovie, my projects were restored and everything worked fine.

     

    Hope that helps someone.

  • Teri-lee Level 1 Level 1 (0 points)

    Yeah I had the same thing: a red bar under my clips and a black video. After reading your response I just imported the clips into the iPhoto library and it worked immediately. I think dragging clips into a project instead of importing them creates the problem