4 Replies Latest reply: Sep 14, 2012 4:00 AM by TStam
TStam Level 1 Level 1 (75 points)

Have Caldigit Raid Card in 2008 mac pro with 4 internal drives, Raid 5. Works great, but have had problems with configuration software "Raid Shield" since Lion. Problems persist with ML. Each time I run the software, it works but displays an Error 3. It can be cleared but returns each 5 seconds or so. I've emailed Caldigit for a year now. They acknowledge the problem and say there's a fix coming, but it never comes. Version installed is 2.22, latest.

 

Anyone else with Caldigit have this problem? Has anyone been able to fix it?


Mac Pro, OS X Mountain Lion
  • FatMac>MacPro Level 4 Level 4 (3,640 points)

    I don't have their Raid Card, just their USB 3.0 card, but checking the CalDigit website in the Raid card software section, there's a note that says "For Mac OSX 10.7 (Lion) and 10.8 (Mt. Lion) users: You do not need to install any driver, Lion comes with built-in driver to support CalDigit RAID controllers." Perhaps the 2.2.2 drivers installed are conflicting with what they say is built in. Have you tried uninstalling their drivers?

  • TStam Level 1 Level 1 (75 points)

    Thank you. You are correct about the built in drivers. My understanding is that those are just to allow the card/raid to function. The drivers do not allow for any manipulation or control of the raid or any alarms. That's what the Raid Shield is for. If you uninstall the Raid Shield, you cannot see or manipulate the card or raid set, install firmware, or change settings at all, while it will function fine as a drive under Lion or ML. I have uninstalled it and the raid works fine but I can't control it or see the details if I have to which leaves me uncomfortable.

     

    Raid Shield does function.................you just have to clear the error, do what you want quickly, and execute before the error comes back or you just have to clear it again.

     

    Frustrating.

  • FatMac>MacPro Level 4 Level 4 (3,640 points)

    TStam wrote:


    ...Frustrating.

    It is indeed and I'm surprised because after struggling for 1.5 years with a Sonnet USB 3.0 card, the CalDigit card worked first time, every time in Snow Leopard, Lion and Mountain Lion without a hassle.

     

    The Raid Shield sounds like an application rather than a driver. Is it possible to identify the drivers 2.2.2 installs and delete them, leaving the Raid Shield in place? For the USB 3.0 card the drivers get placed in /System/Library/Extensions/ and have a CalDigit name. The receipts go in /private/var/db/receipts

  • TStam Level 1 Level 1 (75 points)

    Problem solved. Wrote to Caldigit again. They told me to install 2.2.2 again. I ran the separate uninstaller application then reinstalled 2.2.2 Raid Shield. It worked. No more error 3. I am not sure why this fixed it, because this is the same version as I had previously installed.